Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

BPSeries Party AI Goes WeiDu!

horredtheplaguehorredtheplague Member, Developer Posts: 178
Now that I've got the scripts at least mostly smoothed away, I went ahead and tackled a WeiDu version for you all. This version adds dialog strings to your dialog.tlk file, so you'll have to have your TLK of choice placed in your BGEE/Data/00766 folder before installing. If you've used some of the other mods already, you'll have done this already and can skip it. The scripts will have proper descriptions in-game, instead of the sometimes-confusing BGEE receycled strings in the non-weidu version. This also adds entries to your SCRPDESC.2da file. What this does is allow you to see detailed entries for BPSeries scripts when you open the Customize-->Scripts GUI page.

So far, there's translations for French, German, Italian, and Russian. (For some reason the BPSeries text for Spanish in the old BPv181 file was in English *sigh*) More translations welcome!

If you see any weirdness or encounter any difficulties installing, let me know.

You can find the filepack over at Spellhold Studios, in the Big Picture forum, under the same name as this thread.

«1345

Comments

  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    Just Added: New version with the Detectable Stats package (now required for the scripts). Natrally, the scripts take full advantage of the addition. I also added back in a lot of missing ToB identifier rows, in various IDS files. Plus, a few very common modder additions.

    For those who have no clue what Detectable Stats does--it allows you to detect various spell states on yourself OR others, that you never could have detected before. It adds the info to both IDS files and to relevant spells and items. This in turn allows you to use the most intelligent/accurate choices in targetting blocks--so spells aren't a second-guess. Like this example from Spellstrike (which dispels many different types of buffs):
    OR(12)
    Specifics(LastSeenBy(Myself),HAS_SHIELDS)
    Specifics(LastSeenBy(Myself),NEEDS_BREACH)
    CheckStatGT(LastSeenBy(Myself),0,STONESKINS)
    CheckStatGT(LastSeenBy(Myself),0,SHIELDGLOBE)
    CheckStatGT(LastSeenBy(Myself),0,MINORGLOBE)
    CheckStatGT(LastSeenBy(Myself),0,WIZARD_SPELL_DEFLECTION)
    CheckStatGT(LastSeenBy(Myself),0,WIZARD_PROTECTION_FROM_MAGIC_WEAPONS)
    CheckStatGT(LastSeenBy(Myself),0,WIZARD_SPELL_TURNING)
    CheckStatGT(LastSeenBy(Myself),1,WIZARD_SPELL_IMMUNITY)
    CheckStatGT(LastSeenBy(Myself),1,WIZARD_SPELL_TRAP)
    CheckStatGT(LastSeenBy(Myself),0,WIZARD_SPELL_SHIELD)
    CheckStatGT(LastSeenBy(Myself),0,WIZARD_PROTECTION_FROM_NORMAL_WEAPONS)

    This covers just about anything a Spellstrike can dispel, so you cast wisely. Only 3 of the above choices are available in the vanilla game, even BG2:ToB (the least useful 3 for this spell).

    Modders, feel free to use the DS package from inside this mod. I did have to make a couple changes to get it to work with BGEE, and this will give you a stable place to start at.


    Latest BPSeries v.1010 package available on Spellhold Studios. Don't hesitate to grab this version as I'm through updating until I get some feedback/bug reports (I promise, this time!).

  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    The latest version of the BP Series is now available, in the Spellhold Studios Download section for BGEE (v0.2015). Huge changes and feature additions this time around, and five new scripts for even better specialization and streamlining. You can read all about it in the Big Picture forums at SHS.

  • KazugaKazuga Member Posts: 38
    edited December 2012
    better u post the link ;) http://www.shsforums.net/topic/55595-bp-series-for-bgee-goes-weidu/

    Thank u, amazing !

    i have missing string @ every script :/

    Artur
  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    Kazuga said:

    better u post the link ;) i have missing string @ every script :/

    @Kazuga, thanks for posting the link. As for the missing strings, there's a certain procedure for using weidu mods right now, that requires some manual input. Nothing too bad--you just have to copy/paste the modified dialog.tlk file into your lang/(%language%) folder. This step will hopefully be removed when weidu is updated next, but since the folder structure of BGEE is far different than BG2:ToB, it's to be expected.

    Kazuga
  • KazugaKazuga Member Posts: 38
    ah thank you, its working =), but little translate mistakes. (for German) and some scrips are in englisch :/

  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    Kazuga said:

    ah thank you, its working =), but little translate mistakes. (for German) and some scrips are in englisch :/

    Glad you got it to work. Hopefully a new weidu version will come out soon and solve the little issues.

    I'm looking for volunteers to assist with that (and other) translation(s), if you know of (or resemble) any such person. :)

  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    And a new version is out! Grab it at: http://www.shsforums.net/files/file/1025-bp-series-party-ai-scripts-for-bgee-and-bg2tobbgt/ Lots of changes, fixes and updates. Version 0.3024 is the first version to support both BGEE and BG2:Tob (w/ or w/o BGT). I'm sure it can handle more, but in this version no scripting support is offered for any mod added/altered content. This support will surely come back in future versions of the package, but I wish to solidify the core foundations first before building upon them. Details on the download page, in the readme file, and on the BP forums at SHS.

    Enjoy!
    And Merry Christmas!
    --Horred the Plague

  • TomeTome Member Posts: 466
    edited December 2012
    Thanks for all the work, but the new download doesn't work-zip is 'invalid'. Have downloaded twice to double check.

  • RigowenRigowen Member Posts: 10
    Tome, you might want to try a program like 7-zip. On Windows 8 I had the same issue with th ebuilt in zip compression/unzip features, but 7-zip did the trick.

  • RigowenRigowen Member Posts: 10
    edited December 2012
    Can anyone tell me how spell triggers are setup or work? I think I have everything installed correctly or at least I can see the new scripts (I previously was using the non-weidu version). I set my pure mage to use the BP-Mage script, but nothing happens when i hit "f", "v" or "n". is this a BGII feature or am I missing something?

    Edit: It looks like these are high level spells and or items that allow the combination of multiple spells.

    Post edited by Rigowen on
  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    Rigowen said:

    Can anyone tell me how spell triggers are setup or work? I think I have everything installed correctly or at least I can see the new scripts (I previously was using the non-weidu version). I set my pure mage to use the BP-Mage script, but nothing happens when i hit "f", "v" or "n". is this a BGII feature or am I missing something?

    Edit: It looks like these are high level spells and or items that allow the combination of multiple spells.

    Yes, this is support for spells like Spell Trigger, Spell Sequencer, Contingency, etc. Most of it higher level than BGEE might need, but the minor spell sequencer is within reach I guess. Honestly, it's code I left in from the old eSeries from years back, and never gave it much of a proper testing (not much of a spell trigger user myself, i guess?).

  • mlnevesemlnevese Member, Moderator Posts: 9,537
    edited December 2012
    @horredtheplague Just installed the latest version (0.3029) and I have found a bug. Rassad carries a Wakizashi +1 that becomes unremovable if BP Series is installed.

    I looked at it with NI and noticed the version placed by BPSeries in override lacks the dropable, displayable, not copyable and magic flags. Setting them seems to fix the problem.

    It's the sw1h47.itm.

    The Katana +1 and +2 also lack the flags sw1h44.itm and sw1h55.itm.

    Post edited by mlnevese on
  • KazugaKazuga Member Posts: 38
    thx for the update ! Love it !

  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    @mlnevese : Thanks for the bug report. It was the second I got on it tonight, and sure enough my code for adding the magical flag was completely buggered. It was several items, not just that wakizashi...For now I just removed the ugly code; I still set the enchanment levels though. I'll have to figure out how to properly play with those bitwise operators in weidu before I make another attempt. Maybe I'll get lucky and Beamdog will fix it properly first. :)

    Updated to v0.3030, to fix this problem (I tested files in editor, it seems to have done what was needed).

    @Kazuga Thank you! Glad you're enjoying the work. :)

    mlnevese
  • DarkersunDarkersun Member Posts: 397
    Hello, I have a question about this mod.
    Will it only add scripts for my party or will the enemy AI changed as well ?

  • mlnevesemlnevese Member, Moderator Posts: 9,537
    edited February 2013
  • KunikosKunikos Member Posts: 12
    Thanks so much for this mod. Would you consider a script for the Monk class? It doesn't seem to work well with any of the provided ones. The built-in game AI scripts have one for Thief Aggressive that at least uses stealth, but it would be nice to be able to toggle detect trap mode and have the character use stunning blow, quivering palm, etc.

  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    Kunikos said:

    Thanks so much for this mod. Would you consider a script for the Monk class? It doesn't seem to work well with any of the provided ones. The built-in game AI scripts have one for Thief Aggressive that at least uses stealth, but it would be nice to be able to toggle detect trap mode and have the character use stunning blow, quivering palm, etc.

    BP-PUREF is the closest I have to a monk script; it doesn't have the traps toggle but it has the monk special attacks like quivering palm and stunning blow in place. I'll definitely consider it--this is the first request for one. I'll also need to take into account other special abilities like immunity to poison/disease, self-healing, et al. Furthermore, their enhanced movement rate and higher dependence on melee/unarmed attacks should be accounted for in their decision-making strategic processes.

  • KeryvianKeryvian Member Posts: 14
    I second both the thanks and the request for a monk-specific script.

  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    edited February 2013
    Ok, I've worked out a BGEE prototype of a monk script. Very little testing, still needs a BG2 version before I can release. Some of the highlights:

    --Support for Monk Special Attacks Stunning Blow and Quivering Palm. I lowered the "threat level", requirements and gave an option that will allow these to be used against even a single opponent of 'sufficient' hit points (formerly only used in group encounters of 5 or more). Sufficient Hit Pts: Stun Blow: 26+, Quivering Palm: 41+
    --No melee/ranged toggle or weapon switching support. This is mandatory as there's no scripting way to Equip [My Fists] nor to UnEquip[My Bow or Sword]--short of weapon self-destruction. You'll have to handle any weapon usage/switching on your own end, my regrets. Unless you'd like your own little "iron crisis", every time you need to clench your monk's fists? (My guess is "no")
    --However, since this deficiency gave us an extra hotkey opening, I added a seperate toggle for both Stealth and Find Traps. Now you can do one, the other, or both (or none) at the same time as you choose. If the idea catches, maybe I'll squeeze it into a couple of the thief scripts for you (scripts where I can fit it in).
    --A monk script exclusive: Near/Far Opponent Targetting Toggle. This is more a preference than a mandate; the monk will opt for attacking opponents close by, or ones far away, at a flip of the switch. This should allow you to have that "archer-hunter" e.g., which many people already use monks for due to their speed bonuses. Shouts from party members in need, or immediate attackers of the monk, still take targetting preference. But these could possibly be archers attacking them anyways? :)


    Besides this, I'm doing another cleanup on the backstabbing code. Because of the bug with dialogs et. al. giving false combat readings from the engine, causing thieves to sometimes backstab innocent victims and other havoc--I included another check. If the backstabber doesn't Detect a NearestEnemy(), they will not backstab. I can already see a potential loophole or 3--such as when the fiend goes hostile after his rage speech, the thief backstabs the fiend's butler instead of the fiend--but let's see how it goes. Hopefully a step forward, in the least.

    Should have something public within a few days, maybe sooner.

    Kunikos
  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    v 0.3040 is uploaded to Spellhold Studios Download section. Including the all-new monk script. It has all the features above, tested and appearing to be working (even did a few combats w/ the near/far toggle on--it 'seems to' work like on the label). The seperate stealth/find traps toggles are my personal favorite--they may find their way into thief scripts yet. :)

    mlnevese
  • ShadowSmugglerShadowSmuggler Member Posts: 44
    I posted this over at SHS.. but the monk script is missing a string. Also, this was a bug with the 3034 version but imoen with the thief script didn't like commoners sitting and drinking, or officer vai.. she backstabbed them whenever she got the chance. Hoping the 3040 version fixes that. (my reputation is 18+)

  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    edited February 2013
    That's very weird about the commoners/Vai. Adding extra conditions makes it LESS likely for an event to happen, not more common. I didn't see a post at SHS. This was BG:EE that it happened in? What exactly were you doing with the party? Just standing? Talking with somebody? Any info you can remember will be helpful.

    Please keep in mind that I'm trying to beat an engine bug here, my scripting without the bug is more than sufficient. We never saw a problem of this magnitude happening in years of BG2-only with these scripts. It happened, but very rarely. I've been hoping for several versions that it's been beat. Only surefire way is to not allowed any scripted backstabbing at all until the engine bugs are addressed.

    EDIT: Just saw this was a prior-version bug. Let me know if the new version works better.

    In v0.3040: Any ideas what string was missing? In general of course, not the exact string.

  • ShadowSmugglerShadowSmuggler Member Posts: 44
    I'm just guessing it's the monk script. When you go to customize and select the script for the monk, instead of telling you it's the monk it just says missing string.

    Also the new version seems to have solved that little backstab bug. Let's see the commoner, I was talking with perdue to give his sword back and after I was done -poof- imoen felt the commoner grabbed her ass and decided death was a good response. After a reload I kept imoen by the door so there wouldn't be a repeat. I then went to visit officer Vai and after the conversation with Vai.. Imoen thought vai grabbed her ass too and decided a knife in the back would be funny. So far it has not replicated itself with the 3040 version.

  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    Good to hear the backstab bug appears mostly beaten. Which language was the problem in? Are you 100% sure your dialog.tlk file was updated properly between versions? I just checked English, German and Italian, and the description strings for BP-Monk script were intact in the language files and library code. So they were appearing fine in-game, in my two test installs---BG2 and BG:EE.

    I did find a couple missing stings in the actual scripts though. Stunning Blow and Quivering Palm were still using their BG2 ref's, so I'll have them corrected in v 0.3041. It should be out this weekend, with a couple of translation updates as well (French and Spanish).

  • KunikosKunikos Member Posts: 12
    So, latest update #7 adds two new monk kits-- Dark Moon Monk and Sun Soul Monk -- make sure to test whether Lay on Hands, Stunning Blow, or Quivering Palm exist, because these kits remove them and add other abilities. I don't think you can really support both BG2 and BG:EE while adding those kits until BG2:EE comes out.

  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    edited February 2013
    Kunikos said:

    So, latest update #7 adds two new monk kits-- Dark Moon Monk and Sun Soul Monk -- make sure to test whether Lay on Hands, Stunning Blow, or Quivering Palm exist, because these kits remove them and add other abilities. I don't think you can really support both BG2 and BG:EE while adding those kits until BG2:EE comes out.

    I beg to differ. I already checked this, months back.

    SPCL811, SPCL815 and SPCL820 exist in BGEE as well as BG2. BGEE has all the stock monk abilities, not just the player-cast "spells", in complete form. The BGEE additions boast a new Monk party member after all, so this is only logical. Whether the player will make a high enough level to use these additions in BGEE is arbitrary, but including them anyways won't hurt anything.

    If the kits that are added add new specialty kit spells, adding them to the scripts is also a simple addition (depending on the complexity of the additions, and how it translates into IE scripting code).


    But this did bring one thing to my attention, @Kunikos: I forgot to keep the warrior HLA's intact on the BG2 side. I'll get those in place with next update, as well as try to address these new BGEE kits.


    EDIT: I just took a cursory look through all the added kit spells in update 2014. These should be quite possible to script out; at first glance I don't think any of them will require a new script to add. Just some work, on my end.

    Post edited by horredtheplague on
    mars0124mlnevese
  • mlnevesemlnevese Member, Moderator Posts: 9,537
    And the scripts will probably need no changes for BG2EE unless they change the monk's HLAs.

  • horredtheplaguehorredtheplague Member, Developer Posts: 178
    To answer the debate, I have a new version available at SHS. This version accounts for all the kits in BGEE update 2014 (#7). No in-game testing yet, but 90%+ of the code was based on existing code (similar spells). Should be good to go.

    It also adds the HLA's back into BG2 for monks.

    Last but not least, it added more Stealth/Find Traps toggle support to both games' scripts. Several hotkeys were switched around as a result. Details in (updated) read-me file and in-game (English only for now, others soon). Enjoy!

    mlnevese
Sign In or Register to comment.