Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Planescape: Torment: Enhanced Edition has been released! Visit to purchase and check for details. Planescape: Torment: Enhanced Edition Official Soundtrack is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[Known 7036] Aerie/Circus Tent Bug

KaartusKaartus Member Posts: 3
edited September 2014 in BGII:EE Bugs (v1.2.2030)
Hey there i've been experiencing a strange bug that occurred when I entered the sewers via the Copper Coronet. After killing the Kobolds, Hobgoblins, etc and talking with the charmed man and his strange friend I went upstairs and ran into the slavers.

Quickly I ran back downstairs baiting them into a more easy battle and upon winning looted their bodies. I noticed that the game was beginning to lag, with no other programs running I quickly saved and upon hitting 'save' the game crashed.

I reloaded the file - to my surprise it worked, but now the hobgoblins were back. Cool, more free loot. I killed them and then realised the entire dungeon was as if I had never explored it in the first place. The slavers were back upstairs, and so on.

I left the sewers, killed the slavers, freed the slaved and exited via the building unattached to the Copper Coronet - only to be greeted by the Chapter 2 NPC offering to help me rescue Imogen for 20,000gp. I even get the cut-scene.

So now i'm living in a time warp, which would be fine - I seem to be able to progress (somewhat) except for the Aerie companion quest. Her uncle requests her presence in the circus tent. When I get there the guard recognises i've fixed the Circus tent quest and gives me another +1 Rep (score!) so I carefully don't save (just quick-save) and go in. Everything has reset - except for Aerie the NPC (she doesn't show up so the Orge Sword is now just an item) and when I go to confront Kalash the Illusionist I get no dialogue (in fact he welcomes me - ad infinitum and uncle whatsisface tells me i'm an idiot ad nauseum). So I can't get out nor continue the Aerie quest line.

I'm sure there is probably a work around, but I don't know it and it seems that the game assumes I am in Chapter 3 now because the Irenicus dreams keep coming, even though other parts of the game think i've only just arrived for the first time.

Otherwise, love the game guys it feels amazing to be playing BGII again :).
Post edited by Gate70 on


Sign In or Register to comment.