Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[Tool] Big World Setup (BWS): Mod Manager for Baldur's Gate / Enhanced Edition (Trilogy) for Windows

1293032343540

Comments

  • bearcattonybearcattony Member Posts: 17
    When will BWS update their compatible mods since the IWDEE 2.5 patch just came out? It is a major facelift of the game.

  • BleibeidlBleibeidl Member Posts: 1
    The config file name changed from Baldur.ini to Baldur.lua

    Quick and dirty fix:
    Open this file in a text editor (with line numbering enabled):
    BigWorldSetup-master\App\Includes\09_Install.au3

    change line 954 from
    If $p_Version=3 Then $MyIni=@MyDocumentsDir&;"\IceWind Dale - Enhanced Edition\Baldur.ini"
    to
    If $p_Version=3 Then $MyIni=@MyDocumentsDir&;"\IceWind Dale - Enhanced Edition\Baldur.lua"

    Make the file Read-Only (maybe launching BWS with the no-autoupdate VBS is sufficient, didn't test).

    I have tested installation of the BWS "Recommended" modset and everything installed smoothly.
    There might still be bugs ingame, though.

    Cheers,
    Blei

    Wise_Grimwaldbearcattony
  • bearcattonybearcattony Member Posts: 17
    It worked. Thanks Blei. Put this fix on the IWDEE mod board until Alienquake fixes it himself.

  • BloodstoneBloodstone Member Posts: 76
    Quick question. I am working on an EET Install. When I'm doing a "recommended" install and I get down to the Tactical Section, SCS is a green font, but many of it's components are orange/yellow and not checked off by default. Is there a difference between the green and orange? I'm confused because I was thinking if it's green it should be ok, or is this just letting me know that if I select those particular options that I could have a conflict or a dependency that I have to address?

    Not trying to sound stupid, just trying to better understand so this install is smoother. I was thinking as long as I stayed away from any "red" components I would be ok, with maybe having to just take care of conflicts. Thanks.

  • hackinslashhackinslash Member Posts: 45
    Green is the recommended/easy game play option. Orange/Yellow brings more tactical selections to the table(possible harder game play).

    Wise_Grimwald
  • KennisKennis Member Posts: 113
    Is anyone working on IWD in EET now that the 2.5 update is here? I’d love to play with my team all the way through.

    Mantis37
  • SpodacusSpodacus Member Posts: 7
    Hey guys. Got BGEE and BGIIEE with SoD and was wondering why the install keeps saying it can't locate my ToB files. I have steam

  • jasteyjastey Member Posts: 1,135
    Interesting. I have SoD from BeamDog and I never get this message with BWS. At which point does this error message show?
    Maybe you need to run modmerge before using your SoD install for EET, too (I'm not sure, though)?

  • Wise_GrimwaldWise_Grimwald Member Posts: 2,248
    I had a similar problem with my installation. My installation is with Gog and ToB is automatically installed with SoA. However when it came to installing two mods it said that ToB wasn't installed. One was the Mazzy Friendship mod

    ##### Mazzy Friendship #####
    ### 0000: Mazzy Friendship ###
    Ready for installation
    Setup-mazzy.exe --no-exit-pause --noautoupdate --language 0 --skip-at-view --force-install-list 0 --logapp
    [Setup-mazzy.exe] WeiDU version 24500
    Using Language [English]

    Using .\lang\en_us\dialog.tlk

    SKIPPING: [Mazzy Friendship]
    ToB is not installed! Please install the Throne of Bhaal expansion before installing the Mazzy friendship.

    F:\Baldur's Gate - EE\Baldur's Gate II - Enhanced Edition>
    ToB is not installed! Please install the Throne of Bhaal expansion before installing the Mazzy friendship.
    Mazzy Friendship (Mazzy Friendship) was skipped.

    If a component was skipped during the install, this indicates a conflict or dependency that's still missing in the BWS. Either a similar component is already installed and thus this message is harmless, or the component depends on a mod that's missing. If you don't want to continue after your analysis, you can stop the Big World Setup now and resume from this point later.
    Enter [c]ontinue or [e].
    [c]
    Removing mazzy #0

    The other mod was as below:

    F:\Baldur's Gate - EE\Baldur's Gate II - Enhanced Edition>Extended NPC-NPC Interaction SoA (IEP Extended Banters) was installed successfully.

    ToB is not installed! Please install the Throne of Bhaal expansion before installing the extended ToB Minsc/Aerie interaction.
    Extended Minsc/Aerie Interaction ToB (IEP Extended Banters) was skipped.

    If a component was skipped during the install, this indicates a conflict or dependency that's still missing in the BWS. Either a similar component is already installed and thus this message is harmless, or the component depends on a mod that's missing. If you don't want to continue after your analysis, you can stop the Big World Setup now and resume from this point later.
    Enter [c]ontinue or [e].
    [c]
    Removing iepbanters #1

    ToB is not installed! Please install the Throne of Bhaal expansion before installing this minimod.
    Imoen "Retrospection" dialogue for BGII: ToB (IEP Extended Banters) was skipped.

  • jasteyjastey Member Posts: 1,135
    Thank you for the report. It's possible BWS doesn't download the newest versions of the Banter Mods yet.

    Wise_Grimwald
  • NinoganNinogan Member Posts: 3
    Just installed this and I'm super excited to get BG2EE a spin with some nice mods but I get the following error during installation:

    * BiG World Textpack: The Mod itself (BiG World Textpack v17 ENGLISH.7z)
    http://www.shsforums.net/files/download/979-big-world-textpack-english/
    * BiG World Textpack: Translations and sounds (BiG World Textpack v17 ENGLISH.7z)
    http://www.shsforums.net/files/download/979-big-world-textpack-english/

    Is this known and just temporary downtime or something because it seems I need these to install the mods I want.

  • jasteyjastey Member Posts: 1,135
    SHS and with it G3 (same server) are down atm. Let's hope it's one of the various blackouts that will be over quickly.

    Ninogan
  • NinoganNinogan Member Posts: 3
    jastey said:

    SHS and with it G3 (same server) are down atm. Let's hope it's one of the various blackouts that will be over quickly.

    Gotcha, thanks for letting me know. Hope it is resolved soon. I haven't played BG2 in years so I am super stoked to get into it again :D

    Wise_Grimwald
  • Wise_GrimwaldWise_Grimwald Member Posts: 2,248
    Google was down recently. That could have been part of the problem.

  • NinoganNinogan Member Posts: 3
    It's still down. Does anyone know if the big world textpack thingy is available anywhere else too?

  • AstroBryGuyAstroBryGuy Member Posts: 3,414
    G3 and SHS should be back up in a day or so.

    https://forums.beamdog.com/discussion/comment/981404/#Comment_981404

    Heard back from the admins of these sites:

    "We know! The host went down, should be up in a day or so.
    Thanks "

    Wise_GrimwaldNinogan
  • jasteyjastey Member Posts: 1,135
    @Ninogan Which mods are the ones you need the textpack for? Some were updated recently and no longer need it, e.g. Ascalon's Questpack and Hidden Adventures. (Also, Jarl's Adventure Pack, but that's for BGT, only).

  • prouddadx3prouddadx3 Member Posts: 4
    My daughter and I were wanting to use the Big World Setup to add mods to our games but since the servers are down we are unable to get some of the links to work. We were wondering if anyone knew how to get the following mods. Thank you in advance!
    BiG World Installpack
    BiG World Textpack
    BiG World Textpack
    Gavin NPC
    Valerie NPC
    Isra NPC
    Neera Expansion for BG:EE
    Innershade
    The White Queen
    I Shall Never Forget
    Eilistraee's Song
    Gavin NPC for BG2:ToB
    Isra BG2 NPC
    IEP Extended Banters
    Lucy the Wyvern
    Alternatives
    Rogue Rebalancing
    Wizard Slayer Rebalancing
    Sword Coast Stratagems
    aTweaks
    klatu Tweaks and Fixes
    Worldmap

  • SpodacusSpodacus Member Posts: 7
    edited May 2018
    Alright. My ToB content is installing now

  • SpodacusSpodacus Member Posts: 7
    Yeah, i can't download Big World Textpack right now

  • MonoCanallaMonoCanalla Member Posts: 291
    Can something be installed manually AFTER installing the whole BWS, EET thing?

    I wan thinking in The Sellswords, a quest mod that doesn’t change the world map. Would installing it then break something?

  • Wise_GrimwaldWise_Grimwald Member Posts: 2,248

    Can something be installed manually AFTER installing the whole BWS, EET thing?
    I wan thinking in The Sellswords, a quest mod that doesn’t change the world map. Would installing it then break something?

    I think that you can so long as biffing has not been done. Others may know better.

  • MonoCanallaMonoCanalla Member Posts: 291

    Can something be installed manually AFTER installing the whole BWS, EET thing?
    I wan thinking in The Sellswords, a quest mod that doesn’t change the world map. Would installing it then break something?

    I think that you can so long as biffing has not been done. Others may know better.
    Sorry, what is biffing. I googled it, but still I don't know what it means in this context.

  • ThelsThels Member Posts: 1,309
    It gathers all the files in your override folder, and combines them into a single .bif archive.

    Used to be important back in the day, as having tons of files in there would cause the game to lag. Nowadays with the EE versions, it shouldn't be needed.

    Fulsom2121
  • hackinslashhackinslash Member Posts: 45
    EET doesn't use the Generalised Biffing so you'd need to uninstall EET End and install the mod, run EET End again. Can't promise smooth gameplay doing it this way. I'd just start my install over again.....

  • MonoCanallaMonoCanalla Member Posts: 291
    Thanks. Now my problem is with portraits. I don’t know what portrait mods I installed, but just started a game and Imoen has an horrendous portrait. It was a terrible selection of portraits too in the character creation. I saved a copy of my old portraits folder and pasted the files in every portraits folder I could find around. And yet nothing. Even in EE Keeper it allows me only to use portraits from who knows where, but not my collection. Custom Portrait within my game looks like is from the Baldurs Gage EET folder in Documents, but is not losing the files I posted there either. I wonder what should I do with this.

  • BloodstoneBloodstone Member Posts: 76

    Thanks. Now my problem is with portraits. I don’t know what portrait mods I installed, but just started a game and Imoen has an horrendous portrait. It was a terrible selection of portraits too in the character creation. I saved a copy of my old portraits folder and pasted the files in every portraits folder I could find around. And yet nothing. Even in EE Keeper it allows me only to use portraits from who knows where, but not my collection. Custom Portrait within my game looks like is from the Baldurs Gage EET folder in Documents, but is not losing the files I posted there either. I wonder what should I do with this.

    I believe most mods, especially EET, put portraits into the override folder instead of a separate portraits folder like we used to. I had this same problem and then copied my custom portrait folder into the overide folder and everything showed up. I just streamlined it so it wasn't to overly large. Hope that helps

    Wise_Grimwald
  • SpodacusSpodacus Member Posts: 7
    edited June 2018
    Hey, guys, I am having a problem where my installer won't move past installing a list of components for IEP extended banters. I could try not installing it, but that would suck. Plus it says the mod installed successfully, just this won't pass.

  • MonoCanallaMonoCanalla Member Posts: 291
    Spodacus said:

    Hey, guys, I am having a problem where my installer won't move past installing a list of components for IEP extended banters. I could try not installing it, but that would suck. Plus it says the mod installed successfully, just this won't pass.

    Open debug. At the very bottom it might display a message you don’t see in the dialogue box. Most likely you’ll have to take a decision about a mod (like Sirene’s choice of portrait), or it might be telling you a mod is missing, so you’d have to manually download it and extract it before continuing.

    Spodacus
  • Fulsom2121Fulsom2121 Member Posts: 25
    edited June 2018
    @Spodacus
    BWS window sometimes is too small to display full left part of window. Switch full screen and you see all.

Sign In or Register to comment.