Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

There's currently a forum problem with avatars not showing in reactions.
Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[Linux] converting Bink (bik) to Webm (wbm)

TrustrygTrustryg Member Posts: 5
After reading the thread "Can anyone suggest a good free bink to webm converter?" I tried to convert one of my Bink files (Dreamcatcher1.bik) with the installed ffmpeg 2.8.14 and the suggested
ffmpeg -i INPUT_FILE.bik -c:v libvpx -b:v 1M -c:a libvorbis -f webm OUTPUT_FILE.wbmbut NWN-EE refused to load it. After inspecting the working beamdog.wbm I tried to use the same audio rate of 48000 instead of the original 44100 and a video rate of 30 instead of 15, but still to no avail. mplayer can play both without problems. Does anybody have an idea what NWN-EE doesn't like?

To give some details about the converted Dreamcatcher1.wbm I'll add the output of "mplayer -identify":
Playing Dreamcatcher1.wbm. libavformat version 56.40.101 (external) libavformat file format detected. ID_VIDEO_ID=0 [lavf] stream 0: video (vp8), -vid 0 ID_AUDIO_ID=0 [lavf] stream 1: audio (vorbis), -aid 0 VIDEO: [VP80] 800x600 0bpp 30.000 fps 0.0 kbps ( 0.0 kbyte/s) Clip info: encoder: Lavf56.40.101 ID_CLIP_INFO_NAME0=encoder ID_CLIP_INFO_VALUE0=Lavf56.40.101 ID_CLIP_INFO_N=1 Load subtitles in ./ ID_FILENAME=Dreamcatcher1.wbm ID_DEMUXER=lavfpref ID_VIDEO_FORMAT=VP80 ID_VIDEO_BITRATE=0 ID_VIDEO_WIDTH=800 ID_VIDEO_HEIGHT=600 ID_VIDEO_FPS=30.000 ID_VIDEO_ASPECT=0.0000 ID_AUDIO_FORMAT=22127 ID_AUDIO_BITRATE=0 ID_AUDIO_RATE=48000 ID_AUDIO_NCH=2 ID_START_TIME=0.00 ID_LENGTH=12.06 ID_SEEKABLE=1 ID_CHAPTERS=0 ========================================================================== Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family libavcodec version 56.60.100 (external) Selected video codec: [ffvp8] vfm: ffmpeg (FFmpeg VP8) ========================================================================== ID_VIDEO_CODEC=ffvp8 ========================================================================== Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders AUDIO: 48000 Hz, 2 ch, floatle, 0.0 kbit/0.00% (ratio: 0->384000) ID_AUDIO_BITRATE=0 ID_AUDIO_RATE=48000 ID_AUDIO_NCH=2 Selected audio codec: [ffvorbis] afm: ffmpeg (FFmpeg Vorbis) ========================================================================== AO: [pulse] 48000Hz 2ch floatle (4 bytes per sample) ID_AUDIO_CODEC=ffvorbis Starting playback... Movie-Aspect is 1.33:1 - prescaling to correct movie aspect. ID_VIDEO_ASPECT=1.3333 VO: [vdpau] 800x600 => 800x600 Planar YV12
For me that looks similar enough to the output for beamdog.wbm, but apparently I'm missing something:
Playing /home/nwn/lib/beamdog/00785/data/mov/beamdog.wbm. libavformat version 56.40.101 (external) libavformat file format detected. ID_VIDEO_ID=0 [lavf] stream 0: video (vp8), -vid 0 ID_AUDIO_ID=0 [lavf] stream 1: audio (vorbis), -aid 0 VIDEO: [VP80] 660x600 0bpp 29.970 fps 0.0 kbps ( 0.0 kbyte/s) Clip info: encoder: Lavf56.37.100 ID_CLIP_INFO_NAME0=encoder ID_CLIP_INFO_VALUE0=Lavf56.37.100 ID_CLIP_INFO_N=1 Load subtitles in /home/nwn/lib/beamdog/00785/data/mov/ ID_FILENAME=/home/nwn/lib/beamdog/00785/data/mov/beamdog.wbm ID_DEMUXER=lavfpref ID_VIDEO_FORMAT=VP80 ID_VIDEO_BITRATE=0 ID_VIDEO_WIDTH=660 ID_VIDEO_HEIGHT=600 ID_VIDEO_FPS=29.970 ID_VIDEO_ASPECT=0.0000 ID_AUDIO_FORMAT=22127 ID_AUDIO_BITRATE=0 ID_AUDIO_RATE=48000 ID_AUDIO_NCH=2 ID_START_TIME=0.00 ID_LENGTH=5.24 ID_SEEKABLE=1 ID_CHAPTERS=0 ========================================================================== Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family libavcodec version 56.60.100 (external) Selected video codec: [ffvp8] vfm: ffmpeg (FFmpeg VP8) ========================================================================== ID_VIDEO_CODEC=ffvp8 ========================================================================== Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders AUDIO: 48000 Hz, 2 ch, floatle, 0.0 kbit/0.00% (ratio: 0->384000) ID_AUDIO_BITRATE=0 ID_AUDIO_RATE=48000 ID_AUDIO_NCH=2 Selected audio codec: [ffvorbis] afm: ffmpeg (FFmpeg Vorbis) ========================================================================== AO: [pulse] 48000Hz 2ch floatle (4 bytes per sample) ID_AUDIO_CODEC=ffvorbis Starting playback... Movie-Aspect is 1.10:1 - prescaling to correct movie aspect. ID_VIDEO_ASPECT=1.1000 VO: [vdpau] 660x600 => 660x600 Planar YV12
Might it be the movie aspect? Does anybody has an idea, what else to try?

Regards, Trustryg

JuliusBorisov

Comments

Sign In or Register to comment.