Default Avatar

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Badges

10 CommentsName DropperFirst Comment
Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

leo

About

Username
leo
Joined
Visits
13
Last Active
Roles
Member
Points
12
Badges
3
Posts
10

Comments

  • Is a text still readable in this resolution?
  • Yay! We got in Canada! Just bought it on my 5.1.1 Ipad3, downloading :P
  • it takes so long can't wait that patch already
  • @Aosaw, Does it make sense to keep this kind of people on this forum? I vote for ban.
  • Great news, thanks for specifying, guys!
    in Again 5.1.1 Comment by leo January 2013
  • @leo don't worry about @akura's (pleas be careful of your posts because to some people they may sound offensive Honestly, I wasn't trying to be insulting to any person here, it's just an explanation of my position. I mean using of my iPad. I just …
    in Again 5.1.1 Comment by leo January 2013
  • I've had zero problems on a 4th gen iPad, but I always wear my reading glasses. And my microscope lol. Completely agreed witch comment about adjustable text.
  • 2akura, well It's not worth for me. honestly, I really want to play BG, but if I have to choose between usability of my device and ANY game, I will choose usability.
    in Again 5.1.1 Comment by leo January 2013
  • Yeah, right, they wrote about it in a pinned thread, but also they wrote about possible supporting of 5.1.1 that can come out soon with some of future patches or something.
    in Again 5.1.1 Comment by leo January 2013
  • The same!!! I don't want to upgrade my iPad to ios6 because they don't have normal maps there!!!! I wanted to buy your game and failed because it said that it's for ios6 only! Please downgrade the game requirements.