Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Original Shadows of Amn (CD installation) and Near Infinity


First post here by me. :)

I've recently installed almost every version of Baldur's Gate, then copied the game files to backup directories, and now can access original and enhanced, patched and unpatched, expansion and non-expansion versions of each game.

Just now I stumbled upon an issue, though. Reading with Near Infinity the files of the unpatched and patched Shadows of Amn (without ToB) seems to be working in general, but certain items give an "Error reading XXXXXXXX.itm null" (where "X" are placeholders). This starts with the first item in the list, ACIDBL, and goes up to AEGIS2. AIFAST then is okay, but further down the list, these errors will happen again.

I installed from the CDs, copied, patched, copied, uninstalled, and then did a clean new installation together with the Throne of Bhaal CD. From these files, all items work.

Any idea where this comes from and how to solve it?


  • argent77argent77 Member Posts: 3,067
    This error can be triggered for original BG1/2 games if you:

    1) Didn't install the full game, so that some files are still left on your CDs. You should reinstall the game and select a full installation.

    2) Or moved the game installation to another location. The file baldur.ini contains several CD entries (CD1, CD2, ...) pointing to the data folders of the game. Make sure they point to a valid location.

  • compleCCitycompleCCity Member Posts: 49

    I've adjusted the ini files, else almost nothing would work correctly (I assume – had this issue with the original installation paths). Though I'm wondering about one thing: there's the "CD1" directory listed, but CD1 directly installs into "data" – there is no CD1 directory in the installation folder. I tried it with "data" instead, but that didn't work either. This is the same for the ToB-installation, though, and there it works.

    I did a full install.

    If I e.g. view ACIDBL.itm from the ToB files (same CD installation, not GOG's Complete), it reads the data from \data\Items.bif, which is already present in the pure SoA files, and the readable AIFAST from those can be read with NI. Something wrong with the chitin.key?

  • argent77argent77 Member Posts: 3,067
    CD1 folder not existing is alright. Non-existing CD paths are simply ignored by the game (and NI).

    I've looked into the read errors more closely. It seems Near Infinity doesn't fully work on pure original BG2:SoA installations anymore. If you really need to browse the pure SoA game files, then you can try the latest NI version that is still fully compatible with that game version: Near Infinity 1.36-20151112

    I wouldn't recommend to use this version anywhere but for SoA though. It is extremely outdated.

  • compleCCitycompleCCity Member Posts: 49
    Many thanks! That works. (Have a "global" NI somewhere and always choose the game I want to view – and now a local copy directly in those both game file folders, so that's okay.) Many, many thanks! Now I can review differences between pre- and post-ToB, which was my intention. :)

    Might I ask another, only very loosely connected question? You know of the inactive BG1 demo? That has two BIF files, but when trying to access it with NI, it says "No Infinity Engine game found" – which is true, it's no game, only some sort of cutscenes batch file or something (still it's named baldur.exe). Any way to access its data?

  • argent77argent77 Member Posts: 3,067
    I looked into the BG1 demo ages ago. From what I remember, the data files differed too much from the regular game files, so I decided against adding support to NI. I don't have the demo anymore, so I can't say any more specific. Not sure if there is a tool available that actually works with the demo.

  • compleCCitycompleCCity Member Posts: 49
    Okay, thanks.

    As here apparently doesn't exist some "Solved" or "Best answer" thing …

    … quest solved by argent77! ;)

Sign In or Register to comment.