Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

BG2 (not EE): Cannot move between areas (earlier patch problem solved, now I got a new issue)

KedineKedine Member Posts: 31
edited December 2018 in Troubleshooting
Hi!

I got stuck in the game when I need to talk to Elhan, give him Rhynn Lanthor and get to Suldanessellar.
I got all needed done and now need to talk to him, but "Elhan appears busy".
So I cannot talk to him.
Fast googling tells me that has been a common problem around winXP 2003, and then there was some patch to fix this, but I find no patches anymore.

Any advice to fix this problem?

-Kedi

Post edited by Kedine on

Comments

  • BubbBubb Member Posts: 834
    Hi @Kedine,

    The patches' official download has long been dead. You can either download them from Sorcerer's Place, or if you'd rather go with the official download source, you can get the patches from the Internet Archive's backup of BioWare's website.

    JuliusBorisov
  • KedineKedine Member Posts: 31
    edited December 2018
    Thanks @Bubb.
    I thought the G3 pack included all needed, but seems it did not fix it all :/

    The patch helped, I can talk to Elhan now.

    Now I have another problem though (no wayyy...)
    I had this problem before already, that I cannot enter Forest of Tethis, Small teeth pass or North Forest and apparently now Sundanessellar...
    The game lags while loading the area, and just stucks with the loading screen and only way to exit the screen is via F4 and then end the game through Task manager.

    Why... Why does the game not wanna work... there was no problem with Windows8 or Win7, but now with Win10pro I get all the problems... *hits head to the wall*

    I should have finished the game 15 years ago so I would not stress so much with it now :D

    Post edited by Kedine on
  • BubbBubb Member Posts: 834
    When you open the options menu from in-game, what is your version number? The only thing I can think of is for you to try the v26499 patch, which states it does something to help weird loading times.

  • KedineKedine Member Posts: 31
    edited December 2018
    I have no version number anywhere. This is 4 in 1 DVD Box set (4 DVD's, BG1, BG1 expansion, BG2, BG2 expansion) for Operating system Windows95/98/ME/2000/XP/VISTA

    I tried the patch and now it does not even try to download, but it doesn't get stuck either, it just shuts the game off when trying to warp with Elhan.

  • KedineKedine Member Posts: 31
    edited December 2018
    @Bubb I figured it out. I had a mod that said "reveal wilderness areas before chapter 6" on. I took it off and the warp works now.

    Thanks for help with dialog and stuff :)

    *happy happy*

    BubbGusindaJuliusBorisov
Sign In or Register to comment.