Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Cant pick up thing under tree south of friendly arms inn

buffalobillbuffalobill Member Posts: 4
I'm new. Playing on tablet so I dont have a mouse. And I cant seem to pick up the item that shows up outside the keeps southern wall. The stylus doesnt want to get it. I think its suppose to be a ring of wizardry?


  • sarevok57sarevok57 Member Posts: 4,630
    it is indeed, or you 100 % sure you are using the right tree?

  • buffalobillbuffalobill Member Posts: 4
    I believe so. Not sure about the PC version, but on the tablet version, u can toggle doors, loot etc with a button on the bottom right of the screen to show up. When I am at the spot where the ring should be, a little chest icon appears and if I zoom in on tablet I can even see the greenish blue glow of the little ring. But since I dont have a mouse on a tablet, u can click all u like but nothing happens :( any advice

  • sarevok57sarevok57 Member Posts: 4,630
    yikes, never played the game on the tablet so i have no idea what to do here, hopefully someone comes in and knows what you can do

  • Grond0Grond0 Member Posts: 5,356
    I don't have the tablet version either, but I wonder if you're clicking in the right place? You can see from these screenshots that the entrance point to access the cache is not directly on top of it, but a little south - have you tried clicking there?

  • buffalobillbuffalobill Member Posts: 4
    Your pictures worked. Thanks man. I got the wizardry ring and diamond sofar

  • sarevok57sarevok57 Member Posts: 4,630

    Your pictures worked. Thanks man. I got the wizardry ring and diamond sofar

    there are some more easter eggs if you are interested:

    ring of protection +1

    in the area where you meet elminster for the first time, go north of that position and then a hair to the right, if done so correctly, you should see a fair size boulder all by itself ( sometimes there is even some type of wolf around there ) in the middle of that baldur is a ring of pro +1 very handy

    ankheg plate mail

    in nashkiel go to the bottom of the map all the way to the left, again like the friendly arm inn, you will see a small little tree in a field, underneath that tree there is a pearl and ankheg plate mail

    wand of frost

    when you arrive at the nashkiel mines stay at the top of the map and go all the way to the left, and you will see a big dead tree, in the middle of that tree is a wand of frost

    ring of fire resistance

    on your world map you want to go to the area that is most south and east as you can possibly travel ( i believe you can get the by going east via nashkiel mines ) once there, go down south pass the flaming fist soldier ( do his quest if you want, although bringing samuel to the friendly arm inn IS better ) and then go east of his position, while going east you will fight some sort of 4 legged canine and then go east a little more and then go up to the cliff face, around the - middle/bottom - part of that cliff face there is a little slot which hides a ring of fire resistance, an Iol gem ( as in capitol "i" - o - l game heh ) and I believe a star sapphire as well )

Sign In or Register to comment.