Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Game Crashing at The Friendly Arm Inn all of a sudden

Hi there,
New guy.
As the title suggests I can no longer enter the Inn without crashing.
I have seen another post that mentions "deleting" Khalid causing a problem but not much other than that.
I have not "deleted" him but just left him in a building elsewhere and now BAM crash city.
Strange thing is I have been back here since leaving him and had no problems and now....
I have used Keeper (mentioned in the one other post I found about this) for various other simple things but never touched Khalid or Jaheira oddly enough.
I also went back and retrieved him and attempted to enter with him and got back in but then of course if you try to reform the part both he and Jaheira want to leave.
How can I get around this? Is there another way to remove a connected party member that I am not aware of atm?
Any help would be greatly appreciated since not being able to utilize this rest area is a bit frustrating to say the least.
Love the game touched on it many many years ago and just had to try it again, glad I did up to this point at least.
Thanks in advance!



  • sarevok57sarevok57 Member Posts: 5,383
    this sounds very strange, are you running any mods?

    also, if you want to remove one party member that are pairs ( aka jaheira and khalid ) you can either kill one of them off and remove them that way ( this way is 100 % permanent ) or you can try putting one of the pairs into a different building, and then when they both leave from reforming your party ( if they do both leave ) just talk to the one that you want and you should have just the one

  • TThalesTThales Member Posts: 9
    Thanks for the reply !
    Yes I am running mods, should have mentioned that sorry.

    BG1 NPC Project and BG2 Tweaks up too this point seemed to be working just fine.

    When I did get back in at one point with K + J, dropping K did result in them both leaving. I thought that was permanent or at least you would have to have both join again (I may have misunderstood)? Are you saying that if I can enter the Inn and that happens I can then talk only to one and have them join? Didn't really want to kill anyone but I suppose I could get past that if that is the only option to get this working again.

    As I kept reading last night another option seemed to be installing SCS and only installing the part that lets you separate pairs. Would that just be asking for more trouble in your opinion or a viable option?

    After much frustration last night I think I tried everything I could think of with lots of traveling and with this one and without that one (not to mention tons of freeze ups) and just couldn't get anywhere. Like I mentioned what makes it even stranger is I sure thought I had been back there since leaving K house sitting somewhere, maybe I'm mistaken in that regard. It was pretty late I was getting foggy.

    I will continue to monitor, thanks again for help attempt!


  • sarevok57sarevok57 Member Posts: 5,383
    usually 99% of problems are caused by mods in the EE series

    if somehow you can uninstall your mods, and then start adding them back one by one, and test on each one, then you can deliberately tell which mod is causing all the problems ( which can be a pain, but this is usually the first step to trouble shooting whats going on )

    for only have one pair on a team i wouldn't use the FAI inn ( because you are forced to bring your whole party in or out at once )

    so lets say for example you want khalid on your team but not jaheira, we will use Joia's house ( her house is immediately to the west of the entrance inside the keep - she gives you the quest for the flame dance ring and the hobgobs )

    finish joia's quest ( so then you dont have to do it later ) and put jaheira in that house by herself ( keeping the rest of your party outside )

    now when you go to reform jaheira, khalid will probably leave as well, but now khalid is outside and jaheira is inside, now if you just want khalid on your team, just talk to him, and only he will join ( you can do this with other pairs as well; aka minsc and dynaheir, xzar and montaron ) and as long as you dont go back into that house, jaheira wont nag you to join back up

  • TThalesTThales Member Posts: 9

    Had a few seconds read your reply, again thanks for trying.

    Not sure how to go about uninstalling the mods will look into it. Trouble is then another game I have going will be affected as well.

    This really makes no sense! Even getting Khalid killed results in the same [email protected]#n thing, enter the Inn and BAM freeze/restart.

    Actually that building too the west was the location I left him after going and getting him again (had another save).

    Going all the way back to when he was part of the party, I can bring him and enter the Inn but anything to do with not having him results in crashes.

    Sighhhh, even kicking both of them out results in the same thing.

    I'm lost at this point...

    Thanks again!

  • sarevok57sarevok57 Member Posts: 5,383
    want to attach a copy of your save file and i will try and load it up and see if i get the same issue, since i have a clean install, if i get this problem, then it is definitely a game bug that needs to be fixed, but if i dont get this problem, then its definitely a mod bug

  • TThalesTThales Member Posts: 9
    I guess if you are willing to give it a shot.

    Thank you very much for trying. At this point I am so frustrated with this I just don't want to deal with it any more tonight.

    I have gone back in saves as far as I want to and everything has the same result. So either I f'ed something up messing with keeper or a mod has done me in even though I can't find any other reports of something like this happening. Most likely something I changed I suppose since I can't find this happening elsewhere except for one report.

    No matter what I do if I remove K (stripped of everything or not) and try to enter the Inn it's game over. So if I have to choose between not being able to enter the Inn (where other characters are waiting if I ever wanted to use them) or just saying screw it and starting over, at this point maybe I will just start over even though it really ticks me off that I have wasted so many [email protected]#n hours in this party.

    Very disappointing to say the least. Now of course I am worried about my other save as well.

    After all these years I really thought it would be fairly smooth sailing and not game over/sorry about that...

    I do realize the limitations of the game engines from back in the day but I did read up on these mods and such and really didn't expect to run into something like this.

    I appreciate the help/support and if you can get anywhere I will be monitoring the thread. Just had enough of banging my head on the desk for the night.


    Attached the sav file, hope that's all that is needed.

  • sarevok57sarevok57 Member Posts: 5,383
    im not seeing the save file

  • TThalesTThales Member Posts: 9
    So I'm trying to post the file but it says "file format not allowed" for the sav file.

    What a night...

    Any clue as to what I'm doing wrong?

    Documents folder and all that, BGEE/Save folder/name of save opens a folder with bitmaps and a sav file I try to attach the sav file and "file format not allowed".

    I dragged the whole folder over and the bmp files show up as attached but nothing else, with that message of course down in the lower left corner.

    What fun...

    I will check back tomorrow night. Thanks again for trying!

  • TThalesTThales Member Posts: 9

    Ok google foo may have helped found a Beamdog page, file has to be zipped.

    Let's try again.

    That looks better. Didn't know about the zip part, sorry. First time here and all that.

    That should be where I brought everyone that was last in the party, before trying to get rid of Kahlid.

    Marched them all the way back and tried all sorts of different ways, him/her house outside not outside so on and so on. Tried many different saves as well, there just seems to be something flagged or a variable tripped somewhere/somehow.

    Let me know what happens.

  • sarevok57sarevok57 Member Posts: 5,383
    hookay, so i did some quick testing, and so far i have no problems with bringing khalid into the FAI inn:

    i went in and out of the FAI about 20-30 times and not one crash

    and then i went over to joia's house, dumped khalid in there, and just told khalid to reform party, and khalid left the party while jaheira stayed around

    so my guess, is that there is a mod somewhere on your game that is causing this issue

    from what i can tell your khalid does not have anything on him that would case a crash ( inappropriate items, or items that don't exist for example )

    although, i do notice that you have ammo bags, which if im not mistaken is not a default EE item ( and despite the fact you have 3 of them, they are actually all the same bag, or at least it is in the file i played )

    so what is happening is, there is something inside the friendly arm inn that is connected with khalid that is causing your game to crash

    i noticed for the most part that neera, has nothing illegal on her person that i now of, dorn wouldnt join the team because you have 2 REP ( i guess i could have lowered it, just to see if he has anything illegal on him, or perhaps you know what he has for inventory? )

    or perhaps its a script issue? i noticed that your team mates were using the beamdog scripts, are they doing so for your game?

    one thing you could try is perhaps dropping your ammo belt(s) and see if that lets you in

    you said you EE keepered one of your characters, but i did not seem to have a problem, so i dont think your EE keeper machinations messed it up

    looking at the mods you have installed, my guess is that somehow perhaps the bg1 npc project is messing with something in the FAI ( something that deals with khalid )

    but by the looks of it, you already have the treasure needed from this place, and you don't necessarily have to come here ( unless you sold something that you needed ) anything that bentley buys, thalantyr from high hedge will buy the same things ( except for bolts which taerom the blacksmith in beregost will buy )

    so even though you are having this whacky bug that khalid cannot go into the FAI ( which is ironic because that is where you got him ) its not a complete game breaker since there isn't anything crucial in there and you can still continue on with the game

    but with that being said:

    try dropping the ammo belts perhaps, and if that doesnt work, i am going to point my finger at NPC project and say there is some sort of scripting error that is happening when khalid enters the FAI

    if all else fails, save your save games, to a complete wipe, reinstall everything and then install your mods one by one, and see if you get the same problem ( because it could also be possible that one of your mods didnt install properly, and reinstalling might be able to fix the issue )

  • TThalesTThales Member Posts: 9

    Didn't really have time for this but couldn't resist checking.

    I keep saying it but Thank You!!!

    One quick question though, did you go back into the Inn after leaving Khalid in the house? I just had to ask because I as well got him to stay put and removed him from the party but then if I go back....

    Just wondering, I didn't know if the 20-30 (above and beyond testing!) were after leaving him or as the screenshot shows with full party (I got away with that as well).

    I noticed how the ammo belt works some time ago and meant to deal with that, I had no idea it was shared just seemed so handy I couldn't resist. I will either leave them on the ground or just get rid of the unnecessary ones with keeper tonight and see what happens.

    I could try avoiding the place I guess, don't know that I would use Garrick again. Neera is kind of cool, that wild chance makes it interesting but a pita at the same time. I do have her in another party/game so I can leave her as well I guess.

    Thank You very much for all your efforts, I won't bug you again except to say if the ammo bags worked or not. It will be a night or two at least for time if I have to nuke everything and reinstall.

    Back to work...


  • sarevok57sarevok57 Member Posts: 5,383
    the above screenshot of me entering the FAI was with khalid in the party for the 20-30 times

    then i just tried now with khalid placed (reformed from party) in a random house and again for around 20-30 times went inside and out of the FAI without khalid in the party and still no crashing

    ( i was going to try and see if khalid was in a different house while still being in the party but to enter the FAI you have to gather your whole party to do so, so i couldn't test that )

    im really thinking it is caused by a mod you have that is making your game crash

  • TThalesTThales Member Posts: 9

    I think at this point (unfortunately) your last sentence may be the answer.

    Nice of you to go back and check entering after dumping Khalid for me (again).

    I dropped all the ammo bags and tried again and yeah, Crash...

    Gave that a few tries and just said ok that's enough!

    I was very skeptical about going through an uninstall/install and re-mod. I just have a horrible image of me sitting here after all that and having it bork the other parties/games I have going.

    So I have continued on bypassing the F A Inn and just getting on with it.

    If I may one more question since I didn't want to run through spoilers and such. Is there any reason plot wise that I would HAVE to return too that Inn?

    You have been very patient and gone out of your way to help with the testing and everything, can't really thank you enough.

    Frustrating crash especially since I couldn't find anything like this besides one particular post.

    Anyway Kicked Khalid and have moved on to two different other party member changes, left bags behind and hopefully everything is just gravy from here on out. Having fun with it again, so that's the most important thing.

    Thank You again!!!!!


  • sarevok57sarevok57 Member Posts: 5,383
    no worries good buddy :)

    here is all the "plot wise" stuff the FAI can possibly offer:

    for items, luckily nothing to fancy here, except for the golden pantaloons ( if you want to build the big metal unit in ToB these are essential ), although if im not mistaken you already had them in your inventory, and hyper worse case scenario you can always console them in, if need be

    plus bently has a buckler that gives you +1 to CON, but its a buckler and i dont think its even +1 so not really worth it to be honest

    joinable companions, obvious given, but unless you dont need; jaheira or khalid on your team; don't want dorn on your team; or never let neera leave your team if she joins then that is all you are missing for team mates

    but other than that, not much going on here, in fact its entirely possible to beat the game never touching foot in the area period

    so as long as this is the only bug you have, i say just keep playing the play throughs you have ( i believe you said you had 2 of them ) and then once those play throughs are done, thats when you can do the complete re-install clean wipe and all that good stuff so then you dont lose the progress you have now :)

  • TThalesTThales Member Posts: 9

    Just had to pop back in quick.

    Wouldn't you know it!

    Same thing happened with my second party!!

    I think my jaw hit the desk and I just sat there staring for a bit. Could not believe it...

    Thanks for the heads up on anything else related to that Inn, nothing I can't get around. I think Garrick is stuck in there but didn't want him around anyway, maybe Neera on that game I can't remember and Dorn won't talk to me anyway our rep is too high. The second party I have who I want I think, for the duration so no big deal.

    Just surprised me that's all. So it's not related specifically to Khalid apparently so who know what mod it doesn't like...

    All good now (as far as I know) and progressing on through the game.

    Thanks one more time for all your help!!


Sign In or Register to comment.