Skip to content

Party Can't Travel to Friendly Arm

I've left Candlekeep, picked up Xvar and Montaron, and traveled east to the map with the road markers pointing to the Friendly Arm and Beregost.

I've walked my party to the northern edge of the map and clicked at the edge, with my cursor showing the wheel and arrow icon. This takes me to the world map, where the F.A. inn is shown with a shield and crossed swords over it and its name in blue.

I click on the inn, highlighting it. Then, I click on the Travel button, and am am immediately returned to the map with the two road markers.

I've tried leaving the map at various different points, to no avail.

I can travel to and from Beregost with no problem.

Any advice?

Comments

  • SamsaptakaSamsaptaka Member Posts: 4
    I should have noted that I'm using Windows via Steam.

  • SamsaptakaSamsaptaka Member Posts: 4
    Never mind. I solved my own problem.

    The Coast Way map is labeled Friendly Arm Inn on my world map. However, I can click on the unlabeled Friendly Arm Inn icon and travel there.

    And, I just realized that the swords and shield shows where the party is. It's been a long time since I last played BG.
  • PingwinPingwin Member Posts: 259
    I think it is more a case that the labels appear quite a long way below the area they are with. If you have another area just to the south, then the label can be closer to the southern area than to the area it actually goes with. I've traveled to an area south of the one I intended to visit before due to to this.
    Samsaptaka
  • SamsaptakaSamsaptaka Member Posts: 4
    That makes some sense. Thanks.
Sign In or Register to comment.