Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Using EEKeeper to Fix Random Renfeld Encounter (Minor SPOILERS)

LouisReduxLouisRedux Member Posts: 6
[I have read the rules, sorry if this becomes a double post, the first attempt vanished]

Hi everyone,

Apologies if this has been answered elsewhere, my fairly extensive googling has not found the answer, and the possibility exists that I am being a bit thick! :)

Problem contains story element spoilers, see below:
I'm trying to progress the romance between my PC and Jaheira, and more importantly progress the Harpers Hold quests etc. I am an XP hound!

I have >110 in game days, and yes, whilst I know the Renfeld encounter event is random, and what "random" means, I have either yet to see Renfeld or have seen him and missed him (talking to Rylock does not progress the quest).

I am trying to do a clean playthrough, but I have a life! I can't keep waiting to progress this quest, and several dozen travels into and out of the city haven't worked to generate this specific encounter.

I have downloaded EEKeeper and don't know which variable to add or modify. Adding Renfeld's body to my inventory and speaking to Rylock did not work. Scanning through local and global variables for the PC and Jaheira did not reveal anything obvious (i.e. anything to do with Renfeld, Rylock, Harpers, or Xzar). I've used the creature browser and the "find strings" functions to look up the resource names and reference numbers but don't know what to do with this information.

I'm stuck! Help!

How do I use EEKeeper to add this quest/modify the quest or encounter status/progress this quest line?

I'd really rather not use the command console if at all possible.

TL:DR I'm stuck at a particular point in the progression of the game due to not having had a random encounter. This is either a bug or a mistake on my part. I'd like to use EEKeeper (as opposed to the command console) to edit a save and be able to progress the quest line/encounter. How do I use EEKeeper to edit quest statuses, progress quest line, or add the relevant quest statuses to move forward?

Please can anyone help me with this.

Post edited by LouisRedux on

Comments

  • gorgonzolagorgonzola Member Posts: 3,159
    edited December 2019
    if i am not wrong
    that encounter is not random at all, happens in every play trough the first time you try to leave the town, so no need to use EEkeeper, just get a quest that opens an area outside the town, darnise keep, trademeet, umar hills or the one you get from a certain lord in the CC, go to the city gates, try to reach that area and you will find renfeld in the regular way.
    other aspects of the very long jaheira's romance and personal quest can be altered to make them happen faster, basically changing some timers values, but here it is not needed at all.
    i hope it helps.
    start from a clean save game, not changed trough EEkeeper, and try what i suggest.

    probably it is better to write the word SPOILER in the thread title, so we don't have to use spoilers inside it :)
    it is good to use them, as the right to not be spoiled is very important, but when the whole topic is a spoiler to warn in the title is the better way. a spoiler inside a post is more for not spoilerish threads where something that can spoil is told.
    not that you have done it wrong, better more then less, only a little hint...

  • gorgonzolagorgonzola Member Posts: 3,159
    edited December 2019
    sorry you have >110 in game days, so some bug occurred and you missed that encounter, that you can not miss as it always happens in the first travel outside the town.
    unless you have left the area so fast, after defeating some attackers that the guy has no time to start the dialogue.

    i don't know how to help you at this point.
    i would say start a new game, ctrl K your way trough the initial dungeon, get as fast as you can a quest that highlights an area outside the town, try to reach it, get int he transition area where you fight (ctrlK) the enemies and this time find the man and bring him to his friend.

    while doing it save the game, before leaving the town, when you have his body in the inventory and after delivering him to his helper.
    this way you can compare with EEkeeper the game variables and change them accordingly to the stage you want to reach in your actual game.
    now i don't have save games to compare them for you, and also no time to do it myslef, but enabling ctrl K it should ber a fast process as you don't have to actually fight anybody, you just kill them on sight.
    lame if done to beat the game, very useful for testing and debugging issues.

    LouisRedux
  • LouisReduxLouisRedux Member Posts: 6
    Thank you Gorgonzola, that's an excellent idea, I'll give that a try! :-)

    gorgonzola
  • LouisReduxLouisRedux Member Posts: 6
    And thanks for the little hint too!

  • LouisReduxLouisRedux Member Posts: 6
    Update:

    It seems to have worked. I created a new party and rapidly went through Ch1.

    If anyone else has this problem, here are the steps I took (minor plot spoilers):

    1) I went straight from the promenade to the slums, through Gaelen's dialogue and immediately accepted Nalia's quest. (Something I did not do before)
    2) I travelled to the city gates (something I did not do before, my first move outside the city was as late as possible and to Watcher's Keep (not to play, just to get to Ular Hills etc)), and then to Nalia's keep. I saved the game (not quick save) before travelling.
    3) As Gorgonzola says I immediately got the Renfeld encounter. I killed the baddies, picked up the body and immediately travelled to the docks. (i.e. I did NOT go to Nalia's).
    4) I saved the game (full save), spoke to Rylock, and saved the game again.
    5) Checking game saves with EEKeeper* I was missing "RENFELDDEATH" as a Global Variable with the value 1318015.
    6) I added this to the "proper" play through save on my original PC using EEKeeper, and added Renfled's body to my PC's inventory.
    7) I re-entered the game using this save, and spoke to Rylock, I have now completed that section and the Xzar section of the HArper quests. It appears to be a stable save so far.

    *I am on my first play through, and did not want to "cheat" or edit saves. I only downloaded EEKEeper to fix this issue. I mention this so that people know I wasn't originally working off an edited save.

    Thanks again, Gorgonzola.

  • LouisReduxLouisRedux Member Posts: 6
    It looks like this worked. I had a more detailed reply with exactly what I did and where the differences were on my original play through, but it seems to have vanished after I tried to edit a typo post submission.

    If it doesn't reappear, I'm happy to detail what I did and how the original save was fixed if someone needs me to.

    gorgonzola
  • jmerryjmerry Member Posts: 394
    A technical note:
    5) Checking game saves with EEKeeper* I was missing "RENFELDDEATH" as a Global Variable with the value 1318015.

    The value of this global variable represents a time; several in-game days after it is initially set. If the game time ticks up to that point, the poisoned man becomes a dead man, and the quest is failed. If you're going to force things and set the variable, choose a sufficiently high number.

    LouisReduxgorgonzola
Sign In or Register to comment.