Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Cannot progress Tyrants of the Moonsea

After waking up in the Hillsfar's arena and talking to the Innovator of Pain (telling him I'm ready) the screen fades to black and stays that way. I can still hear the music and can open the inventory/map and see my character moving about on it if I do move her.

Played with the stable and the beta versions, both times same bug. At first, I tried turning off sound/lowering graphic settings/running as admin/compatibility mode... Nothing worked. Then I tried reinstalling, installing on separate drives, clean installation and a modded one, again, nothing worked.

Anyone knows a workaround?


  • jimdad55jimdad55 Member Posts: 42
    "After waking up in the Hillsfar's arena..."

    You're lucky. I can't even get into Hilllsfar. This has been a pretty frustrating module for me, despite having a pretty promising opening with the big battle, and I've given it up a couple of times already since I bought it when it came out. I couldn't get past the banelich, I couldn't get past the dragon on the road to Hilllsfar and now after managing both and finishing the side quest with Cheswick or whatever his name is, which I assumed would get me in, I have a guard telling me I can't enter.

    There seems to be no persuade option, doesn't seem to be anything from a recent quest that could help gain entry and I cant think of anything I could buy, even if there was a nearby store, to get entry. I did read a short post from someone saying that you need to be human to get in ( I'm playing Spectoral the sorcerer) and if not you need a scroll but that's about it.

    There seem to be quite a few bugs as I've gone along although nothing game-ruining so far. I'd like to see if I can finish it as the OC bored me to death ( several times actually). And this is me playing on the easy setting...

  • jimdad55jimdad55 Member Posts: 42
    Well, finally got into Hillsfar. Turns out I WASN'T human after all. Who knew? And the scroll was sitting in my inventory. With such a disorganised approach I'm amazed I've got this far.

    Now, I'm in the arena and getting my ass kicked on a regular basis by one and all. I need a good cheat code . . . :)

Sign In or Register to comment.