Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Server description doesn't work correctly

I'm having trouble with setting description for my server. I've put the description in ServerDesc.txt but it doesn't show up in Server Details, old module description is showing instead. I've tested this locally and the description does shows up correctly in LAN, but does not in online server list. What can I do to solve this problem?

Comments

  • Str8TStr8T Member Posts: 7
    I created simple example to illustrate the issue.

    Server details as seen in the LAN server list:
    ScylOzg.png

    Server details as seen in the online server list
    pJvoO25.png

    As you can see, server description is missing in online server details. Is this a bug or am I doing something wrong?

  • DazDaz Member Posts: 86
    The online server list uses the module's description.

  • Str8TStr8T Member Posts: 7
    Tried setting module description on my test module and it doesn't seem to work either. I've put some text in module description and it simply doesn't show up in server details.

    Also, I have one pretty old module and when I run it, module description is showing up in server details. When I tried changing this description, server details seems unaffected - strangely, old description is still showing up. Description which I've put is only visible in the toolset and module select inside the game.

    Seems like a bug to me. Maybe something changed in module file format and how it is handled by the game/server?

  • WilliamDracoWilliamDraco Member Posts: 141
    The file formats are effectively open sourced and haven't changed.

    As you say the old description stays, you're either changing something that's not the description or there is some duplicate of the mod that you're loading. Do you use module folders? Could be that it's not packing the changed file back into the mod (although would expect no other change to stick either then). That'd explain seeing it in toolset (loads from folder) vs seeing it in server (loads from .mod file)

  • Str8TStr8T Member Posts: 7
    Alright, I figured it out. I've set the LanguageID in the nwtoolset.ini to polish so that I could write my module in this language. When I was setting server description it was set in the polish language by default, but server app was using english description. I've set module description in english and now it's showing correctly.

Sign In or Register to comment.