Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Few bugs

IndividualIndividual Member Posts: 6
edited January 2013 in Fixed
To the point:
- The game crashed for me while trying to flip a wizard's spell book to the second page, right at the start of the game (was just checking in-game menus, character, quests windows etc.).
- It appears that overall, switching between the menus makes the game freeze for a second and that can lead to a crash
- Upon moving the starting Quarterstaff item from the handslot a couple of times, each following time I pick up the weapon and want to put in the the same or an inventory slot, the game reacts with a delay and the slots, in which you can dump the item, become unselectable during that period.
- In polish version, every single opening of the options menu (or any other menu) lags out the sound, it loops for around a second; the game does not crash but it's very annoying. No such issue with the english version.
- There's a black square on one of the selectable colors in the first row (affects every adjustable color, that is: hair, skin, minor and major clothing). Appears on a different square each time the game is run.
- Dear Lord, the game freezes even during removing the fog of war from certain areas or trying to brute force drawers... Looks like it has to do with selecting the items from the bar at the bottom of the screen. It happens as I press F2 or F3 in order to open the drawer with an item or fist (really?)

I've assumed that Steam Overlay causes those issues and it appears to be so. Shift + tabbing to steam works fine, but upon tabbing back to the game, parts of UI disappear and other shenanigans happen. I was to upload a screenshot but realized that making one in the game results in a black-screen screenshot (huh?).

I was hoping for a new, enhanced adventure but, so far, it's been a big disappointment. Playing the game with random freezes each few or tenths of seconds on every random event is far from being enjoyable.

I don't mind spending those 15€ on the game (I bought BG1 Collector's Edition as soon as it was released back in 90's) but can't get over the bad experience so far...

Post edited by Individual on

Comments

  • CerevantCerevant Member Posts: 2,314
    One thing you can do is disable hardware cursor in the steam client - this seems to clear up some issues with the overlay.

  • IndividualIndividual Member Posts: 6
    edited February 2013
    Thanks Cerevant, you are a genious, this did indeed solve some of the issues:
    - solved steam overlay issue when returning from steam overlay to the game (huge part sof game's menu/ui were missing before)
    - game no longer reacts with a delay/lag when moving objects in inventory or using/selecting the options form the bottom-screen quickslot (F1, F2 etc.)

    Edit: the delay issue returned after having the game opened for 10 minutes, sadly.

    Now it's pretty much the looping sound when changing areas / accessing main game windows (options, scrolls, inventory etc.) that's left.
    Also, my mouse stops responding in the game (doesn't move while I'm I moving it) right after selecting a certain (any) option in the game's menu, i.e. turning Dithering on or off OR opening/closing a window as well as hovering the cursor over an item, in order for the tooltip to appear.

    The mouse issue is, naturally, not apparent outside of of BG:EE.

    I've tried to run the game in a compatibility mode but Steam succesfully prevents me from it so far.

    Post edited by Individual on
  • CerevantCerevant Member Posts: 2,314
    Some things to check:

    Are you running the latest version of BG:EE? An update was released by steam a few days ago. Make sure you are seeing "1.0.2012" in the upper right corner of the main game screen.

    What kind of video card do you have? Make sure you have the latest video drivers installed.

    You can also disable hardware cursor in BG:EE itself, under options/graphics.

    Hope this helps!

Sign In or Register to comment.