Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

My resolution is broken. The display is clipped at the sides no matter what resolution I play at.

I am running Windows 7 on a macbook pro. My display resolution is 1920x1200. When I launch the game in fullscreen this happens:
http://forum.baldursgate.com/discussion/7636/resolution-1920x1200-showing-clipped-fix

I have tried all of the following:
(a) Changed my laptop resolution. Doesn't work.
(b) Run in windowed mode. Works but is retarded because the map won't scroll properly.
(c) Change baldur.ini settings. I tried every combination of parameters. Nothing works. Either it's windowed, or fullscreen and broken.
(d) Changed registry settings for default resolution. Didn't work. They reflect the actual screen resolution so that is not the issue.

I am guessing that when I launch Baldur's Gate some settings are parsed from the registry which tells BG to run at my original resolution (either 1920x1200 or 2880x1800). Changing screen resolution after that doesn't work because some flag has been set somewhere.

Has anyone had this problem? And how to fix it?

Comments

  • gmiwenhtgmiwenht Member Posts: 3
    FIXED!

    Took me two days to figure it out! Such a simple solution after having tried everything including disabling/rolling back all my graphics card drivers, tweaking the registry, windowed fullscreen mods, taskmar manipulation scripts. I ALMOST got it working by killing explorer.exe and using Shift Window script, but there was like a 20 pixel border that I could not align so I gave up.

    Finally I stumbled upon a solution here:
    http://forum.baldursgate.com/discussion/11221/simple-solution-bg-ee-working-on-intel-hd-graphics-based-laptop

    All credit where credit is due, but I will share the solution for the many others who will surely experience this problem.

    First you need to locate the actual .exe, not the steam:// shortcut. This will be in Steam/SteamApps/Common/Baldurs Gate Enhanced Edition.

    Then right-click BGEE.exe, click Properties. Under the Compatibility tab check the box that says "Disable desktop composition."

    Apply and use a shortcut run the .exe.

    That's it!

    Ray22
Sign In or Register to comment.