Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

How to set up tp2 mods

VolomonVolomon Member Posts: 1
Ok I'm looking all over, and can not find one clue on how to set these mods up.

For instance: Player How-to: Getting Mods to work on EE, part II

Step One
Install them as normal.

Wtf....ok looking for a new thread.

Mod and modding tutorials quick links

Zero tutorial quick links.

Wtf....new thread.

Any locations where it assumes I don't know how to install these files? I'm trying to add in the BGEE party scripts.

Comments

  • JalilyJalily Member Posts: 4,681
    1. Unzip the file you downloaded and you should see a folder named, say, NameOfMod and a file named setup-NameOfMod.exe.
    2. The party scripts mod doesn't use the latest version of WeiDU* (that's the .exe), so grab the latest version here. It's the first bullet point on that page.
    3. Unzip that file and find weidu.exe. Copy weidu.exe and the NameOfMod folder into your 00766 folder.
    4. Rename weidu.exe setup-NameOfMod.exe (in your case, setup-bpseries.exe).
    5. Run the .exe and follow the instructions that appear.

    * If it did, installation would just be copying the folder and the .exe into your 00766 folder and running the .exe.

    ThacoBell
  • Fina92Fina92 Member Posts: 270
    @Jalily Hi! I was wondering if you could lend me some aid as well as I have a similar problem as Volomon had in this thread. I have downloaded the latest version of weidu and unzipped it and all, but where should I install it? I tried to follow your instructions above and I managed to do the first 2. BUt I didn't have a file in the unzipped weidu folder that said "weidu.exe".
    The Weidu folder instead contained this:
    -a folder of "examples"
    -a file that said "COPYING"
    -a website for the README which confused me more than anything
    -a note of the changes in weidu that gave me a headache and no answers
    -a program file that said "tolower"
    -a program file that said simply "weidu" (it was the largest one)
    -a manifest file that said "weidu.exe.manifest" (no idea what that is)
    -another program file that said "weinstall"
    -another manifest note that said "weinstall.exe.manifest"

    I tried the largest file and did what you wrote above (I'm trying to install the kitpack) but just got errormessages and no installation process.

    Any suggestions ?

  • IsayaIsaya Member, Translator (NDA) Posts: 737
    @JosefineS The program file called "weidu" is weidu.exe. It's just that by default the Windows file explorer hides known extensions such as .exe. You can change that behaviour (and show extension) in the file and directory options in the control panel (I can't give exact names as I don't have an English version of Windows).
    You can apply the instructions without taking care of the exe part, either for weidu.exe or for setup-something.exe, just ensure you apply that to a "program file" of that name.

    Fina92
  • Fina92Fina92 Member Posts: 270
    @Isaya Thank you so much for helping me, but I can only understand about 20% of what you are writing :P Computer stuff just isn't for me it seems ha ha!

    BUT if I understand you correctly you are saying that I should just use the progam file that said "weidu" och follow Jalily's instructions?

    Because I did that and as I said above, it got me nowhere.

    I'll specify:
    I took all of the files from the weidu folder (except the link to the website, the folder of examples, the FILE that said COPYING and the note of changes), and I put them in the 00766 folder. Then I also put the kitpack files in the 00766 folder and I changes the name of my Weidu file to setup-kitpack.exe and then I tried to run both the newly created setup-kitpack.exe and the already exisiting -setup-kitpack (that came with the kitpack folder). Both ways I end up with that black box that you do the installatin from but it says
    -first the place of the file that I'm trying to run,
    -then weidu version 23100
    -then SETUP-KITPACK.EXE.DEBUG -- queried

    I'm at a total loss here :(

  • IsayaIsaya Member, Translator (NDA) Posts: 737
    @JosefineS Let's stick to instructions and to minimum explanations then. ;-)

    You don't need to copy everything from the WeiDU archive you downloaded. Only the "weidu" program file is needed.
    If the file explorer doesn't show any .exe extension to weidu and setup-something files, never add an .exe extension to any file, otherwise the file will become "setup-something.exe.exe" in its "real name", the one where the .exe extension is not hidden.
    The setup-something that came with the mod is old and needs to replaced (i.e. not kept side by side), as the new version of weidu handles BGEE properly (the old versions didn't).
    You need weidu version higher than 231 (forget the last two 00, typical of beta version). The latest one on the page linked by Jalily is 234.
    So sum up:
    - download the latest version of WeiDU (234 at the time of writing) and extract the archive
    - copy "weidu" from the archive into 00766
    - copy the mod content into 00766
    - delete the file setup-kitpack that came with the mod
    - copy the weidu file and rename the copy to setup-kitpack
    - double-click on setup-kitpack to install the mod

    After a few lines recalling the Weidu version (it should display 234) and some stuff, you should have a question about selecting a language or a confirmation whether to install the mod or not. This is the normal process of insttallation.
    Here is an example of normal display. The second question about the language selected in BGEE will only appear when you install the first mod and will not be repeated afterwards.
    (The 00764 name differs because I took the screenshot with a beta version of patch)

    Fina92
  • Fina92Fina92 Member Posts: 270
    @Isaya IT WORKS!! Thankyouthankyouthankyouthankyou!!!

  • MathsorcererMathsorcerer Member Posts: 2,878
    I am receiving an error "no translation for @1" for which, despite repeated reading of WeiDU documentation, I am unable to resolve. If you haven't seen this error before, would I need to let you browse a copy of the .tp2 and .tra files?

  • IsayaIsaya Member, Translator (NDA) Posts: 737
    @JosefineS You're welcome. Enjoy your game.

    @Mathsorcerer I gather you're trying to make an item mod.
    I assume you have a command COPY for your itm file, with SAY xxx @1 to give its name or description. Since you use @1, which is a reference for a string in a tra file associated with the mod, you need to ensure that you actually create the string in the tra file associated with the tp2 file. Obviously, it's missing.

    You may find a good example in this tutorial.

  • MathsorcererMathsorcerer Member Posts: 2,878
    That is the frustrating thing--I *do* have a tra file that is being referenced by the tp2. If I put my strings directly in the tp2 the item installs successfully therefore there must be something about my tra file that the setup doesn't like. The tutorial you reference is an excellent one and is, in fact, the one I am already using as my map.

    Definitely an item mod. It took me a while to figure out how to approximate a sword of sharpness in this game engine but I think what I have will work nicely.

  • BaptorBaptor Member Posts: 216
    Hey! I tried this trick with Spell_Revisions mod. It worked fine up until I tried to install the components, at which point it skipped them all and said I needed BG:II. Suggestions on how to get around this issue?

    T2av
Sign In or Register to comment.