Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Custom Kits

CoM_SolaufeinCoM_Solaufein Member Posts: 2,599
I read some where that custom kits are broken with the latest versions of BGEE and BG2EE, true?

Comments

  • FrecheFreche Member Posts: 473
    edited May 2014
    I say it right now that I could be wrong here since I haven't read too much on the topic but as I have understood old kits are broken.

    Short answer: Custom Kit mods must be designed to work with the 1.2 patch.

    Due to several tables being externalised it's currently needed to manually include more info in the tp2 for the weidu install. I recently saw a post here on the modding forum from someone who had made a working kit, so it should be possible just a bit more work from the author.

  • WispWisp Member Posts: 1,102
    edited May 2014
    At the least you need to append to several more 2DA files than ADD_KIT does by itself. You can download a TP2 library here that complements ADD_KIT (and frees you from having to do the EE-specific work).

    There are/were some more problems, such as the game throwing fits over certain symbols (commonly found in modder prefixes) being used in 2DA files, or not being able to handle more than a few new kits before running into some overflow bug, but they may have been fixed by now.

  • CoM_SolaufeinCoM_Solaufein Member Posts: 2,599
    Great, thanks.

    I probably won't be adding new kits into this mod at the moment. I'm not familiar with kits and the people who originally coded it for me have vanished. :\

Sign In or Register to comment.