Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Possible solution for Creative X-Fi Owners having issues with Static

DreadPirate_DuoDreadPirate_Duo Member Posts: 6
edited December 2012 in Windows PC (Archive)
Hello everyone.

I was having a huge issue with loud static running for 3 or so seconds... normal sound for 5 - 8 seconds... then static again.

I did some research on OpenAL and found a lot of interesting articles.
I searched the install directories of BGEE and could not find any dlls that would indicate that OpenAL was configured for BGEE... so I searched my HD for OpenAL32.dll and OpenAL64.dll... low and behold I found them in my Minecraft appdata directory.

I copied both the 32 and 64 bit versions of the files to the directory that has baldur.exe in it (not the directory with BGEE in it).

I fired up BGEE and no static... played for 2 hours, no static!

I'm not 100% sure it is fixed... but 2 hours with no static (or studdering sound) and I'm very hopeful that this will prove to be a solid solution.

For reference, these are the locaitons of the source files and the destinations:

My Source for OpenAL32.dll & OpenAL64.dll
C:\Documents and Settings\(USERNAME)\AppData\Roaming\.minecraft\bin\natives
(This will require that MineCraft has been run on your system, it may work if you download and run Minecraft classic which is free, run it, and save a game).

Desination for the DLLs (I used the Direct Installer to install BGEE)
C:\Program Files (x86)\Baldur's Gate Enhanced Edition\Data\00766
(Notice this is not the directory where BGEE.exe is located, the solution does not work if you put the DLLs in that directory as BGEE.exe is not the process that is attemting to use the sound hardware)

I hope this helps others... or BGEE's team to come out with a proper patch. I read the EULA for OpenAL and I cannot post the DLLs to this forum... but I'm hoping that I gave you enough information to get them yourselves.

Post edited by Balquo on
FenghoangonkelosuppoLock

Comments

  • DreadPirate_DuoDreadPirate_Duo Member Posts: 6
    BTW, I an running with the following specs

    Crative X-Fi Platinum (I love this card)
    Windows 7 Ultimate x64
    Other things that don't pertain to this thread :-)

  • BartimaeusBartimaeus Member Posts: 15
    Shouldn't this probably go into the PC Support forum, not the bug report forum?

  • DreadPirate_DuoDreadPirate_Duo Member Posts: 6
    I posted here because I feel that the DLLs should have been placed in the proper place during the install process. You are right, this is more of a PC Support post... but it would be nice if the Devs would create a patch to make this fix "automatic".

    Just to be clear, I don't fault the Devs for this too much... there are hundreds of thousands of possible hardware combinations that people could have in their rigs... you can't think of everything, nobody's perfect.

  • OrigamiPaperOrigamiPaper Member Posts: 1
    I was getting sound hammering and occasional crashing whenever I left an area/building and this worked great for me (so far!).

    Thanks!

  • HexonxonxHexonxonx Member Posts: 5
    Have't had the chance to try the fix.
    But the DLL files can be found online to download (Google or such).

  • FenghoangFenghoang Member Posts: 160
    edited December 2012
    Thank you so much! This is working for me. =D

    It seems to have fixed both the Prologue and ingame sounds.

    I ended up using the OpenAL32.dll from Unigine "Heaven" DX11 Benchmark (it's a free benchmark/stability test for overclocking your video card if you're curious) that I already had installed. You don't really need the OpenAL64.dll - unsurprisingly since BGEE is a 32-bit program.

    I can also say that not all OpenAL32.dll files seem to work. I tried using two different ones from my STALKER games, but those didn't seem to affect anything. I also noted that they were all different in size - the one i got from the "Heaven" Benchmark was 832KB, where as the STALKER ones were only ~50KB.

    I'm still curious as to why this problem seems to only affect Creative X-Fi users...

  • TrentOsterTrentOster Administrator, Developer Posts: 433
    OpenAL is a spec, much like OpenGL. As such, there should be a software-only implementation of the OpenAL features that should work on almost any configuration (thus the 832 KB size). When the BG:EE launcher is run for the first time it installs OpenAL on your computer. The installer chooses the OpenAL32.dll based of the auto detection of your system. As the installer seems to work for the vast majority of audio cards out there we really cannot get rid of the installer and force everyone to the software mode.
    My guess is that there is a bug in the OpenAL detection of the X-Fi and the auto detected OpenAL settings are incorrect.
    We'll look into making the 832K OpenAL 32 easier to find.

    Best,
    -Trent

  • TrentOsterTrentOster Administrator, Developer Posts: 433
    On the downlaod site for the Heaven benchmark it says:
    Known Issues:
    Crash on Creative SB X-Fi cards
    Please switch your sound card in gaming mode to get correct work with OpenAL library.

    Can someone try the setting without changing the OpenAL32.DLL

  • chiefehchiefeh Member Posts: 1
    I've never figured out how to access the Creative Audio Control Panel since I installed Windows 7, so I can't test the 'gaming mode' thing... but the OpenAL Installer from Creative seemed to fix the problem for me.

    http://connect.creativelabs.com/developer/Wiki/OpenAL Installer for Windows.aspx

  • VampQueen31VampQueen31 Member Posts: 60
    edited December 2012
    I love my Xi-Fi too but creative is just horrible with support for it, the drivers suck and even old games that where made for Creative EAX wont work with it without tweaking or third party software, like open AL. But the hardware is phenomenal.

  • DreadPirate_DuoDreadPirate_Duo Member Posts: 6
    Trent,

    Thanks for looking into this.
    My X-Fi was in Gaming mode the entire time... but to try to help I reverted back to the default install, changed my card to "Audio Creation" mode and tested out BGEE that way.

    I had the issue with the audio static and game studdering.

    I changed it to Gaming mode and both issues were still there.

    I changed it to "Audio Creation" mode again and put the "new" dlls in... it worked flawlessly for a bit, then crashed (about 40 minutes of game time).

    I changed it to Gaming mode and left the "new" dlls in place... no issues, no crashing.

    I hope this helps... let me know if I can do anything else to help...of course this would be a non-issue if MS didn't remove directsound from Windows 7 and later.

  • DrudenhausDrudenhaus Member Posts: 8
    I switched to "gaming" mode and sound magically works now with the X-Fi driver. I typically leave it in a different mode for ASIO use so I hadn't thought to change the mode. Thanks!

  • FenghoangFenghoang Member Posts: 160
    edited December 2012

    On the downlaod site for the Heaven benchmark it says:
    Known Issues:
    Crash on Creative SB X-Fi cards
    Please switch your sound card in gaming mode to get correct work with OpenAL library.

    Can someone try the setting without changing the OpenAL32.DLL

    My sound card was on "Gaming Mode" the entire time for both the installation and during the play session prior to the OpenAL32.dll mod. I'm generally too lazy to switch to the other modes... XD
    chiefeh said:

    I've never figured out how to access the Creative Audio Control Panel since I installed Windows 7, so I can't test the 'gaming mode' thing... but the OpenAL Installer from Creative seemed to fix the problem for me.

    http://connect.creativelabs.com/developer/Wiki/OpenAL Installer for Windows.aspx

    The past couple of X-Fi drivers (2-3 years running?) were missing the Control Panel in the installer, and that's why you couldn't get yours to show up. You have to extract the "VolPanel" folder from one of the older drivers (I used the CSL_PCAPP_LB_2_60_29 ones) by using WinRAR and install it manually that way.

    With that said, you can still change your sound card settings via the Audio Control Panel found in the Start menu.


    EDIT: I tried using the OpenAL installer Chiefeh linked, with the Heaven OpenAL32.dll removed, and it didn't seem to fix the problem. The OpenAL32.dll mod has been working fine for me however.

  • HectorHector Member Posts: 23
    I'm getting audio crackling and shuddering on a SoundMAX card. Any ideas?

  • funkyleetdoodfunkyleetdood Member Posts: 3
    I have always run my x-fi card in game mode, but no amount of switching made a difference, I had also downloaded the OPEN32.dll file from the net and still no joy.
    So I decideded to try the heaven benchmark program above. I downloaded the heaven benchmark program, installed it and nicked the OPENAL32.dll from the program files. I then put into the relevant BGEE directories.
    Blow me down if it didn't sort the crackling and horrible noises I was getting! X-fi is in game mode as always and the sound is as I remember it from vanilla BG (which was awesome). I haven't thoroughly play tested it yet but it is looking good thus far.

    onkelosuppo
  • ArthmoorArthmoor Member Posts: 9
    I too have had issues with crackling and static. X-Fi Gamer card installed. I was able to cut down on it some by setting a shortcut on the desktop directly to the baldur.exe file. Apparently the game launcher can interfere with this somewhat.

    That wasn't a complete fix though. I've always gotten static and music failures on the waylay screens even after doing this.

    I found a solution that works for me though. Using the Creative Alchemy program, all I had to do was go into that and add a game config for BG:EE. You'll have to specify it using the game path. Use whatever default settings show up. Navigate to where baldur.exe is located and add the profile, then make sure it's listed under the Alchemy enabled games.

    Bam. After bouncing around the map for about an hour deliberately trying for waylay screens, everything works. No more crackling, no more music cutting out, no more static. Too bad I didn't think to try this BEFORE finishing the game :P

    BTW, Alchemy can be used to badger any game that uses the old DirectSound protocols into working on Vista/Win7. You'll notice once this is set up that a dsound.dll file is present in the folder with baldur.exe.

    Vitalsine
  • ArabaniArabani Member Posts: 25
    Just one question-If it's same "old" sound protocol, why original bg1 works fine and bgee has sound problem?

  • ArthmoorArthmoor Member Posts: 9
    Couldn't tell you that. The last time I played original BG1 was in 1999.

  • FenghoangFenghoang Member Posts: 160
    edited December 2012
    Arthmoor said:


    I found a solution that works for me though. Using the Creative Alchemy program, all I had to do was go into that and add a game config for BG:EE. You'll have to specify it using the game path. Use whatever default settings show up. Navigate to where baldur.exe is located and add the profile, then make sure it's listed under the Alchemy enabled games.

    BTW, Alchemy can be used to badger any game that uses the old DirectSound protocols into working on Vista/Win7. You'll notice once this is set up that a dsound.dll file is present in the folder with baldur.exe.

    What directory were you using? I tried "C:\Program Files (x86)\Baldur's Gate Enhanced Edition\Data\00766" but I couldn't get it working. Also tried adding both of the higher tier directories as well to no avail. And yes, I made sure it was under the "Alchemy-enabled Games" column and have the latest version of Creative Alchemy (1.43.27).

    I've always suspected it was an Alchemy issue though, because the original BG games needed it for sound to work properly in Vista/7.

    EDIT: Actually, does anyone know the RegPath for BGEE? Maybe using the RegPath in Alchemy would have some results. BG's RegPath for example was: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\BGMain.exe\Path

  • onkelosuppoonkelosuppo Member Posts: 12

    On the downlaod site for the Heaven benchmark it says:
    Known Issues:
    Crash on Creative SB X-Fi cards
    Please switch your sound card in gaming mode to get correct work with OpenAL library.

    Can someone try the setting without changing the OpenAL32.DLL

    That might just be the reason. BF2 will also generates a fatal BSOD if one tries to play it with Xtreme Audio Settings in X-Fi's Entertainment mode. Took me weeks to figure that out.
    Ill try playing BGEE in game mode later on tonight.

  • onkelosuppoonkelosuppo Member Posts: 12
    Arthmoor said:

    I too have had issues with crackling and static. X-Fi Gamer card installed. […]
    I found a solution that works for me though. Using the Creative Alchemy program, all I had to do was go into that and add a game config for BG:EE. You'll have to specify it using the game path. Use whatever default settings show up. Navigate to where baldur.exe is located and add the profile, then make sure it's listed under the Alchemy enabled games.
    […]

    Yep, because all that Alchemy does is putting the OpenAL library files like OpenAL32.dll into the game folder you specified. So its a simple script. ;)

    So if putting these files there manually fixes the games sounds, Alchemy will do so to, plus its easier to use. ;)

  • ElfwineElfwine Member Posts: 1
    I have X-Fi Fatal1ty Champion. No luck with ALchemy, but OpenAL32.dll and OpenAL64.dll worked like a charm! Thanks!

  • DreadPirate_DuoDreadPirate_Duo Member Posts: 6
    Update: So far this has fixed my sound issues 100%.

    ALchemy did not work for me either, even after using the latetest official version for Creative (that I could find on their website/ftp). After looking at the file sizes, I'm thinking that the OpenAL32/64.dlls may support more "features" than the ones used by ALchemy... but that is just pure speculation.

    In my opinion, ALchemy is not that easy to use. It does such a simple job (copies DLLs into the same folder as an EXE) but you have too many options and it's clumbsy. I find it easier to manually drop the DLLs in the right folder. The only thing the registry option does is locate the folder with the game EXE in it and drops the DLLs in that folder. Honestly, Creative has never been good designing UI.. but I love the X-Fi's hardware capabilities. I'm sad the card is no longer officially supported (EoL).

  • LockLock Member Posts: 84
    edited March 2013
    I also experienced bad crackling and audio glitches using my Auzentech Prelude which uses the Sound Blaster X-Fi chip. The OpenAL installer didn't fix the problems and neither did the versions of the .dll that I already had.

    However installing the Unigine Heaven Benchmark and placing the openal32.dll from that into the Baldur's Gate folder appears to have fixed the issue. Thanks.

  • CerevantCerevant Member Posts: 2,314
    If there is anyone interested in testing a possible solution to this, please PM me.

  • TashTash Member Posts: 4
    edited July 2014
    I've got a solution to all of these issues!

    I've never had luck with the default OpenAL implementation in games. That's because most of them use "Generic Hardware" variant by default, and this may -- and will -- cause issues with some soundcards. If you use "Generic Software," most of the issues are gone. Now, BGEE doesn't provide the option to change OpenAL settings, so you'll have to download an alternate API implementation called OpenAL Soft here: http://kcat.strangesoft.net/openal.html#download.

    First, install the OpenAL redistributable provided by the BGEE developers (oalinst.exe); it's still required! Then, grab the appropriate package from the link above, extract it to wherever you want, go to Win32 (or Win64, if you have 64-bit OS) folder inside the package, rename the file "soft_oal.dll" to "OpenAL32.dll" (for both 32- and 64-bit OS), and then drop it into your BGEE directory. Alternatively, if it doesn't work on your OS, drop the file into your Windows system32 (32-bit) AND/or systemWoW64 (64-bit) folder(s).

    The sound issues should be gone. If you had problems with LOUD sounds prior to this, the volume levels should be fine now, too (except the sound files that may have different/altered peak values than the original BG1 ones; these still would need to be normalized by the devs/modders). If you have further issues with positional audio (e.g loud footsteps, blaring sound effects, incorrect sound sources) disable "Environmental Audio" in your baldur.ini.

    Post edited by Tash on
    Belvedere
Sign In or Register to comment.