Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

A simple fix for the slowdowns!!!

Hey guys, so first off, these are my specs. Gateway AMD Athlon 64 X2 Dual Core Processor 6000 + 3 ghz. 2942 MB of ram, Windows Vista 32 bit, and NVidia Geforce 6150 SE nForce 430.

Nothing fancy, but I have spent HOURS trying to get this game to run. Uninstalling, reinstalling, editing the .ini file, changing and unchanging just about every option I can and nothing worked until this.

Go to your resolution settings for your monitor and change it to 800x600. Yes, the graphics aren't the best but now the game works great. So, if running Windows VISTA, right click on desktop, choose personalize, click on display settings, slide the resolution all the way to the left. Last but not least, right click on your BG2.exe file and click on compatibility and then choose to run in windows 98/me mode. Now i am playing the game with zero lag. Hope this is some help. I will spread this around to the other posts because I have noticed some other people have the same specs that I have, and I have tried to get this to work on MULTIPLE machines and this is the ONLY thing I have found so far that works. Hope this is some help. I have been frustrated trying to get this to work for the past couple days and this simple fix had me off and running with no slow downs.

typo_tilly

Comments

  • Wandering_MinstrelWandering_Minstrel Member Posts: 197
    I pretty much did what you said although more recently I would use the 1024x768 resolution. I just ordered a graphics card from amazon today so things should run smooth in 1280x720 mode. I could run it in 1920x1080 but everything is way too small for my eyes in that resolution.

  • shadedenmityshadedenmity Member Posts: 11
    @KeaponLaffin5 I finally broke down and bought and installed an NVidia GeForce GTX 650 ($100), and now BG2 runs absolutely amazing, so good decision in buying the graphics card! I should have done this weeks ago.

    Wandering_Minstrel
  • Wandering_MinstrelWandering_Minstrel Member Posts: 197
    This is what I ordered: http://www.amazon.com/gp/product/B00966IU4M/ref=oh_details_o00_s00_i00?ie=UTF8&psc=1 . It is an EVGA GeForce GTX 650. I had several other games that were way too laggy so this should solve that issue.

  • Wandering_MinstrelWandering_Minstrel Member Posts: 197
    The graphics card I ordered finally came today. It works like a charm. No more lagging / slowdowns on my BGEE / 2EE and other games.

  • Raphite01Raphite01 Member Posts: 20
    How the heck can an ancient game that just involves a modest handful of sprites on the screen be requiring these new graphics cards?

    Wandering_Minstrel
  • chiasmchiasm Member Posts: 23

    Hey guys, so first off, these are my specs. Gateway AMD Athlon 64 X2 Dual Core Processor 6000 + 3 ghz. 2942 MB of ram, Windows Vista 32 bit, and NVidia Geforce 6150 SE nForce 430.

    Nothing fancy, but I have spent HOURS trying to get this game to run. Uninstalling, reinstalling, editing the .ini file, changing and unchanging just about every option I can and nothing worked until this.

    Go to your resolution settings for your monitor and change it to 800x600. Yes, the graphics aren't the best but now the game works great. So, if running Windows VISTA, right click on desktop, choose personalize, click on display settings, slide the resolution all the way to the left. Last but not least, right click on your BG2.exe file and click on compatibility and then choose to run in windows 98/me mode. Now i am playing the game with zero lag. Hope this is some help. I will spread this around to the other posts because I have noticed some other people have the same specs that I have, and I have tried to get this to work on MULTIPLE machines and this is the ONLY thing I have found so far that works. Hope this is some help. I have been frustrated trying to get this to work for the past couple days and this simple fix had me off and running with no slow downs.

    Worked for me but its frustrating that the original BGII (which I also have installed on this same computer) works just fine without the need for tweeks.

  • chiasmchiasm Member Posts: 23
    By original I mean the original disc version I bought some 10-12 years ago.

  • Wandering_MinstrelWandering_Minstrel Member Posts: 197
    That graphics card I got back in January? It was working fine until after I updated it sometime in March. When I play a couple games such as NWN2 it will crash randomly. What it does is freeze the whole computer and reboot it. I have tried looking for a solution to my problem but to no avail.

  • FranpaFranpa Member Posts: 637
    edited August 2014
    @KeaponLaffin5

    This is an old thread but you can turn off the automatic reboot function (Windows Vista and newer will automatically reboot if a Bluescreen error occurs). Now you can see what is the culprit and do some further digging around the internet for a solution.

    Maybe there is a firmware update for your video card?

Sign In or Register to comment.