Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Higher level cleric and mage spells not working in Baldur's Gate 2 Enhanced Edition

ARKdeEREHARKdeEREH Member Posts: 531
I just got a new computer and installed Baldur's Gate 2 Enhanced Edition on it. I noticed that my 7th level cleric and 9th level mage spells are not working despite my characters having them memorized. Other spells seem to work fine. There are several ways in which my game probably would not be considered typical settings, so I am not sure what may be the cause of this.

I have a large number of mods from Big World Project installed on this game. I have played Baldur's Gate for many years but I could never get Big World Project to work on my previous computers. I do not like to start new games with nothing, so I instead import my characters into the beginning of each new game and use EE Keeper (or Shadowkeeper with the older games) to recycle the characters' XP once they hit the level cap so that they can keep getting new skills and so forth in spite of the level cap. Since my main Baldur's Gate 2 PC is 7th playthrough, I wanted to make the game balanced so that it would still be challenging for him. As a result, I chose all the most difficult settings among the stable mods of Big World Project. This means that without the multi-playthrough character that I intend to use it would probably be effectively impossible to even get out of the Irenicus dungeon much less have a very interesting game.

I tried to import the character file from my 7th playthrough PC into BG2EE on my new computer, but for some reason it did not work. The computer crashed to desktop every time. I also tried importing the character file of a different PC from when I played as a female PC which is in its 4th playthrough, but this had the same result. I also tried putting saved games from my old computer's original Baldur's Gate 2 and from Baldur's Gate 2 Enhanced Edition into the saved games folder for Baldur's Gate 2 Enhanced Edition on my new computer. Ironically, my new computer's BG2EE would not acknowledge the saved games from my old computer's BG2EE, but it would load some really old saved games from original Baldur's Gate 2.

The result is that I have now been playing Baldur's Gate 2 Enhanced Edition with Evice (who I have played with for 7 playthroughs) but on a really old saved game from 2011 when he was only 4th playthrough. EE Keeper will not acknowledge my game so I cannot edit him back to where he should be after his additional 3 playthroughs, which is quite annoying.

Anyway, since 4th playthrough Evice seemed like the best that I could do given the circumstances, I loaded a saved game of him in the Irenicus dungeon in the Enhanced Edition and found that the Big World Project features worked. I played that for a while but then found when I went to use them that the Dragon Breath and Energy Blades spells did not work for him. Viconia also has Energy Blades memorized and she cannot use them either. This caused me to get stuck on the Big World Project Island that that guy in the Bridge District sent me to and has also severely impaired my ability to fight liches and so forth.

Does anyone know why this is happening and what I can do to fix it? I don't know if this is caused by Big World Project, some new update to BG2EE, or some other reason.



  • ARKdeEREHARKdeEREH Member Posts: 531
    I just successfully cast the imprisonment spell, so apparently it is just certain high level spells that do not work and not all of them. So far energy blades and dragon breath still do not work, which is annoying because they're my two favorite spells which I normally use the most often.

  • GallowglassGallowglass Member Posts: 3,356
    Energy Blades and Dragon Breath certainly work in unmodded BG2ee, so it's a fair bet that it's some problem in your mod setup which is stopping them from working.

  • AionZAionZ Member Posts: 3,034
    If you use the SCS component which turns HLA spells into abilities rather than spells then load a save where you had HLAs inside the spellbook the spells will not cast. From what you've said it's probably because you're using a very old save with a different bunch of mods from your current ones. This is just one of the smaller reasons why using old saves with new mods is a very very bad idea.

    Imprisonment, btw, works because it's a 9th level spell, not an HLA.

Sign In or Register to comment.