Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Aerie's romance stuck at last conversation in SoA

adcoonadcoon Member Posts: 3
I've been replaying Aerie's romance, but it seems to be stuck.

I'm in chapter 3, and the last conversation I had with her was the one where she offers to sleep with me. I told her it was better to wait, having played it before and knowing the outcomes. I know there is one more conversation in SoA, the morning after, though it is several mornings later at this point and still no word from her.

When I go to rest at an inn, I can sometimes hear the romance music start to play once the rest is over, but Aerie doesn't start talking and when I close the Inn window, the music returns to normal. It seems like she's trying to do something but is stuck, so I've tried moving her right up next to the PC before resting, to no effect. She just stands there.

I threw Jaheira out of the party as soon as I got out of Irenicus' dungeon, before Aerie joined the party, and I've never had Neera or Haer'dalis in the party at all.

The AerieRomanceActive global variable is set to 2, and the local LoveTalk is at 47.

What's going wrong? What can I do to get that last conversation to play?

Comments

  • AKrugBierAKrugBier Member Posts: 107
    Yepp, she doesn't talk with you, because there is no State Trigger in the dialogue file for when LoveTalk is set to 47 (the next love talk would be 48).

    I think this solution should work:
    https://www.sendspace.com/file/0a5nws

    Put the .BS file into your scripts folder (/scripts), start the game, assign the "AERIEFIX" script to Aeria in the customization menu (be sure to have party AI set to "ON"), select Aerie ingame and press "F" once, her LoveTalk should be now set to 48, and the next morning she will talk with you.

    After this, you can remove the script from her again.

  • adcoonadcoon Member Posts: 3
    Thanks, but it seems I fixed it by resting in a wilderness area instead of an inn. It's so rare that I rest in the wilderness, but somehow that seemed to do the trick, because the conversation started just fine. Not sure why it's not working when resting in an inn, though.

Sign In or Register to comment.