Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

#10932 [All] The Summoner's Staff's abilities bug still exists in IWD:EE 1.4.0 on iPad

Playing the first time through, I (re)discovered this same (old) bug mid-game, but I see the topic is archived here, though the bug fix is apparently not included in the latest release 1.4.0 (for iPad anyway). Any plans to fix it and include it in a later release? Real bummer for my mage. I get no options to choose between the three spell abilities when I press and hold on the Summoner's Staff +3 icon. Can only use it as a melee weapon.
Thanks for any info.


  • elminsterelminster Member, Developer Posts: 16,186
    edited September 2016
    10932 is a different issue than what you are describing.

    Are you pressing and holding on the icon from your inventory screen?

  • SchmaehgolSchmaehgol Member Posts: 9
    Sorry for the noob post. I tried it again with the backpack button on the lower menu bar and it worked with just a quick press on the summoner's staff icon, which brings up the correct three option menu to choose the effect from. So no bug here, just unexpected that I don't have to press and hold on the iPad to emulate right clicking as elsewhere. Thanks for making me look at it again. The one thing that I don't like about the iPad port is this press and hold emulation of the right click. It was much easier playing BG1&2 on PC with a mouse! The worst is when trying to do a right click and drag to reorient the party formation, since it drags the screen while holding down, too.

  • SchmaehgolSchmaehgol Member Posts: 9
    Still having trouble with this during combat, by the way. I had tested it outside combat and it had worked fine as described above, but during combat last night it seemed to lose focus on my mage wielding the staff when I clicked on it in the use items menu, and it never came up with the three options to choose from, moving on to another character and ignoring my mage's desired action, apparently. I'll keep trying, but it looks to me like it's use is limited to non-combat functionality, when the wielder doesn't have to compete with other character's simultaneous actions (or was it due to the auto-pause in battle interrupting focus?). I'll experiment some more tonight.

  • sanwablosanwablo Member Posts: 18
    Has this issue been fixed? I can only use the staff as a melee weapon. Where should the menu show up? In the bag, while equipped in the equipment menu, or while equipped during combat/in the map?

  • sanwablosanwablo Member Posts: 18
    So it shows up with 11 charges in the pouch but I can't use it.

Sign In or Register to comment.