Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


There's currently a forum problem with avatars not showing in reactions.
Neverwinter Nights: Enhanced Edition has been released! Visit to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Black Pits 2 crash *a* *lot* on Mac (v1.3)

Subject says it all - trying to play through Black Pits 2 with the latest version in the Mac App Store, and the game is crashing after every 2 or 3 fights. I think 3 fights in a row is my current record.

The annoying thing is that it crashes after you win the battle, so all the hard work to make progress goes to waste, and you have to repeat the previous chore without knowing whether it will all be for naught next time too. This is frustrating, especially if I forget which sequencer effect a mage has prepared on a given save, or if I forget to immediately save after every significant action (shopping, post-battle, pre-battle, etc.). I am also nervous that the semi-frequent saves may be part of the trigger for the problem?

Playing on a late 2016 MacBook Pro, 16Gb RAM, OS Sierra (not upgraded to High Sierra yet) so system resources should not be a problem.


  • tbone1tbone1 Member Posts: 1,926
    edited January 3
    I haven't played either of the Black Pits in quite a while (might need to do another run through them) but I have not encountered this at all. For the record, I am also on 1.3 on a Mac. Your specs look fine, so I doubt that is it.

    Is this something that happened recently? I mean, did you play it before with no problems? Do you have this issue only on BP2; does BP1 do the same thing?

    EDIT: And of course, which mods do you have installed, if any?

  • GreenWarlockGreenWarlock Member Posts: 1,335
    BP1 played fine. I have a similar issue on my iMac, which has upgraded to High Sierra, but it does not feel as pronounced. The iMac is 5k with 32Gb RAM, but I doubt any RAM over 2Gb (plus another Gb or so for the OS) will have any effect.

    I don't remember having this problem before, but It is quite a while since I tried the black pits.

  • GreenWarlockGreenWarlock Member Posts: 1,335
    Just tried again, and it crashed on the first fight, particularly annoying as I made it through by the skin of my teeth with just my last guy left :(

    Not sure if it is relevant, but the party is made up of 6 fighters, created in BP1, and imported by character file after making it out of Baeloth's Pits, as there is no way to import a whole game save on v1.3.

  • GreenWarlockGreenWarlock Member Posts: 1,335
    ... and again, just crashed after the first battle, and I'm still in tier 1. Time to call it quits for a while, I think :(

  • ArunsunArunsun Member Posts: 1,571
    I have had this issue on Android for a while on v1.3. Googled it, apparently no one else had that. Some day it disappeared and never occured again, for no apparent reason.
    Used to crash at the end of the battle, when you're supposed to get back into the shop area.

  • GreenWarlockGreenWarlock Member Posts: 1,335
    Thanks @Arunsun, that is exactly what I am seeing.

    I am making a little more progress again after rebooting the notebook. This particular session had an uptime somewhere in the 6-12 month range, so it could be some internal tick count variable getting to extreme values - that is my best guess at the moment. For those of us old enough to remember, Windows 95 (and 98) used to crash after 48 days of uptime as the tick count variable for the OS rolled over!

    Wonder if the dev team can have a special box running that never reboots, just so they can test in such odd circumstances...

  • GreenWarlockGreenWarlock Member Posts: 1,335
    Never mind, back to crashing after even the first fight again, so unrelated to machine uptime. I am running out of clues.

Sign In or Register to comment.