Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

8155 Server 20-30ms ping, with 8156 now 200 - 350ms & can't connect to server without favorite list

HimmelweissHimmelweiss Member Posts: 72
edited February 2018 in Technical Support
Since the 8156 update the connection to the server is rather slow.
With 8155 i had 20-30ms, now it is 200 - 350ms. And i have no idea why.
Sometimes the ping even jumps to 500ms...

Also, since 8156 i can't seem to log into my server with ne normal serverlist ingame (punching fails).
It only works as soon i add my server to the favorite list and clicking in the favorite list on my server to connect.
No idea why, but that's how it works.
+ the favorite list doesn't keep/save the servers i add there.

Anyone else experienced similar issues since 8156?

In 8155 everything was fine.

Comments

  • SnottlingSnottling Member Posts: 73
    Yes, before 8156 my ping was 10ms, now it's around 140ms. I can connect via the list as usual, though.

  • nivniv Member, Moderator, Developer Posts: 400
    Hi!

    Please ignore the Ping column. Currently, it shows the latency as the masterserver sees it (which sits in NY!). We're thinking about replacing it with something else, as it is a useless metric on connection quality in general and shouldn't be used to judge server hosting quality.

    The Favourites view not saving is also a bug! So many bugs, sorry about that. We're doing some fairly heavy changes on the whole multiplayer UI and it's nowhere near done.

    As to the Favourite-only connection issue; that's weird. What's your server named?

    JuliusBorisov
  • HimmelweissHimmelweiss Member Posts: 72
    edited February 2018
    @niv

    Servername: Test
    Modul: Base

    Server is only up if my computer runs, so for the next 6 hours or so it should be ok.
    Server is just an Oracle VM in Windows.

    It's just a Persistent World Test (NWNX) with only Base Systems like HCR, ATS, CNR, Housing.
    Basically just testing a lot of systems and heavenly cleaning the code.
    Like removing the 20 different versions of GetPersisten and SetPersistent functions and a lot of other duplicated functions and files with all the systems added.

    Removed the player password, usualy it is protected since i am just testing and cleaning code.

    Really have no clue either why i can't connect in the normal list but in the favorite list. It is kind of funny :D

  • nivniv Member, Moderator, Developer Posts: 400
    @Himmelweiss Works on my end.

    I bet what you are seeing here is that your router does not support NAT loopback. This is a known issue.

    Technical details:
    - The masterserver advertises your public IP, as expected.
    - Your game client sees this in the data returned and attempts to connect there. The attempt ends up at the LAN side interface of your router.
    - Your router does not do NAT loopback (aka hairpinning, reflection) and thus the connection attempt fails.

    We're looking into how best to fix that (LAN discovery is in progress), but your best bet right now is to simply use Direct Connect to the internal IP.

    JuliusBorisov
  • HimmelweissHimmelweiss Member Posts: 72
    edited February 2018
    okies, understood, yeah direct connect or the glory favorite list :D
    Thanks for the info!

    My Router indeed doesn't support NAT loopback anymore. It was removed a few years ago with an firmware update.

    JuliusBorisov
Sign In or Register to comment.