Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[Mac] Unplayable due to video issues after 8159 update

jwwjww Member Posts: 31
Hi folks,

All the previous patches played fine on my Mac, but after updating to 8159, I'm having some fairly significant video-related issues. They seem to fall in two major categories:

First, something is wrong with the resolution settings. When I first started the game after updating to 8159, or if I select any resolution from the list within the game, the clickable areas of the UI elements are in the wrong place (either a little bit wrong or so wrong that I can't find them, depending on the resolution).

If I manually resize the window, the UI elements become clickable in the correct locations.

In both cases (a resolution from the list, or a manually resized resolution), the window is about twice the width and height it's supposed to be according to the resolution. My screen is 5120x2880, but right now, an NWN:EE window that claims to be 2219x1346 is taking up almost the entire screen. If I select a resolution like 2560x1440 (which should be one quarter of my screen), the window becomes so large that I can't access the lower-left corner to manually resize it anymore, and the UI is so far off that I can't click it to change the resolution again, so I have to adjust the resolution setting in nwn.ini.

-----
I can work around the above issue by manually resizing the window, but the second issue is making the video extremely choppy, enough to cause eye strain. I turned most of the graphics settings down or off, and turned off everything under "Advanced Frame-Buffer Effects", and as far as I could tell, there wasn't any improvement at all. Turning off "Visual Effects High Enabled" helped a little bit, but not enough to really let me play the game.

-----
Is there a way to return to the 8158 patch? Or does anyone know if there's a specific graphics setting that I'm missing that would make a bigger improvement?

(For sake of completeness, I should note that I did update to OS 10.13.3 today from an earlier 10.13, but I don't know whether that would have affected anything.)

JuliusBorisov

Comments

Sign In or Register to comment.