Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Neverwinter Nights: Enhanced Edition has been released! Visit to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Bug in Throne of Bhaal : My character can't level up

Hello everybody,

I've been replaying Baldur's Gate now that I got the EE, and everything was perfect until ToB.

I've only realized now (I just arrived in Amkehtran) that my shaman Bhaalspawn is stuck at lvl 22. Trying to see where this bug could come from, I've looked at all my saves, but since the beginning of my run, he is stuck at lvl 22. He continues to accumulate XP, but the "Next level" is still showing "-1" with the "Ready to level up" line in grey under its portrait. He is currently at 5407175 px (enough for the 24th level).

I've been trying to see with EEKeeper if I could find...something to trigger the lvl up, but I'm not good enough with it and I fear I would do more harm than good :(

I don't really know if you can help me, but I welcome every idea, since I don't really want to go back from the beginning.

I hope you can help me (and save my team from annihilation) !


  • BubbBubb Member Posts: 366
    That's odd. The first thing I thought could be the issue was that your Shaman got assigned an invalid class, but that normally crashes the game (when you level up, which it allows), so that idea is out. The "-1" part almost sounds like the xp tables for the Shaman class aren't set up correctly; are you currently running a modded install? Also, what is your game's version number? If you want you can upload your save here, and I'll take a look and see if I can find anything wrong.

  • MinitailsMinitails Member Posts: 5
    edited May 2018
    I also realized that my character is like that since SoA, not just in ToB.
    I'll upload my most recent save of ToB.
    My game is modded (I wanted to try the Ascension mod, I used the "BigWorldProject Ascencion mod" to be able to use it with the EE.
    But I modded it 3 days ago, and the problem seems to be older than that (because already in SoA)
    As for the game's version number, where can I find it ?
    Thank you to take a look at it :3

  • BubbBubb Member Posts: 366
    You can find the version number here:

    In order to upload a save, you need to zip up its folder. For example, if I were to attach my quicksave slot, I would navigate to C:\Users\username\Documents\Baldur's Gate II - Enhanced Edition\save\ and zip up the folder "000000001-Quick-Save". Here is a guide if I wasn't very clear: link

  • MinitailsMinitails Member Posts: 5
    edited May 2018
    Thanks, the version is : v2.3.67.3
    Mmmh, I always get the message "The file failed to upload", I tried with WinRaR and WinZip :s That's why I tried to put the file on a dropbox
    I'm really cursed T_T
    I'll try anew tomorrow after a good sleep

    Post edited by Minitails on
  • BubbBubb Member Posts: 366
    edited May 2018
    So, I looked at your save game, and it looks completely fine. In fact, when I look at your Shaman, the level up screen works correctly:

    This narrows it down to something in your installation, most likely a mod, or maybe some corrupted game files. I think the next step would be for you to verify your game's files - whatever client you use to play the game should have the option available. A quick google search should tell you where to look, or if you can't find it, you can tell me what client you have and I'll look around.

    If verification doesn't work, it has to be a mod-caused problem. In this circumstance, I would advise you to completely uninstall the game and try a reinstall (this should clear all mod-related content). If you are adverse to clearing all of your mods, (this would most likely break your ToB saves), you can zip up your "override" folder (located in your game's base folder, this folder holds all mod content) and I'll look and see if any of those files are causing your predicament.

  • MinitailsMinitails Member Posts: 5
    Ok ! I'll try this tomorrow, thanks a lot ^^
    I'll come back here after that.

  • MinitailsMinitails Member Posts: 5
    It worked !
    I uninstalled/reinstalled the game and I could finally level up. Then I tried to reinstall the mod, and it still work.
    Thanks for your help :)

Sign In or Register to comment.