Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Planescape: Torment: Enhanced Edition has been released! Visit www.planescape.com to purchase and check for details. Planescape: Torment: Enhanced Edition Official Soundtrack is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Lothander Missing

CalibrationsCalibrations Member Posts: 13
edited January 2013 in Fixed
I was poisoned by Lothander and Marek in Baldur's Gate in Chapter 5. I've retrieved the Gaes scroll from the Umberlee Temple, but when I go to The Blade and Stars Inn where Lothander is supposed to be, he's not there.

I'll use the CLUA to make him appear if I have to, but I'm not sure where to add the cheats=1 line in the baldur.ini since there's like 20+ instances of Game Options in the file.

I don't want to use a command to just cure myself because I'll miss all the exp. Would be nice to correct this.
Post edited by Jalily on

Comments

  • MadhaxMadhax Member Posts: 1,416
    It's been a while since I dealt with the Marek/Lothander quest in Baldur's Gate, so hopefully someone can help me out.

    I've acquired the geas removal spell (through much trickery, I should note. Pickpocketed the wisdom tome, then refused to hand it over and slaughtered the entire Umberlee temple =D). However, Lothander isn't where he said he'd be, in the Blade and Stars inn. I read online that he should be on the second floor, but he isn't on any of the three. I've rested, checked behind pillars just in case, no luck.

    I tried consoling him in with CLUAConsole:CreateCreature("Lothan"), but when I talk to him all he says is something along the lines of "You asked the wrong question! Now we're all dead, you fool!".

    Anyone have any ideas of how to fix this?
  • AranthysAranthys Member Posts: 668
    I had the same problem with lothander... but CLUAConsole'd him and it worked fine for me.
  • MadhaxMadhax Member Posts: 1,416
    Did you use the same command as me? I've never actually used the CLUAConsole before so I don't know if I'm doing it right.
  • MadhaxMadhax Member Posts: 1,416
    Ah, figured it out. The "wrong question" he was referring to was because I had gone back and solicited the seer's services for a different answer, which I guess broke the quest. I went back, asked the seer the original question, then consoled in Lothander twice: once to give me the quest again, and again to turn it in. Seems I'm back on track.

    You did help, though, @Aranthys. Thanks for letting me know I was going in the right direction!
  • KalbKalb Posts: 0
    Hi,
    i cannot finish the Lothander/Marek Quest, which leaves me to die...
    I have the Geas removal scroll and all, but Lothander or Marek are simply no where.
    I checked the Blade and Stars and the Mermaid...nothing.

    Anyone has an idea?
  • ShandyrShandyr Member Posts: 6,668
    If Rasaad is in your party:
    Balquo said:

    Go to the Blade and Stars inn and remove him from your party. Lothander should appear then. Is it a known bug and should be fixed soon.

  • BalquoBalquo Member, Developer Posts: 2,666
    But this should be fixed now. Unless of course, you haven't updated your game.
  • goggolorgoggolor Member Posts: 4
    edited March 2013
    Isn't fixed; it's happening to me now. I thought doing the part of Rasaad's quest that happened in that room would change things; it didn't. I also did the Oberon's House job, because I didn't want to have to schlep all the way back to Nashkel on a 10-day time limit (I wanted R. to get the exp.).

    ANYWAY, tried removing Rasaad from the party; Lothander still didn't show. Do I need to wait? How long? Do I need to do that CLUAC thing (I will need talk-to-me-like-I'm-stupid instructions)?

    This is on OSX, latest version, checked today. Help?
    Irial
  • goggolorgoggolor Member Posts: 4
    Anyway, I figured out how to do the CLUA thing, and fixed it that way. Now I feel all dirty.
  • MrDarthMrDarth Member Posts: 5
    Still not fixed. If you talk to the seer again before you finish Lothander's quest, it will break the quest, doesn't matter if you have Rassad in your party or not. Surprised this is still in the EE, as this bug already existed in the vanilla BG.
  • MathsorcererMathsorcerer Member Posts: 1,634
    The problem does seem to be in Lothander's dialog. Even if you have the necessary scroll, if you ask the diviner a different question his dialog will set LothanderMove to 9 but the section of Lothander's dialog where you get his half of the antidote is keyed to LothanderMove = 2.
    When you talk the the diviner and you ask the correct question it will set LothanderMove to 4; if you then speak with Lothander he will mention the Water Queen's house, sets LothanderMove to 2, and he goes to Blade&Stars. If we edit the action associated with state 12 of lothan.dlg to SG("HelpLothander","GLOBAL",2) then set the trigger for state 13 to Global("HelpLothander","GLOBAL",2) it won't matter whether LothanderMove is still 2 or you set it to 9 by asking the diviner a different question. This also avoids questions how you got the scroll, whether you bargained with Jalantha for it or killed her for it. I am going to make this change and see how it works.
  • hook71hook71 Member, Developer Posts: 515
    edited June 2013
    I have reported this issue in the bugtracker now. Until a patch is released CLUAConsole:SetGlobal("LothanderMove","GLOBAL",2) should fix it. If you can't find Lothander he can be spawned with: CLUAConsole:CreateCreature("LOTHAN")
  • MathsorcererMathsorcerer Member Posts: 1,634
    Okay, it works--changing lothan.dlg so that state 12/response 1/action 3 applies SG("HelpLothander","GLOBAL",2) and the state 13 trigger is Global("HelpLothander","GLOBAL",2) makes it so that it doesn't matter whether you go back and ask the diviner another question before trying to meet Lothander. There was one final piece I had to fix--I had to correct ar0106.bcs so that it will spawn Lothander by checking Global("HelpLothander","GLOBAL",2).

    I am not going to wait for a patch, especially when I can fix something relatively easily. Anyone else who wishes to edit their game as I did may do so; I have already shown what needs to be done. If you are uncomfortable editing your game then I suppose I could send you the .dlg and .bcs files with the changes; the dialog.tlk file has not changed so dropping the files in the override folder will suffice to apply the fix.
  • SouthpawSouthpaw Member Posts: 2,009
    I had the same problem...
    got poisoned...went to the temple of Umberlee, killed them all to get the Book and the scroll, went to the Inn and no Lothander.

    I had to reload from an earlier save position, get poisoned again, get to meet Lothander (see the seer that tells you how to get rid of the poison), go and help the little cleric of Umberlee outside BG (voluntary step), go to the Eastern part of the city, where the priest asks you to get the young boy's body, go to the Temple of Umberlee, ask for the geas scroll, go to the other temple and pay for the Book, take the book to the Temple of Umberlee, slaughter everyone out of frustration, loot everyone, finish the other quests, meet Lothander, get cured, kill Lothander...uff!
  • Dark_NeuronDark_Neuron Member Posts: 58
    edited November 2013
    Still not fixed. This is patch 1.2.
    However, I got the quest in a previous patch (if that is relevant). Stole the book, met the bitch priestess, handed over the book, killed the entire temple and took the book back, went to Blade & Stars: No Lothander on any floor.

    Frustrating...
  • DraedrusDraedrus Member Posts: 1
    edited December 2013
    Hi, December 8 and still not fixed

    I got the scroll of removal from umberlee temple and gone to the blade and stars inn but lothander is not here... My last entry in the journal is that one who tells me to give the sacred book to the umberlee temple... Any ideas ? I don't want to use CLUA console for the moment or other home fix like that.

    I do not have rasaad in my team, just Imoen and my two own characters.

    [edit] I think the problem comes from the priestess when she give the scroll, the quest state is not up to date...
    [edit2] Changed my mind and tried with CLUA, this worked in making a lothan with CLUAConsole:CreateCreature("LOTHAN")... It seems that the npc is not created after we get the scroll, quest done...

    Thank you in advance !
    Post edited by Draedrus on
  • BatharBathar Member Posts: 4
    This problem is still not resolved on the ipad. I'm not sure why this bug hasn't been fixed after so long? I'm equally confused why the game is being sold with this game ending bug?
  • Cerulean62Cerulean62 Member Posts: 1
    Hello, although this post is old I found a solution;

    As it turns out, Lothander was just next to the fortune teller all along where he was earlier. Hope this helps.
Sign In or Register to comment.