Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Bug in Rasaad's quest area? (spoilers!)

EleutherosEleutheros Member Posts: 70
edited December 2012 in iPad (Archive)
So I came upon the two poor souls locked up in the Dark Moon Monk-temple, the riddle seemed like a familiar one and I asked what I thought was the correct question. However, when I tried to open the door it was locked. I proceeded to use Knock (since I'm all out of thieves for the moment) and the door flew open. I then openend the other in the same way. At this point I would have expected something to happen - either a conversation where the two prisoners are happy that they have been rescued or a major trap going of, but nothing happens. If I try to speak to them I just get the "X has nothing to say to you"-response.

Is this a bug, or have just done something wrong?

Btw, sorry if this has been explained before. I have tried searching, but I couldn't find a response to this.

Post edited by Eleutheros on

Comments

  • IllydthIllydth Member, Developer Posts: 1,641
    edited December 2012
    As far as I know @Eleutheros this one is new to me, and I've tried to keep up to date on all the bugs on the iPad. (and THANK YOU for searching first!)

    Can ANYONE out there confirm? Perhaps this is a problem using knock to get around what is only getting triggered by answering the riddle the right way?

    If we can confirm it @Eleutheros I'll get it added to the unofficial/official bugs list for the iPad thread.

    Eleutheros
  • AristilliusAristillius Member Posts: 873
    Interesting. This might not be Ipad specific. Have you tried forcing the locks? Might be a workaround.

  • IllydthIllydth Member, Developer Posts: 1,641
    edited December 2012
    I believe that's the problem he's experiencing...he HAS forced the locks (using knock) and the appropriate interaction isn't happening.

    Even though this isn't confirmed, I"m going to go ahead and throw this into the "bug" thread anyway. See if we can get some kind of response here with some visibility.

    I should have asked: Does this cause the quest to be unable to be continued? Have you tried to continue with the quest beyond this point to see if you are capable of finishing/completeing it or does this "stop" the quest progression?

    Once you "Asked what you thought was the correct question" and the doors remained locked, are you able (after unlocking the doors) able to find a way to continue the quest line? Were you able to "correct" the answer and continue on or does this pretty much lock the quest from completion?

    Eleutheros
  • CuvCuv Member, Developer Posts: 2,535
    Ah yes, this has been reported. Should be fixed next update.

    Eleutheros
  • EleutherosEleutheros Member Posts: 70
    Thanks to all of you for a great response, and good to hear that it most likely will be fixed. It really makes sense to take the effort to check out bugs and report them when the developers are churning out fixes at this rate!

    I'm not sure if I understand what you are asking @Illydth - I'm unable to continue with the quest relating to the two guys who are locked up (I can't enter into dialogue with any of them), but I can (and did) just go on with Rasaad's quest and completed the area without any other problems.

    The only other thing I struggled with during his quest was the apparent troll cave to the north east of the cloud peaks-map. Are you supposed to be able to enter it? I can usually find the sweetspot when paused, but after clicking for several minutes I gave up on this one ...

  • EleutherosEleutheros Member Posts: 70
    I thought I could add a couple of details:

    iPad version: 3rd gen, 64GB with 3G

    "Knock" was only used to force the doors after the conversational way failed to give any response, i.e. after the conversation where I asked my question nothing happened and the doors where locked.

  • IllydthIllydth Member, Developer Posts: 1,641
    Thanks! I think that gives enough info for the bug to be looked into. And it sounds from Cuv that it's already been reported other places and is being looked at (I suspect this bug will be found in all versions.)

    Eleutheros
Sign In or Register to comment.