Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Possible very easy solution for lag problem

When I booted up the game, the lag was so horrific as to make the game unplayable. I researched the issue and there seems to be an insolvable problem related to Intel drivers -- people have posted all kinds of crazy attempted fixes involving .ini file edits, driver hacking, etc, many of which don't work.

On my computer there happened to be a stupidly easy solution I haven't seen elsewhere.

I can't promise this will work for everyone, but in the event that it does, please check this before you do anything crazy with your computer.

When I right-click on the shortcut to run the game, one of the options that appears is "Run with graphics processor -->" After the arrow there are two options: "Integrated graphics (default)" and "High Performance NVidia Processor." I picked the second one -- that is, NOT the default one -- and that fixed all the problems. The game plays just as smoothly as you would expect.

I do have a high-end gaming laptop, so this "high performance Nvidia" thing might not be on everyone's computer. Still, before you do something insane like install freaking Linux (!!) so that you can play BG, check to see whether you've got an option to use non-Intel graphics to play the game, as that will just about magically fix everything.

Sign In or Register to comment.