Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Why are custom sounds still not working?

TiaxRulesAllTiaxRulesAll Member Posts: 198
edited February 2013 in Fixed
I know we are on the holiday break at the time of my posting so i get the lapse right now but between the devs and the community i'm surprised this has not been fixed yet. I really love the customisation that the original series offered the player. It's hard for me to go back to a few mediocre soundsets. I have gone through the proper steps and placed them all into the sounds folder, can hear them in character creation, but only one sometimes two sounds ever fire in game.

Its been reported many times, in better detail, in other posts around here. This SEEMS like it would be a very minor snafu in code to deal with but admittedly I know only little about programming. I do know there are tons of skilled modders in the community and i'm almost more surprised that they haven't peeked into the code a little to see whats up.

Currently, this and the lack of multiplayer "enhancement" have prevented me from playing this game as I bought this mainly for the purpose of me and a friend to play a multiplayer game with 6 custom created characters. We need these soundsets and while I'm aware of and capable of using these "workarounds" my friend, 800 miles away doesn't know jack about them and needs some ease of use upgrades... as promised.

Can somebody please clue me into what is being done to get this fixed.

Post edited by Coriander on
SenashDarkDoggKorlamaqcertus
«13

Comments

  • XantarrXantarr Member Posts: 16
    edited November 2012
    Custom soundsets do not play in game. They should play in game.

    Additional details: after putting the sounds (with the correct naming schemes and everything) into the correct folder (/lang/en-US/Sounds), and proceeding to select the soundset in-game, in the actual SELECTION MENU, all of the sounds play correctly (and in the correct order, as the Play button is continually pressed). However, when selecting and moving the character in-game, they do not play correctly at all. However, if I rename the soundset to, for example, "Female1X.wav" where X is the corresponding suffix for the particular sound (and delete the default included "Female1X.wav" each time, that is, essentially replace Female1 with my own sounds), it WILL work. Additionally, it will display the text associated with what Female1 would have said in the text box in-game. Renaming the soundset to "Femabe1X.wav" (etc.) will cause it to fail again. It appears then that a custom soundset only works right now if it is associated with a particular in-game-text file of some kind, if that makes sense. Otherwise it fails.

    Post edited by Balquo on
  • theJoshFrosttheJoshFrost Member Posts: 171
    I didn't try renaming my soundset like you did, but I experience this problem to. My character will only say one thing when given a command, and will not say anything when selected. The files are not too long, and they work with the original baldur's gate.

  • XantarrXantarr Member Posts: 16
    I believe I've isolated the issue. The problem is that the talk table (dialog.tlk) does not contain dialog for custom soundsets, and so it will not work. In BG1 there was no talk table for the soundsets, so there was no incompatibility issue, and custom soundsets were thus easy to implement. Interestingly, the male Default voice in BGEE seems to be facing a similar, although slightly different, problem.

  • Capac_AmaruCapac_Amaru Member Posts: 21
    edited November 2012
    I am also having this problem. Is it possible to add the custom soundsets to dialog.tlk?

    Not with my level of coding skill...

  • Capac_AmaruCapac_Amaru Member Posts: 21
    edited November 2012
    edit: *snip*

    Post edited by Capac_Amaru on
  • chebmehchebmeh Member Posts: 20
    I put my own custom soundset in the correct directory. I am able to select it, but now not a single soundset (NPCs excluded, however) works correctly. There are no character selection sounds, and when giving my character a command, I only get the one sound, repeated about seven times. I thought this might be an issue with my custom soundset, but apparently it's botched with the others, too. I removed my custom one and things stayed the same, unfortunately.

  • CuvCuv Member, Developer Posts: 2,535
    Did you backup your game before trying to tweak things? If not, you may need to re-update to a clean install.

  • savailsavail Member Posts: 10
    edited November 2012
    Actually, I think I might be having same problem. I didn't modify any files in BG:EE but during character creation when it gets to voice selection I can't hear any single voice. Sometimes after spamming with mouse clicks I can hear one sound but that's all :(

  • chebmehchebmeh Member Posts: 20
    Taking the custom soundset out of the folder works, but I'm a bit disappointed. This really restricts customization of the PC. I'll try just overwriting the existing ones at some point.

  • XantarrXantarr Member Posts: 16
    I actually did go in and try to add them. Actually what I tried to do was replace the Female 1 voice scripts with ones that matched the sound-set I was using. Unfortunately I tried to do so using Notepad, and all I ended up doing was causing every single bit of text in the game to say "missing script" or something to that effect (this included all of the text on buttons, like in the main menu, etc). Anyway maybe that was simply because notepad is not meant to edit .tlk files. That being said it would be nice if, however they manage to fix this bug, they provide us with some way to add custom soundsets to the dialog.tlk.

    Also, though I might make a new topic for this, it turns out that none of the soundsets' "Rare Selected" parts are working at all. They never get to the funny stuff that they're supposed to say if you click on them repeatedly. This bug occurs with regard to the custom soundsets, but is true even for the included soundsets.

  • CuvCuv Member, Developer Posts: 2,535
    edited November 2012
    @Xantarr and @anyone else No... dont change the naming convention. What you are looking to do is name to female7

    Here! Take these that work! Go likewise and do unto others... for I have given you an example this day.

    sorry, couldnt resist. These work... you may use them and duplicate the naming. Drop into your lang/sounds folder. Will get this info posted here tomorrow - http://forum.baldursgate.com/discussion/8317/how-to-tweak-your-game#latest

  • LuigirulesLuigirules Member Posts: 419
    I'll bump this thread, because it's annoying and seems like it could be easily solved.

  • Saber_ScorpionSaber_Scorpion Member Posts: 8
    @Cuv Now if only I could figure out how to save forum attachments. Ha! Anyway, I will be eagerly watching the thread you linked for info on this, because I really want to solve this problem.

    Currently, I can get custom soundsets to play in the Character Creation screen, but when I get into the actual game, the characters make no sound at all except "action acknowledgement 1," strangely enough.
    Xantarr said:


    Also, though I might make a new topic for this, it turns out that none of the soundsets' "Rare Selected" parts are working at all. They never get to the funny stuff that they're supposed to say if you click on them repeatedly. This bug occurs with regard to the custom soundsets, but is true even for the included soundsets.

    Actually, for NPC's, the 'rare selects' seem to be there, but they are used differently. You have to select the character repeatedly, and once in a while a 'rare select' will play at random. Try selecting an NPC like Imoen or Xzar tons of times and once in a while you'll get the rare select. I kinda preferred the old method, but oh well.

  • CuvCuv Member, Developer Posts: 2,535
    @Saber_Scorpion Just click it and you should get a save option after a few seconds. Sounds like you may not have the correct naming. Unless its not the right format. I will update this later today, do some testing with other soundset packs out there and link them if they work with BGEE

  • XantarrXantarr Member Posts: 16
    edited November 2012



    Actually, for NPC's, the 'rare selects' seem to be there, but they are used differently. You have to select the character repeatedly, and once in a while a 'rare select' will play at random. Try selecting an NPC like Imoen or Xzar tons of times and once in a while you'll get the rare select. I kinda preferred the old method, but oh well.

    You are correct. However, it only plays the single rare selection in BGEE once in a while during a MOVE action, not from selection. And it is supposed to play in fact not from move commands but from selection commands.

    Also in BG1 the selection sounds usually played "in order" as opposed to "randomly" like they do in BGEE. Not that it's a big deal.

    Post edited by Xantarr on
  • dibdib Member Posts: 384
    Found a solution to this, it might be a bit complicated for most people but here it is anyway:
    http://forum.baldursgate.com/discussion/8868/heres-how-to-add-custom-sound-sets

  • theJoshFrosttheJoshFrost Member Posts: 171
    I think it's silly to have to download some third party program just so my sound sets would work like they worked in the original game. I hope this bug gets fixed without the use of some program I'm way too lazy to google and download.

  • MunroMunro Member Posts: 12
    edited December 2012
    A solution, maybe, but I hardly think the BGEE team seriously intended that we have to extract an archive and edit code to get custom soundsets to work. This still appears to me to be an oversight which should be patched as soon as possible.

    Are any team members aware of this yet? I'd like to hear that the issue is being worked on, or at the very least known of. I imagine making sure the Enhanced Edition works at least as well as the original should be a high priority for the devs.

    dib's method would work great for singleplayer, but it isn't too relevant for people who plan on playing BGEE with friends.

    theJoshFrost
  • theJoshFrosttheJoshFrost Member Posts: 171
    Munro said:

    A solution, maybe, but I hardly think the BGEE team seriously intended that we have to extract an archive and edit code to get custom soundsets to work. This still appears to me to be an oversight which should be patched as soon as possible.

    Are any team members aware of this yet? I'd like to hear that the issue is being worked on, or at the very least known of. I imagine making sure the Enhanced Edition works at least as well as the original should be a high priority for the devs.

    dib's method would work great for singleplayer, but it isn't too relevant for people who plan on playing BGEE with friends.

    Agreed. And I've tweeted Trent about it, so at least he should be aware of it. I'm hoping it gets fixed soon.

    I want to give every one in my Black Pits party custom sounds, and I refuse to play it until they work properly! Raaaaaaage!

  • CuvCuv Member, Developer Posts: 2,535
    working on this, stay tuned for a simpler solution for people who arent mod savvy.

    theJoshFrost
  • TheBlackThroneTheBlackThrone Member Posts: 42
    edited January 2013
    I tried a couple of soundsets from the shared Dropbox folder, and those didn't work. I assumed it was because most (all?) of them were extracted from older IE games, and are as such potentially outdated.

    So, I opened the 00766 / lang / en_US / sounds folder, and consulted the new sndlist text file. Armed with the instructions found therein, I proceeded to record my own set (using Adobe Audition). I moved my recordings to the folder, making sure that they're all mono 16-bit 22khz wavs with names no longer than 7 characters, and correctly labeled from -a to -w.

    The new set did appear on the in-game list, and I could hear all the responses when pressing the play button in the customize menu, but after selecting it, my character became completely mute. I tried quicksave/quickload and restarting the game, as well as disabling all other sounds and increasing the overall system volume (to establish that it's not just a matter of my recordings being too quiet), but nothing seems to help.

    Is there an issue with the playback of custom sounds? I remember reading somewhere that overwriting one of the existing sets solves the problem, but I'd rather avoid making any destructive changes to the game if possible.

    Post edited by Jalily on
  • TheBlackThroneTheBlackThrone Member Posts: 42
    edited December 2012
    I just tested the same soundset in BG2, and it works great (even seems louder than the preview in BGEE).

  • TiaxRulesAllTiaxRulesAll Member Posts: 198
    yup, its broke, they know, but still waiting on the fix.

  • MortiannaMortianna Member Posts: 1,356
    edited December 2012
    Until it's fixed, just replace an existing set of sound files (e.g., female6a through female6m) with your custom sound files (renaming them identically to the ones that you're replacing). I chose female6 since it's one I'm least likely to ever use. You can always save the original files in case you may want to use them in the future.

    Post edited by Mortianna on
    TheBlackThrone
  • theJoshFrosttheJoshFrost Member Posts: 171
    Shame that this hasn't been fixed yet. It appears so simple...

  • TiaxRulesAllTiaxRulesAll Member Posts: 198
    Happy New Year everybody!...

    ...Soundsets working yet?...

  • theJoshFrosttheJoshFrost Member Posts: 171
    Bumpin bumpin. The fact that this hasn't been fixed or even addressed is rather... bothersome. It actually kind of caused me to get less interested in playing the game now because most of the time I just hear footsteps instead of my sinister baddy of a protagonists lifted warcraft 3 voice.

  • Nic_MercyNic_Mercy Member Posts: 406
    they've been working for me since day one... I installed all the npc voice sets >_>

Sign In or Register to comment.