Skip to content

Neera's dialogue with Adoy doesn't always trigger

GlaykithGlaykith Member Posts: 14
Current Behavior:

I've seen instances on a couple different playthroughs where Neera doesn't always say her lines during the initial conversation with Adoy, which causes awkward gaps in the dialogue because Adoy's lines don't make much sense without context from Neera.

I can provide a save file right before the affected encounter that consistently reproduces the behavior for me, if that will help.

I believe that both playthroughs where I've seen this behavior also exhibited the Neera clone bug ( at one point, so it's possible that the two are related.

Expected Behavior:

Neera always says her lines while conversing with Adoy.


  • Avenger_teambgAvenger_teambg Member, Developer Posts: 5,862
    If you had a clone, then yeah, it is very likely that your Neera was a fake. So the bug here is because of the cloned neera. We cannot do much at this point when the harm was already done.
  • GlaykithGlaykith Member Posts: 14
    I think I figured it out. I inspected my global variables using ShadowKeeper and found that SPRITE_IS_DEADNEERA was set to 1. I had killed what I thought was the "clone" Neera earlier on, so I guess this makes sense. After setting the variable back to 0, I now get the expected dialogue from Neera and expanded dialogue options with Adoy.

    I still find it strange that I was getting all of the other expected Neera dialogue up to this point. The background story, the request to find Adoy, the comment about the squirrel at the entrance to the Enclave, the interjection when talking to Magreb; all of those were there. I guess the Adoy dialogue script checks if Neera is dead where the other scripts don't?
  • Avenger_teambgAvenger_teambg Member, Developer Posts: 5,862
    @Glaykith thanks for digging into this. And yes, some parts of the script check if Neera is dead.
    Normal IsValidForPartyDialog is not working, because Neera could be present out of party.
    And no one expected the neera cloning bug (which should be fixed by now anyway).

    If you can find a way to still clone her (starting from a new game), then i would be very grateful and fix the bug immediately.
  • GlaykithGlaykith Member Posts: 14
    @Avenger_teambg I'm assuming "should be fixed by now" means fixed in the latest (2012) public patch and not an internal development build, correct? That being the case, I'm still seeing the Neera clone bug with the 2012 patch.

    The character I originally reported the Adoy dialogue issues with was technically created under 2011, but I didn't advance her past the Candlekeep starting area until 2012, so none of the Neera flags should be set at that point, I don't think. Either way, I just reproduced the clone again with a brand new character that I know has been played solely under the 2012 patch.

    The only mod I'm running is TeamBG's level 40 rule set.
  • Avenger_teambgAvenger_teambg Member, Developer Posts: 5,862
    So, how does one clone a Neera?
  • GlaykithGlaykith Member Posts: 14
    I spent a couple hours tonight trying to clone Neera while recording with Fraps, but I had no success.

    My technique was to import a leveled character into a new game, head straight to Beregost, rescue Neera, kick her out, and then head to the FAI to see if two Neeras are there standing on top of each other. This path reproduced the issue the first time I tried it a couple weeks ago, but I haven't been able to reproduce it on demand since.

    I'll keep trying over the next few days.
  • Avenger_teambgAvenger_teambg Member, Developer Posts: 5,862
    Could it be that this was fixed by v2012?
  • ErgErg Member Posts: 1,756
    edited January 2013

    Could it be that this was fixed by v2012?


    Unfortunately not. I got the same bug (clone of Neera in FAI) with v2012 (new playthrough started with the latest patch already installed)
  • Avenger_teambgAvenger_teambg Member, Developer Posts: 5,862
    @erg any reproducible method? It may involve movetoarea and could start from a saved game outside of Beregost (which has never seen Neera earlier).
  • ErgErg Member Posts: 1,756
    edited January 2013

    So, how does one clone a Neera?

    I don't know if this is reproducible, I will try and let you know.

    What I did was

    1) let Neera join in Beregost
    2) complete the Adoy quest
    3) complete the proto-romance (all three lovetalks)
    4) drop her from my party in the Jovial Juggler in Beregost, where she left saying I could find her in FAI
    5) after exploring several other areas (I don't rememberer exactly which) I went to FAI and there were two Neera

    I was able to tell the two Neera apart, however, because one still had the default colours, the other one the new colours I gave her.

    Edit: Post corrected: I meant "default" instead of "custom".
  • ErgErg Member Posts: 1,756

    Unfortunately, I'm unable to reproduce the bug. I'm attaching a zip file containing two savegames.

    In the first Neera is still in my party.
    In the second the problem is already present: using MoveToArea("AR2301") will show the clone in FAI.

    The only things I did in between the two saves were:

    1) trigger the remaining two lovetalk, using a combination of ctrl+t and rest in Feldepost's Inn to speed things up, until I got to say the "give me some sugar" line.
    2) dropped Neera in the Jovial Juggler
    3) went back to the previously explored area of Nashkel Carnival to get Branwen
    4) went back to Beregost

    I didn't do any quest or kill in the meantime as you can see from the XP being exactly the same in the two savegames.

    I tried to reproduce the bug, starting from the first savegame and repeating the four step above, but without any luck.

    Hopefully, you may find some clues analysing the savegames. 720.8K
Sign In or Register to comment.