Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

SCS Mod on OSX

mr_namelessmr_nameless Member Posts: 37
edited March 2013 in Mac OS X (Archive)
Trying to install on OS X 10.8, at some point during the Initialise Mod stage I get this error, "resource [bolt02\n.ITM] not found for 'COPY'," and the installation aborts.
Due to some missing/cannot locate ITM files the Initialize stage cannot complete.

I get this from the Weidu log:

SFO: Applying patch(es) to ITM file(s) arow02 ax1h02 ax1h07 blun03 blun05 blun07 bolt02
dagg02 dart02 halb02 hamm02 staf02 sw1h02 sw1h05
sw1h08 sw1h14 sw1h22 sw1h24 sw1h98 sw2h02...

ERROR Installing [Initialise mod (all other components require this)], rolling back to previous state
Will uninstall 2127 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 1000.
Uninstalled 2127 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 1000.
ERROR: Failure("resource [bolt02\n.ITM] not found for 'COPY'")
PLEASE email the file SETUP-STRATAGEMS.DEBUG to davidw, Gibberlings3 forums


Can anyone run SCS V.23 without this problem on OSX (10.8) ?

Comments

  • NifftNifft Member Posts: 1,065
    Yep, I can replicate this with the latest weidu builds.

    Basically, the SCS files use DOS line endings, and split some lists across multiple lines. Either alone would work, but together they screw up WeiDU.

    Let me see if I can fix it...

  • NifftNifft Member Posts: 1,065
    edited March 2013
    Yep, fixing the line endings allows me to install most of SCSv23 on OS/X. There are still errors, and by trying to install everything my game now crashes. So I don't recommend blindly installing everything like I did, but some parts might work. Or not.


    Here's a magic incantation -- use at your own risk, no warranty provided or implied, following these instructions may kill your dog, do not taunt the happy fun ball, etc. -- which got most of the mod to install for me:

    cd /Applications/Baldur's Gate - Enhanced Edition/Game Data/00777/Baldur's Gate - Enhanced Edition.app/Contents/Resources
    perl -pi -e 's/\r\n/\n/g' stratagems/*.tph
    perl -pi -e 's/\r\n/\n/g' stratagems/*.tpa
    Copy & paste that into Terminal.app and see if your install gets farther. If the parts you want don't show any errors, your game may even run! (Mine doesn't until I remove the mod.)

    Cheers, -- N

    Post edited by Nifft on
    Haenir
  • mr_namelessmr_nameless Member Posts: 37
    Thanks Nifft, my install could actually finish. Things are running fine, I haven't installed too many components for now.

  • EudaemoniumEudaemonium Member Posts: 3,199
    For some reason my terminal doesn't work with the above commands. It just states that the file or directory doesn't exist. Any help available for this issue?

    [Deleted User]Phyrax
  • PhyraxPhyrax Member Posts: 198
    I have the same problem!

  • EudaemoniumEudaemonium Member Posts: 3,199
    Mayhaps the glorious @Nifft can offer some advice on this issue?

  • CerevantCerevant Member Posts: 2,311
    I don't think perl is installed as part of OSX, so you would need to download it.

    Eudaemonium
  • EudaemoniumEudaemonium Member Posts: 3,199
    @Cerevant: I downloaded and installed the free perl, but it doesn't seem to have done anything to help :(.

    [Deleted User]
  • CerevantCerevant Member Posts: 2,311
    What happens if you type the following command:
    perl -V

    Eudaemonium
  • EudaemoniumEudaemonium Member Posts: 3,199
    It comes up with the following:


    Summary of my perl5 (revision 5 version 12 subversion 4) configuration:

    Platform:
    osname=darwin, osvers=12.0, archname=darwin-thread-multi-2level
    uname='darwin b1026.apple.com 12.0 darwin kernel version 12.0.0: tue may 15 23:31:29 pdt 2012; root:xnu-2050.6.70~1release_x86_64 x86_64 '
    config_args='-ds -e -Dprefix=/usr -Dccflags=-g -pipe -Dldflags= -Dman3ext=3pm -Duseithreads -Duseshrplib -Dinc_version_list=none -Dcc=clang'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
    Compiler:
    cc='clang', ccflags ='-arch i386 -arch x86_64 -g -pipe -fno-common -DPERL_DARWIN -fno-strict-aliasing -fstack-protector -I/usr/local/include',
    optimize='-Os',
    cppflags='-g -pipe -fno-common -DPERL_DARWIN -fno-strict-aliasing -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.2.1 Compatible Apple Clang 4.0 (tags/Apple/clang-418.0.60)', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
    Linker and Libraries:
    ld='clang -mmacosx-version-min=10.8', ldflags ='-arch i386 -arch x86_64 -fstack-protector -L/usr/local/lib'
    libpth=/usr/local/lib /usr/lib
    libs=-ldbm -ldl -lm -lutil -lc
    perllibs=-ldl -lm -lutil -lc
    libc=, so=dylib, useshrplib=true, libperl=libperl.dylib
    gnulibc_version=''
    Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=bundle, d_dlsymun=undef, ccdlflags=' '
    cccdlflags=' ', lddlflags='-arch i386 -arch x86_64 -bundle -undefined dynamic_lookup -L/usr/local/lib -fstack-protector'


    Characteristics of this binary (from libperl):
    Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV
    PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_64_BIT_ALL
    USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES
    USE_PERLIO USE_PERL_ATOF USE_REENTRANT_API
    Locally applied patches:
    /Library/Perl/Updates/ comes before system perl directories
    installprivlib and installarchlib points to the Updates directory
    Built under darwin
    Compiled at Jun 20 2012 13:55:28
    @INC:
    /Library/Perl/5.12/darwin-thread-multi-2level
    /Library/Perl/5.12
    /Network/Library/Perl/5.12/darwin-thread-multi-2level
    /Network/Library/Perl/5.12
    /Library/Perl/Updates/5.12.4
    /System/Library/Perl/5.12/darwin-thread-multi-2level
    /System/Library/Perl/5.12
    /System/Library/Perl/Extras/5.12/darwin-thread-multi-2level
    /System/Library/Perl/Extras/5.12
    .

    [Deleted User]
  • CerevantCerevant Member Posts: 2,311
    Ok, so it looks like perl is all happy, maybe you have SCS in a different directory? The directions above assume that SCS is in a folder called "strategems" inside the Resources folder of the App bundle. Is that where you have it?

    Eudaemonium[Deleted User]
  • EudaemoniumEudaemonium Member Posts: 3,199
    @Cerevant: I do. It seems to not be able to find any .tph or .tpa files: Are these ordinarily stored in the stratagems folder? For reference, I have two folders. A 'stratagems' and a 'stratagems_external'. The former contains the .tp2 file and everything else.

  • NifftNifft Member Posts: 1,065
    @Eudaemonium - hmm, let me check. I un-installed SCS to work on my own mod a while back.

    (It's really a pity I can't have multiple Override folders... would make testing this kind of stuff much easier.)

    Eudaemonium
  • EudaemoniumEudaemonium Member Posts: 3,199
    @Nifft: Thanks! I really want to be able to try this mod for a change, and I'm not entirely sure why it isn't working (or why your method above seems to not have any effect). I am not a modder at heart :(

  • NifftNifft Member Posts: 1,065
    edited April 2013

    @Cerevant: I do. It seems to not be able to find any .tph or .tpa files: Are these ordinarily stored in the stratagems folder? For reference, I have two folders. A 'stratagems' and a 'stratagems_external'. The former contains the .tp2 file and everything else.

    Try this:

    find stratagems -name '*.tp[ha]' -print

    That ought to print out a bunch of file names ending with 'tpa' and 'tph'. As above, you'll want to 'cd' to wherever your BG:EE game is installed. I think it's the path in my first command, but do check.

    If it does print a bunch of file names, then try this:

    find stratagems -name '*.tp[ha]' -exec perl -pi -e 's/\r\n/\n/g' \{} \;

    This will find all the 'tph' and 'tpa' files, instead of me trying to remember where the files were. :-)

    Eudaemonium
  • EudaemoniumEudaemonium Member Posts: 3,199
    edited April 2013
    @Nifft: That seems to have worked! Thank you so much! (Installing now, no guarantee it'll work at the end, though).

    EDIT: Almost all of SCS installed and it seems to be running fine! BG boots up at least.

    Post edited by Eudaemonium on
    lunar
  • PhyraxPhyrax Member Posts: 198
    edited May 2013
    OK, so basically this worked for installing SCS on my system:

    I installed PERL (see above link) and had a copy of Weidu in my resources folder.

    Then, via Terminal:

    cd '/Applications/Baldur'\''s Gate - Enhanced Edition/Game Data/00777/Baldur'\''s Gate - Enhanced Edition.app/Contents/Resources/'

    find stratagems -name '*.tp[ha]' -exec perl -pi -e 's/\r\n/\n/g' \{} \;

    Subsequently "BG Mac mod installer v2" allowed for installation of SCS.

    Have to check wether the game actually runs, but based on the information given in Terminal, it seems to be doing fine...

    EDIT: yup, the game still runs. Didn't encounter many mages yet, but they will probably be much harder now!

    Wowo
  • WowoWowo Member Posts: 2,058
    @Phyrax trying this now, thanks for the solution!

  • NicholsNichols Member Posts: 16
    Where do you all find the .tp2 files? All I can find is the .exe?

Sign In or Register to comment.