Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Szass Tam disappointments (looking very much like bugs)

xzar_montyxzar_monty Member Posts: 630
So, the first time after ringing the bell, I got Szass Tam down to "badly wounded", at which point he said something like ok, you've been enough of a nuisance, now pick your stuff and leave before I really get angry. This dialogue implied that I should have been able to get away from the place. But Szass Tam remained hostile and, in fact, immediately after the dialogue, proceeded to destroy my party by using his "wish followed by a lot of nasty spells" strategy. So, this looked like a bug.

The second time, after reloading, I got him down to "near death", at which point he said something like right, get away RIGHT NOW (using lots of capital letters) and teleported me back to the clearing in Amn. I got no quest experience reward. No journal entry. Nobody (especially Neera) said anything about having solved this damn problem with the Red Wizards. When I check my journal, this whole business is still very much an unsolved quest, although of course there's no way I can get back. So, this also looked like a bug.

Anyone else seen stuff like this?


  • kryptixkryptix Member Posts: 741
    The second result is an ok one, I don't think that quest has separate quest experience rewards. The first one I got but I killed him again after the wish and he just got stuck at near death for 10k hitpoints lol... Had to reload and the second time I only used traps on him and immediately accepted his deal to get away.

  • xzar_montyxzar_monty Member Posts: 630
    Ok, thanks.

    But surely the journal is bugged? There should be an entry saying I did what I was sent to do and was teleported back by Szass Tam, or something. The whole charade should move from the "quests" category to the "done quests" category, which it doesn't.

  • kryptixkryptix Member Posts: 741
    edited January 2014

    Try this:

    C:SetGlobal("OHN_TOB_PLOT","GLOBAL",15) While your in that little Neera special area.

  • xzar_montyxzar_monty Member Posts: 630
    @kryptix: What is that meant to do? Fix the journal?

  • kryptixkryptix Member Posts: 741

    @kryptix: What is that meant to do? Fix the journal?

    Yeah and have neera talk to you

  • xzar_montyxzar_monty Member Posts: 630
    @kryptix: Ok, that last part sounds good. What I do first in order to be able to type that command line? I've never used the "cheat" console (or whatever it is) before.

  • JenzafarJenzafar Member Posts: 303
    edited March 2014
    OK, I just did Neera's ToB quest for the second time. The first time, after fighting Szass Tam for a while, he told me to go, teleported me back to that clearing where the quest started, and then I had a wand of whips in my inventory.

    This time, he sent me back, but with no wand! Did I mis-remember, and actually picked it off a corpse or a shelf or something? I searched, but can't find it again.

    edit: remembered name of wand.

  • CLsdlt80CLsdlt80 Member Posts: 72
    Just got to that part, I'll share my experience. First of all, I tried it a couple of times, and didn't notice any wand. I also believe, after doing the fight a couple of times, that if when you get teleported back you don't receive any experience and journal closure, there's a bug going on... The only time I got experience and journal closure was in 2 cases. One was when I lowered his hit-points to the point he ceases hostility, blue circle and all, and hits the dialogue line of: OK, I've seen enough go back now, my PC says: ok no more fighting then, goodbye. I also got to a point when the fight would start, I would lower his hit-points and he would jump immediately to the more drastic goodbye line: OK, go NOW! At that point I got teleported back with no experience and no journal closure. The other alternative was to go through both fights, that means, the two dialogue lines triggered correctly, two fights... I did that and got journal closure and experience, but lost 3 NPCs in the process because of his insane spell casting... So I believe that something needs to get revised there, regarding how the closure triggers.

    To open the CLUAConsole you have to edit your Baldur.ini file which, in Win7 case, is in a folder with the name of your game inside the documents folder. There must me a line that says:

    'Program Options', 'Debug Mode', '1',

    If that line is in the file, within the game you press control-space at the same time, and the console opens.

  • CrevsDaakCrevsDaak Member Posts: 7,153
    edited March 2014
    Actually, his script was very good, but anyway an easy fight for a complete party with tons of XP, but I can't recall if I got XP at the end or not.

  • CLsdlt80CLsdlt80 Member Posts: 72
    Yeah... when you find out that you can get enough damage made in less than a round is when it gets easier. it took me about 3 or 4 times to find that out, because I was only shooting towards him with the expert shooters... finally I gave it shot with all the party and bam!

  • MacHurtoMacHurto Member Posts: 731
    Is it easier to take him there than when he greets you the first time? I think on the black pits meeting he instacast timestop with wish ring, throws all spells at you, renews timestop, renews spells, throws everything at you again. Were you disrupting his timestops somehow?

  • LathlaerLathlaer Member Posts: 475
    Szass Tam is like Kangaxx. Either embarrassingly easy (when you attack him with everything you've got the second he turns hostile — he didn't even have the chance to cast Time Stop when I fought him) or tougher than any non SCS mage in the game if you let him stop the time.

  • panamakidpanamakid Member Posts: 13
    I have similar problems as OP. Has anything changed in the two and a half years, maybe the bug was fixed or there's a way to get the proper ending? I put the line from way above in the console and it made Neera speak her piece, but I got no experience or journal entry (and a wand? Is there a wand?).

    Sorry for necrophilia, grateful for answers.

  • stevelegend09stevelegend09 Member Posts: 2
    I am seriously struggling, I have no experience with consoles. I have a cough and I have never completed the damn game before. Can someone just make the game playable for me please?! This sucks.

  • GallowglassGallowglass Member Posts: 3,356
    I remember this bug, but I thought it had been fixed in the 2.0 patch (or maybe it was even earlier?) There was a long thread about it somewhere on here.

    What version are you playing, @stevelegend09?

  • ArchaosArchaos Member Posts: 1,421
    edited November 2016
    You shouldn't be able to defeat Szass Tam at all in a real PnP game, anyway.
    The game allowing you to do that, even as a bug, is nonsense.
    He should only be marked as a plot NPC and be immortal, period.

    He's not some random lich. He's basically the ruler of Thay. Remember Edwin? He's basically his master.
    When you fight Szass Tam, you fight him (or his simulacrum) as well as ALL the Red Wizards of Thay and their bodyguards.
    If not an army.

    At best it should be like:
    "You defeated Szass Tam ...or did you? He is an epic lich with a phylactery.
    You lose because some days later, all of Thay was teleported back to you and vaporized you when you rested.

    Even more so with Larloch.

  • GallowglassGallowglass Member Posts: 3,356
    Archaos said:

    You shouldn't be able to defeat Szass Tam at all in a real PnP game, anyway.
    The game allowing you to do that, even as a bug, is nonsense.
    He should only be marked as a plot NPC and be immortal, period.

    Yes, and this is indeed what the game also intends.

    Being yourself practically a demi-god by that stage of the game, you can hurt Szass Tam badly (which persuades him to send you home instead of killing you), but you can't actually kill him. Except that it frequently didn't work reliably due to a bug, which I thought had been fixed (and hasn't happened to me in a long while), but apparently some people are still seeing the bug for some reason.

    WORKAROUND for those who experience this bug (if the cause is still the same as before):- Attack Szass Tam in melee only, not with ranged weapons nor projectile magic. If anything was currently in flight at the moment when he turned back to neutral, then that might still hit him afterwards and turn him back to hostile, which often used to trigger the bugged outcome.

  • XantorXantor Member Posts: 110
    Bug still exist and it's realy frustrating when u want defeat him 2 times, because in second time realy often buged and didn't send u back to Theyr.
    Btw he isn't that hard to defeat he fall rly fast ^^
    Archaos said:

    You shouldn't be able to defeat Szass Tam at all in a real PnP game, anyway.
    The game allowing you to do that, even as a bug, is nonsense.
    He should only be marked as a plot NPC and be immortal, period.

    He is nothing for u, u're demigod, Demogorgon killer and more u even defeat Sendai, Yaga-Sura and Abazzigal army and last available part of Theyr Army, even Elminster and Cyric afraid of your power ;p

Sign In or Register to comment.