Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been announced! Visit nwn.beamdog.com to pre-order, apply for the Head Start and check for details. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

BG2 Tweak Pack not installing correctly?

MoobooMagooMoobooMagoo Member Posts: 11
I saw this on the list of supported mods so I installed what I wanted from it but now my game is all messed up. I'm not sure how it happened but it seems that many of the things that were supposed to be changed didn't work, particularly in regards to descriptions for things.

For example, I installed the tweak that shuffles around weapon profficiencies which is supposed to include a new description, but the profficiencies did not change and now the descriptions that should have been changed look to be some random Haer'dalis dialog. Some of the item descriptions had this happen as well. My favorite is the White Dragon Scale description which now reads 'Come now, who could be stronger than you? Who would dare give orders to you?' That is an awesome description for a suit of armor but I digress.

I don't know what all is affected because I didn't really do much after I noticed the mod didn't install correctly. I'm going to reinstall the game and take another crack at it and make sure everything I'm using is up to date (like Weidu). Before I did this I wanted to check here to see if anyone else has had this happen before and how to fix it, since I really enjoy the tweak pack and would like to use it.

Comments

  • ErgErg Member Posts: 1,756
    @MoobooMagoo, BG2 Tweak Pack (v14) is still using WeiDU 232, so you should download the latest version of WeiDU from here, rename the file WeiDU.exe as setup-bg2_tweaks.exe and replace with it the old setup-bg2_tweaks.exe in the main BG folder (i.e. the one with the file chitin.key).

    Once you have replaced setup-bg2_tweaks.exe, don't use bg2_tweaks-v14.exe to install the mod, otherwise the old file will overwrite the new one, nullifying any change. Instead, just double click on setup-bg2_tweaks.exe inside the main BG folder (I'm assuming that the foder bg2_tweaks-v14 and the file setup-bg2_tweaks.exe are already there because you attempted to install the mod at least once).

    If you still have problems after that, attach here the files WeiDU.log and SETUP-BG2_TWEAKS.DEBUG (you'll have to zip or rar them first).

    N.B. Having a more updated version of WeiDU.exe in the main BG folder will not automatically update setup-bg2_tweaks.exe, that's why you must manually replace the file. However, if you have an up to date setup-modname.exe, from another mod, then setup-bg2_tweaks.exe will be automatically updated and manual replacement will not be necessary.

    elminsterAstroBryGuy
  • Carl_LCarl_L Member Posts: 41
    Ok... I seem to have fixed it. Thank you to everybody who took the time to help me out.

    Erg
  • DangerDudeDangerDude Member Posts: 4
    Hmm, I have the same issue. Tried the remedy above, but it did not work. As soon as I loaded my save game, my party started discussing how they Aerie can craft the Flail of Ages if I bring her the other heads....

  • Wise_GrimwaldWise_Grimwald Member Posts: 1,235
    In my installation it won't remove racial restrictions to kits.

  • ErgErg Member Posts: 1,756
    @Wise_Grimwald, you are using the original game, but that component only works for the Enhanced Edition, according to the ReadMe.

    However, ToBEx also externalise clsrcreq.2da, so maybe it could work with the original game too, if you install ToBEx, but I haven't tried and ToBEx implementation is different, so I'm not sure it is compatible.

  • Wise_GrimwaldWise_Grimwald Member Posts: 1,235
    Have installed EBG2 so that shouldn't be the problem.
    I take it EBG2 is the enhanced edition? Or is EBG2 and BGII:EE different?

  • Wise_GrimwaldWise_Grimwald Member Posts: 1,235
    Apparently I was confused. EBG2 is expanded BG2. BGII:EE is enhanced BG2. :(
    Blushes abound!

  • Wise_GrimwaldWise_Grimwald Member Posts: 1,235
    edited September 2014
    Just confirmed that Enhanced BG2 is not the same as BGII:Enhanced Edition. Problem is that there are a lot of similarities between the two.
    See:
    http://www.shsforums.net/topic/21344-enhanced-bg2-cont/page-6

    I strongly suspect that BGII:EE was developed from EBG2.

    Post edited by Wise_Grimwald on
  • subtledoctorsubtledoctor Member Posts: 8,001
    edited September 2014
    EBG2 was a kit and tweak mod for the original BG2 game, made many years ago.

    BG2:EE is a re-release of the whole game, with graphical and engine improvements and bug fixes. It does incorporate parts of some mods for the original BG2, such as 1 Pixel Productions and TobEx. But I don't believe it incorporated anything from the 'EBG2' mod.

    The two have nothing to do with each other, afaik, other than the coincidence that they both independently decided to use the word "enhanced" in their name.

    CrevsDaakjackjackWise_Grimwald
Sign In or Register to comment.