Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Game slows down to 1 or 2 frames per second as of 1.3 [Windows] [Steam]

Operating System: Windows 7
CPU: i7-3610QM 2.30 GHz
GPU: AMD Radeon HD 7600M 1GB
System RAM: 4GB

To clarify, I haven't played BG:EE for about a month, at which time the game played normally. After Steam downloaded patch 1.3, my partner and I decided to continue a multiplayer game we had been playing.

When I launched BG, I got a white square filling the screen on a black background, slightly offset to the left, before going to the launcher. After clicking 'Baldur's Gate', I got a fully white screen while the sound of the cinematic played. While setting up a multiplayer game and loading a save file, I noticed the tooltips in the permissions screen took 3 or so seconds to fully open. Upon starting the game, my partner's game ran normally, but mine was running at maybe one or two frames per second, with characters moving very slowly in one second intervals, and tooltips affected as before. Audio did not seem to be affected. The same problem occurred in a single player game when loaded.

I reinstalled the game but still have the same problems, and verified the game cache through Steam. Other games run fine on the computer (specifically, I've tried Castle Crashers, Hearthstone, Long Live the Queen, and Banished). Anyone know what I can do to fix these problems?

Sign In or Register to comment.