Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Can't install Ascension mod on BGII:EE, please help!

MelduinMelduin Member Posts: 4
edited January 2015 in BGII:EE Mods
So I've tried to install the mod "Ascension" using the instructions and I'm aware of the known problems the enhanced edition has (I resolved the "dialog.tlk" problem), but I have come across another problem I can't find anywhere on the forums:

When I run the Setup-Ascension.EXE, I get offered my choice of language then it asks me what to do with the 6 uninstalled components: "[I]nstall them, [S]kip them, [A]sk about each one?". When I select "install them" or "ask about each one" the client tells me, "I cannot find [Data/25Dialog.bif], which leads me to believe that you do not have the Throne of Bhaal expansion installed. You must have ToB installed to use install the Ascenion mod."
http://gyazo.com/d1c950e45e8977f5be34df49b12dce7b
If I look into the "Data" folder, the "25Dialog.bif" file exists, so I'm stumped.
How do I resolve this issue?

Post edited by Melduin on

Comments

  • CuvCuv Member, Developer Posts: 2,535
    Ascension wants to make sure you have ToB installed. If you open up the Setup-Ascension.tp2 (which is either in your main game directory if you are using the classic weidu Ascension - or inside the BP Ascension folder) then you will see right after the languages section this -

    ===============================================
    ///////////////////////////////////////////////////////////////////////
    ///////////////////////////////////////////////////////////////////////
    // The Ascension
    ///////////////////////////////////////////////////////////////////////
    ///////////////////////////////////////////////////////////////////////
    BEGIN @1

    REQUIRE_FILE ~Data/25Dialog.bif~ @2 // ToB sanity check

    -----------------------------------------------------------------

    So should be an easy enough fix to put forward slashes in front of this section and re-save it. (back up the tp2 somewhere if this all goes wrong. I recommend ConTEXT, but Wordpad should work. Make sure you have admin privaledges for the folder or the edit wont take (much like the baldur.ini issues described elsewhere.

    ----------------------------------------------------------------
    ///////////////////////////////////////////////////////////////////////
    ///////////////////////////////////////////////////////////////////////
    // The Ascension
    ///////////////////////////////////////////////////////////////////////
    ///////////////////////////////////////////////////////////////////////
    //BEGIN @1

    //REQUIRE_FILE ~Data/25Dialog.bif~ @2 // ToB sanity check
    ----------------------------------------------------------------

    Then try re-running the installer. You DO want the Ascension main component. Up to you if you want the other harder battles - install or skip them.

    And yes, you are aware there may be some gameplay problems with this and the EE. So please don't complain if you run into problems. Just post if something gets you stuck and me or someone can probably help you get past the bad spot. Good luck and have fun :)

    MelduinJuliusBorisovGotural
  • MelduinMelduin Member Posts: 4
    Thanks for the fast response!
    My computer didn't have a default program to open "Setup-Ascension.tp2" with, so I used wordpad. Everything was as you had said, I entered the slashes and saved the changed wordpad. I then attempted to run "Setup-Ascension.EXE" and was met with:
    "In state 981, I expected one of these tokens:
    [0] EOF
    [46] BEGIN
    [196] LANGUAGE
    Parse error at COPY
    ..."
    http://gyazo.com/9347ff282bba1d80b0751365b9e2d659
    Further help would be appreciated :smile:

    Cuv
  • CuvCuv Member, Developer Posts: 2,535
    oh hmm - you may need a newer version of weidu. What version of Ascension are you trying to install? where did you get it?

  • MelduinMelduin Member Posts: 4
    I got it from what I assumed was the official site:
    http://weidu.org/asc.html.
    Under "Installing The Mod" - the 9th instruction.

  • CuvCuv Member, Developer Posts: 2,535
    Hmm, I can't get the native weidu Ascension to install at all either. I will point you to the somewhat EE compatible version here - http://www.shsforums.net/files/file/546-the-big-picture-v181/

    That is the Big Picture Mod - but all you need to do is install the Ascension component. The pure EE version is still in the works but is not ready yet.

    MelduinJuliusBorisov
  • MelduinMelduin Member Posts: 4
    I installed "the big picture" and added the "Ascension" component (along with some others that piqued my interest) and only wish to know what the differences are between this and the version of "Ascension" I was trying to install.
    Other than that I thank you for your swift and very helpful replies :smile:

    CuvJuliusBorisov
  • CuvCuv Member, Developer Posts: 2,535
    no problem :) The BP version should be identical except that it will install on the EE. cheers

    MelduinjackjackJuliusBorisov
  • domeplsffsdomeplsffs Member Posts: 36
    edited January 2015
    May i ask if the OP got BP Ascension to work? I tried it as well, but i got all sorts of 'Missing String xxx' in-game. <--- sad panda

    Edit: Typos

    Cuv
  • NervaNerva Member Posts: 133
    Did you get Ascension to work properly with BG2EE 1.3?

  • Blackguard_Blackguard_ Member Posts: 7
    How do you resolve the dialog.tlk problem? I try to install ascension and it says "cannot find dialog.tlk, hit enter to close". I am using the steam version and extracted everything into the bg2 ee game folder in my steam folder. There is no dialog.tlk in this version, just a dialog.bif. But that doesn't seem to help. what now?

  • Blackguard_Blackguard_ Member Posts: 7
    oh, i can try the big picture. will try in the morning

  • shawneshawne Member Posts: 3,239
    The Big Picture version will work, but you'll want to use the attached override file or your PC will die after using the Slayer form.

    CuvBlackguard_JuliusBorisov
  • Blackguard_Blackguard_ Member Posts: 7
    what do I use to install the big picture? i cant seem to get it working

  • shawneshawne Member Posts: 3,239

    what do I use to install the big picture? i cant seem to get it working

    http://www.shsforums.net/files/file/546-the-big-picture-v181/

    Drop that file in whatever directory has CHITIN.KEY and run it. That should do the job. :)

    JuliusBorisov
Sign In or Register to comment.