Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

getting "Failure("No rule to identify IWDEE")" on certain mods (SoB, TomeAndBlood etc..) MacOSX10.6.

I did as much searching as I could but didn't find anyone with a similar problem.

I'm trying to mod BGEE and while many mods work just fine, some of the ones I'm most excited about I keep getting the error:

ERROR Installing [Core Revisions], rolling back to previous state
Will uninstall 34 files for [TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2] component 0.
Uninstalled 34 files for [TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2] component 0.
ERROR: Failure("No rule to identify IWDEE")
PLEASE email the file SETUP-TOMEANDBLOOD.DEBUG to [email protected]
Using Language [English]

Sometimes it's the whole mod that won't load (like ToB) and then certain mods like Scales of Balance I can load some of the mod but some of it gives me this same "No Rule to identify IWDEE".

Is there a work-around for this? It doesn't seem to be a common problem but maybe I'm just doing something dumb.

I'm running an old MacBook that has to use the x86 weidu and can't upgrade past Snow Leopard.

Comments

  • GrammarsaladGrammarsalad Member Posts: 2,540
    Did you say that you are using version 86 of weidu? Not (what is it?) 276?

    If so, I'm sure that is a big problem...not sure if there is a fix for it if you can't use a later version

    @aquadrizzt any insight?
    @subtledoctor you know about those silly mac machines. Can you help him out?

  • Not not version 86 but as in the mac I'm temporarily stuck with is so old that I have to use the x86 version of weidu instead of the 64/86 snow leopard/mavericks version. It's only a very select few mods giving me this error but, as mentioned, it's two of the bigger mods that I was most hoping to get running, as my luck would have it.

    Would this be some sort of issue with the fact that I don't have Icewind Dale installed?

  • argent77argent77 Member Posts: 2,936
    It depends on the actual WeiDU version. Afaik, you need WeiDU v237 to properly support IWD:EE (which also includes related WeiDU keywords) and v232 or later for BG[2]:EE. I don't know if there is a legacy Mac version available for the latest WeiDUs though.

    If you want to install the mods in BGEE only, you can try to open the mod's TP2 files and remove instances of the "iwdee" keyword. It is usually found in strings following the ENGINE_IS or GAME_IS keywords. But sometimes you have to change more than that, so you should have at least some knowledge about WeiDU's scripting language before attempting it. Make a backup beforehand just in case.

  • I'm using weidu 236, as 237 doesn't have an x86 version for mac compiled yet, from what I can tell (I'm not great with all this scripting/coding lingo)

    Thing is, I am just trying to get BG:EE going. I thought about trying to go through and delete any mention of iwdee but of course the mods that I'm having trouble with are the rather monstrous sized mods and there's so different references in their .tp2 files that I felt pretty certain I'd just end up breaking something.

    If I'm feeling ambitious tomorrow maybe I'll give that a shot.

  • GrammarsaladGrammarsalad Member Posts: 2,540
    I see...That doesn't seem like a difficult fix. I'll try to upload a version if tom later--probably late tonight or tomorrow--without mention if iwdee or its components

  • [Deleted User][Deleted User] Posts: 0
    edited January 2015
    The user and all related content has been deleted.

    Post edited by [Deleted User] on
    Grammarsalad
  • GrammarsaladGrammarsalad Member Posts: 2,540
    What subtledoctor said. Feel free to 'summon' me (by typing "@grammarsalad " )if you really, really can't use the latest version of weidu with tome of magic. I have more time these days (so far) than aquadrizzt, and I should be able to make the necessary changes for you.

Sign In or Register to comment.