Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Item Upgrade mod

Has anyone else experienced problems with Weimar's Item Upgrade mod? The mod correctly installs the items and the recipes work, but none of the dialog.tlk components seem to install properly. As such, I'm left with items without descriptions and the dialogue with Cromwell and Cespenar is all buggy (I get error messages and a code for where the missing dialog should be in the dialog.tlk file). Am I doing something wrong with my install? I've tried installing it both before and after installing the Tweakpack with the same results.

Comments

  • Rollingd20sRollingd20s Member Posts: 11
    It works fine for me. I did a normal install (Mac, Beamdog version) and received no error messages, and it works properly in game. Maybe a conflict with another mod? I have only unfinished business and tweaks installed in addition to item upgrade.

  • Saigon1983Saigon1983 Member Posts: 156
    Check weidu.conf file in the main directory of your game, I think there is different path from your language and patch applies to another dialog.tlk. For example, my language is russian, so my .tlk file is in ru_RU directory, and in weidu.conf also must be written "ru_RU", but if there will be "en_US", the patch will installs correctly, but in game I'll have no words or any description of mod's units

  • MusignyMusigny Member Posts: 1,027
    edited April 2015
    What is your weidu version ? (did it perform an auto-update ?)

  • Balsak_the_SweatyBalsak_the_Sweaty Member Posts: 9

    It works fine for me. I did a normal install (Mac, Beamdog version) and received no error messages, and it works properly in game. Maybe a conflict with another mod? I have only unfinished business and tweaks installed in addition to item upgrade.

    I have a W7 install and the only other mods I run are UFB, tweaks, and npckit. All of those run fine.

    Check weidu.conf file in the main directory of your game, I think there is different path from your language and patch applies to another dialog.tlk. For example, my language is russian, so my .tlk file is in ru_RU directory, and in weidu.conf also must be written "ru_RU", but if there will be "en_US", the patch will installs correctly, but in game I'll have no words or any description of mod's units

    weidu.conf has lang_dir = en_us
    Musigny said:

    What is your weidu version ? (did it perform an auto-update ?)

    I have weidu185 installed.

  • MusignyMusigny Member Posts: 1,027
    edited April 2015
    If you are playing with EE, you need a serious update.
    Get Item upgrade version 40 from here http://www.weidu.org/Weimer-ItemUpgrade-v40.exe

    weidu 185 ? This is weird : the BG2 tweaks comes with v236 for instance.
    If no other mods can update your old weidu version to v237/238, please consider downloading http://www.weidu.org/~thebigg/WeiDU-Windows-238.zip, extract weidu.exe and rename it to override your setup-itemupgrade.exe file.
    I used to select the "original list version" in both cases when installing the components but I no longer use it.
    Please let us know.

    BlackravenJuliusBorisov
  • Balsak_the_SweatyBalsak_the_Sweaty Member Posts: 9
    edited April 2015
    I had issues trying to download v238, but I was able to get v237. With v237, the mod appears to be working properly. Thanks for the help!

    MusignyJuliusBorisov
Sign In or Register to comment.