Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Full Plate and Packing Steel - a total conversion of the armour system, updated for BG:EE and BG2:EE

darleydarley Member Posts: 11
Some of you might remember Full Plate and Packing Steel for bg2/tutu/iwd by erik;

http://www.gibberlings3.net/fullplate/

It's a cracking mod and has been in my must install list for years. If you're not familiar with it, it completely redefines how armour works in the game. It flips the AC gradient on its head, making leather armour grant the lowest ACs and heavy plates the highest. It then gives all armour resistances to slashing, crushing, piercing and missile attacks, with the highest resistances going to plates, and leathers getting the lowest. tl;dr it makes both branches viable and no longer leaves thieves and other light armour wearers at a disadvantage, while also giving front line fighters a very different feel.

For example; a fighter in full plate would soak up roughly half the damage coming into him (armours do have holes to certain types of damage however, crushing for heavy plates). This is offset by the AC of only 6, meaning more attacks will be landing. The opposite is true of leather armour, you can dodge more but the resistances are much lower, and chains and scales sit somewhere between the two.

It gives combat a lot more realism which was something I always thought the d&d system lacked. Huge, slow moving front line fighters not getting hit while lightly armoured skirmishers would get creamed, and all getting hit for the same amount of damage to boot. Erik's mod addressed the issue perfectly and that's why it's been one my favourites for so long.


Full Plate and EE

It was semi compatible but certain aspects didn't translate, the new armours added by ee (magma plate and neera's rugged leathers) weren't picked up, only the mage spell Armor got patched, none of the others (this might have been an issue in bg2/tutu/iwd too due to a typo in a FOR loop), and (ironically) full plate armour didn't work. These should now have all been addressed.


Full Plate and Packing Steel v2.2

http://www.mediafire.com/download/726ji7jzgomi1vq/fullplate-v2.2.zip

!!! NOW UPDATED FOR SCS AND BG2:EE !!!

Just extract it to your main BG:EE directory, in my case 'C:\GOG Games\Baldur's Gate - Enhanced Edition' and run the weidu installer (which has also been updated to the latest version). If updating from 2.1 uninstall previous version first.


Stuff To Do

I finally got off my arse and learned how to work with weidu because I really couldn't be bothered to manually update the files using DLTCEP again, what with the likely raft of mod updates needed after SoD launches. This decision was all of 3 days ago so I'm still pretty rough around the edges but I don't think there'll be any issues with bg:ee and this updated 2.1 version. Very little extra code was needed, just a few small tweaks here and there.

Things I still want to look at though;

- Bug fixing - this is a first draft so report anything not behaving and I'll roll my head across the keyboard in an attempt to fix them as they crop up.
- SCS compatability - in the main it works fine, however some spells introduced to aid in SCS's pre-buffing magic users I'm pretty sure need to get their AC bonuses adjusted and resistances added. It's only a few though if I remember right and I'll look at this first.
- BG2:EE - it should work fine but again will need to be told about any new armours ee adds. It's pretty simple so won't take long (he says shifting nervously).
- IWD:EE - no idea as I don't actually own an ee copy of it. In theory it should be ok, it worked on the original fine (I think) but I'm not sure what's been changed when it was ported. In fact the more I think about it the more I'd bet it'll need many a working day spent on it. Report back anything if you like but this won't be a priority.
- SoD - I'd personally like to get the mod working with the upcoming expansion as soon as I can. I've no idea how that'll pan out so I'll deal with it when it comes up. No negative waves man.
- The minor components - I need to look to look at the two additional things the original mod provided, namely allowing multiple protection items to be worn at once, and a backstabbing for everyone module. The former is already picked up in other mods, Bg2 tweak pack is probably the most popular, and so I'll probably depreciate this at some point. The backstabbing I'm unsure about, I never used it and it doesn't really synergise with the armour conversion meat and potatoes. Unless there's lots of support for it, it'll likely eventually get shelved too.


Compatibility

The original was very compatible with other mods of its time and is probably fine with newer ones too as it patches files rather than overwrites them. Anything new that changes armour values or affect spells that create magic armours (armor, ghost armor, spirit armor, and barkskin) will be cause for concern though. Combine at your own risk. Read the original readme for further compatibility info too. Finally I'll reiterate what that readme says, install as close to last as you can manage.

I've not kept up with all the newer mods of the ee era, mainly just opting for updates of the oldies. I am Jack's raging pessimism. If my jaded outlook on life is unwarranted and there are some popular, good quality new offerings out there, and probably more importantly, you care enough about this update to want it to work with them, then let me know.



Finally I'd like to thank erik for making the thing in the first place. He last logged into g3 about a year ago but if he does ever read this, xoxo. Feel free to message me if you want to take the project back. I've really not done much at all so he's the man to be thanking.


Change Log

2.2 - Updated to support bg2:ee, and now fully compatible with SCS (pre-casting versions of certain protection spells needed updating).
2.1 - Updated to support bg:ee.

cognoscentusMaxxximusJuliusBorisovineth

Comments

Sign In or Register to comment.