Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[FIXED] BG2EE won't launch

PhyrekPhyrek Member, Mobile Tester Posts: 6
edited December 2015 in Troubleshooting
1. Launch the game from Steam
2. Windows error sound plays but no error shows up

Crash dump files
Filename: crash - BG2EE Error dmp files.rar (3.9 MB)
Link: https://mega.nz/#!LBR0SJzB!AVlP15nnCttFtT6T6Qh62i1t32CQzWrRDn2g48ZFILg

Observed
Game won't launch from the PC, however it does open if launched while connected remotely with a tablet.

Expected
The game launching properly from the computer and playing fine... or at least some error with info.


What I have tried:
-Checked the task manager and the game shows as running but it never starts.
-If I try to start it again it shows it is already running.
-If I end the task and retry I get the same problem
-Checked for video card updates and the computer was already running the latest version.
-Tried running the game on different compatibility modes, as administrator, screen resolution, disabled display scaling...
-Verified game integrity from Steam.
-Installed OpenAL from game installation files.
-DEP exception added.
-Probably some more stuff I don't recall right now.


The weird part: I was playing with my tablet and I connected remotely to the PC and tried to launch the game just for the heck of it, to my surprise the game actually opened. I ended the remote session and went to check the PC and the game was still running and didn't crash, so I tried to play with some of the in-game settings and tried to run it windowed, and I still get the same issue from the PC... it still opens if I launch it from the tablet's remote connection.


Some PC Specs
-Toshiba Satellite U300 laptop (yeah I know its REALLY old)
-OS: Windows 8.1 Pro
-Dual core 1.73 GHz
-2GB RAM
-200 GB HDD partitioned in two (first one for the OS, second one for docs and games)
-Intel GMA 965 series


Note: The computer came originally with Windows Vista, there are no driver updates from the manufacturer, I downloaded the latest supported version of drivers/software manually from each component's site (Intel, Realtech, etc). Every other game I use work perfectly (including similar games as Icewind Dale EE and BG1). I think this might be something related to the resolution settings as the game runs with no error when I am connected remotely with the tablet, I remember I fixed a game editing some of the resolution settings within the program installation files but I don't know if this is possible (or even necessary in this case) with this game.

Thanks in advanced for any help :)

BTW, I am copying this from what I submitted on the steamcommunity site as I haven't received a reply yet... I still need to add the game version (I'm at work and can't check it from here), let me know if anything else is missing. Sorry for being spammy!

Post edited by Phyrek on

Comments

  • GallowglassGallowglass Member Posts: 3,356
    Evidently the game runs, but is failing to show on screen at launch, so one has to think it's some sort of graphics problem.

    Since you have current drivers ... maybe as you suggest, something awry in the resolution settings, that's worth experimenting with ... or otherwise, I remember a time when I started having odd graphics issues (which initially affected only a couple of applications, other things still worked for a while), and it was difficult to pin it down, but eventually it turned out to be the graphics chip gradually failing.

  • PhyrekPhyrek Member, Mobile Tester Posts: 6
    I was able to fix the issue by myself after hours and hours of troubleshooting... surprisingly the fix was to DOWNGRADE the graphics card driver.... I hate computers sometimes...

    Gallowglass
Sign In or Register to comment.