Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

IWDEE: Orrick Inventory update

NervalNerval Member Posts: 10
Hello,

I'm running into troubles with Orrick (it seems that I'm not the only one?).

I never had any update on his store. I have finished Chapter 2, but I haven't yet traveled to the Severed Hand (Still in Kuldahar).

I tried the usual solution: CLUAConsole and Debug Mode.

For anyone that would like to try it (it may still solve your problem if you are affected):

Add the following lines to the Baldur.ini file (found on Linux at $HOME/.local/share/Icewind\ Dale\ -\ Enhanced\ Edition/Baldur.ini).

	'Program Options',	'Debug',	'1',
	'Program Options',	'Debug Mode',	'1',
Right after

INSERT INTO options ROWS (
It is important for these two options to be right after the INSERT INTO stanza. I ran into problems not doing it this way (the debug mode would not be activable). Another potential problem is that the game will overwrite the file for some unknown reason (it is for this reason that the Maximum Frame Rate is usually not changeable. The option works fine, the file is simply overwritten). To avoid it, one possible solution is to change the owner of the file, for example assign it to root. The downside to this is that any change of option made in game will be reverted when you quit your game.

Anyway, once the Debug Mode is active, type Ctrl + Space in game. A prompt should open.

First, type the following commands (exactly as is, with the same case, spaces, quotes, etc):

C:GetGlobal("UNIORRICK","2100"); C:GetGlobal("Chapter","GLOBAL");

At Chapter 1, UNIORRICK should be set to 0 I think. At Chapter 2 & 3, it should be set to 1. That's what I gathered from other threads on the subject, however I cannot be sure about it.

I ran into my first problem here: UNIORRICK was not set for me at any Chapter. So I set it to 0 while in Chapter 2, and at that point an option should activate in the dialog file of Orrick to add the new Inventory. I never got it.

If your values are not correctly set, you can modify them using the following commands:

C:SetGlobal("UNIORRICK","2100",0); C:SetGlobal("Chapter","GLOBAL",2);

Outside of Orrick's study. Go inside to see him, see if it activates the new Inventory, then revert back the Chapter to its original value.

I did exactly that, without success. My guess is thus that since I already visited Orrick, the new variable UNIORRICK is not taken into account. I don't know very well the save format of IE games, but I think it may be related to the fact that when you install a mod modifying an NPC, only NPCs that you would not have already visited would be modifyed. The one you've already seen will not be edited.

Maybe I can change something in my saves then ? Remove some overriding file ? I haven't found anything in EEKeeper.

I have only icewind_tweaks installed, with a few rule changes. No modification to NPCs. Some changes to items, to allow unlimited stacks of scrolls, this kind of thing. Maybe it messed up with the files ? It's been installed right at the start of the game (only launched a game, quit, then installed the mod).

Comments

  • NervalNerval Member Posts: 10
    Ok, I think I've worked it.

    At Chapter 2 or 3 (before you start 4! If Chapter 4 has started, set Chapter to either 2 or 3 and revert back after), you have to get out of Kuldahar (I have gone to the Vale of Shadows), set the Global UNIORRICK to 0; come back to Orrick and ask to see his wares.

    The whole area, Kuldahar and Orrick's tower, seems to be considered AR2100. It seems to be important, as the script that would add the inventory would execute upon entering the area.

    So, get out, set the variable, get in, check if everything is good.

    Another quirk: I could not see the value of UNIORRICK. The console only printed

    GLOBAL: UNIORRICK 2100

    So, the variable existed, but we could not read the value. It seems however that setting it was properly working.

  • a_wizard_am_ia_wizard_am_i Member Posts: 2
    edited September 24
    This is apparently still an issue as one of my saved games has the same issue.

    I check back with Orrick after starting chapter 3 (got to severed hand, then went back to Kuldahar) hoping to drop all my gold on a shimmering sash to find that it's not there. It's stuck with the initial set of items plus what I've sold him.

    Tried the above mentioned console commands but it didn't seem to do anything.

    Anyone have an alternate solution?

  • sarevok57sarevok57 Member Posts: 4,750
    for orrick's first round of goods, you can try these 2 commands ( just directly copy paste these lines )

    C:SetGlobal("UNIORRIK","AR2100",0)
    C:SetGlobal("Chapter","GLOBAL",2)

    this should open up the first shop upgrade, to get the second shop upgrade you can try these 2 commands

    C:SetGlobal("UNIORRIK","AR2100",1)
    C:SetGlobal("Chapter","GLOBAL",4)

    this should open up the second shop upgrade

    @Nerval i think some of your commas and whatnot were a little off, hence the reason why yours didn't work


    also another reason why your game might not be giving you the upgrades when its supposed to could be because if you have mods installed that affect the AR2100.bcs, although every once in awhile this used to affect me as well, but not anymore since the latest patch

    JuliusBorisov
  • a_wizard_am_ia_wizard_am_i Member Posts: 2
    Thanks.

    What ended up working was:

    C:SetGlobal("UNIORRIK","AR2100",1)

    then

    C:SetGlobal("UNIORRIK","AR2100",0)

    Then went back to Orrick and the items finally appeared.

    sarevok57JuliusBorisov
Sign In or Register to comment.