Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Not Enough Free Disk Space Error

MatthewMatthew Member Posts: 21
edited October 2012 in Windows PC (Archive)
So, got myself one of those all-in-one Sony Vaio TV/PCs recently and it has getting on for 3 TB of Disk Space. Of course, none of my old Infinity Engine games work right because the drive is too large for them to recognise (as I understand the problem). Basically, screen goes black when I try to run them, and then the error message comes up "Not enough free disk space to continue, shutting down". Tried a couple of solutions:

1) DIsk Cleanup - Games worked for a while, then stopped working. Further clean ups have no effect.
2) Setting the cache size to "0" in the ini file, no joy.

I do not really want to set up a partition in the drive or run the games from an external hard drive, though I realise those might be the only option in the end. All of the games run fine on my Sony Vaio laptop, so it is not a total loss, but still frustrating. Anybody have any other solutions for this?

Post edited by Matthew on

Comments

  • bigdogchrisbigdogchris Member Posts: 1,336
    edited October 2012
    Ignore the error and continue installing, leaving the cache at the default, then patch the game. Also set the compatibility mode to Windows 98. When you launch the game, you may also need to play with the Software BLT settings to get it to display right.

    Troubleshooting Guide

    Either way, this is the perfect example of why people should buy BG:EE The old/legacy code has been gutted and rewritten to support modern OSes.

    BenjaminKrypplingz
  • MatthewMatthew Member Posts: 21
    As I said above, this is not an installation problem, the games install fine. This is an issue with the games being unable to detect sufficient hard drive space for the cache when running. I am looking forward to the "enhanced" version, but in the meantime I want to find a solution to this problem, and unfortunately PlanetBaldur'sGate does not address it. Seems to me like the sort of issue that can be solved relatively easily, given that they do work from time to time. Thanks for your input, anyway.

  • bigdogchrisbigdogchris Member Posts: 1,336
    edited October 2012
    Did you do the full install (check all boxes), just to make sure it's not reading from the CD?

    Did you try the compatibility mode? Right click Baldur's Gate shortcut and click properties, then compatibility tab Try Windows 98, 2000, or XP SP2.

  • MatthewMatthew Member Posts: 21
    Yes. I have tried enabling every variation of the options in the properties menu, running the games as an administrator and so on, all to no avail. This is a fairly well documented issue for [i]Infinity Engine[/i] games with hard drives that have 2+ TB of free space. From what I can tell, the solution lies in figuring out why after a disk clean up the games suddenly start working, then stop working, and why further disk clean ups have no effect.

  • bigdogchrisbigdogchris Member Posts: 1,336
    edited October 2012
    I have read that stuff too, all saying to reduce the size of the partition.

    If you have Vista/7, the OS does have the ability to reduce the size of the partition down, then create a new one for the game, then eventually delete and extend your primary partition again. I know it's not optimal to do but it would probably fix the problem and is using all features built into the OS.\

    I've had to dual boot XP before just to get games to work right. I didn't want to do it but games built with Windows 95 code are just not going to work well in new OSes.

    Good luck!

  • MatthewMatthew Member Posts: 21
    No worries. At the moment they work fine from an installation into an external hard drive, so I am probably not going to bother with the hassle of partitioning up the main drive. Mind, the "fog of war" is being rendered a bit "blocky", but I think that must be a graphic card setting issue.

  • TagzTagz Member Posts: 1
    @ Matthew

    Try to go into the graphic options in the game and change it from 32 to 16 bit color this should give you a smoother fog of war!

  • MatthewMatthew Member Posts: 21
    Yeah, that was the first thing I tried, but to no effect, sadly. Must be some setting on the graphics card or else a side effect of running the game from an external drive.

  • OremusOremus Member Posts: 15
    Can you install a virtual machine such as VMWare Player or Virtual Box? These would let you run whatever operating system you want on your machine (no need for compatibility mode), set the hard drive size manually, install older and possibly more compatible drivers, etc. The game should then think that the hard drive space is smaller and not have a problem. I haven't tried that kind of thing in this situation, though.

  • MatthewMatthew Member Posts: 21
    I had not considered that possibility, might be a workable solution. Thanks!

  • MatthewMatthew Member Posts: 21
    This turned out to be a NVidia issue and was solved as follows:
    -Dazzle- said:


    Hi all,

    I managed to fix this problem for baldur's gate in vista by enabling software directdraw. Maybe it also works in XP and for other infinity engine games, I haven't tried. It'll only work for the 2d rendering engine (OpenGL mode won't work). After you've applied the fix, the game is very fast and without any artifacts. The fix is permanent. You don't need loader scripts or stuff like that.

    Here's how to:
    1. Download and install the microsoft application compatiblity toolkit:
    http://www.microsoft.com/downloads/details...;displaylang=en
    2. Start the 'Compatibility Administrator' with administrator rights.
    3. Click the 'New' Button
    4. Right click the new database. Select 'Create new application fix...'
    5. Name your program and vendor however you like. Browse to your bgmain2.exe file. Click next
    6. Select 'None' for operating system modes. Don't select additional compatibility modes. Click next
    7. Tick the 'ForceDirectDrawEmulation' compatibility fix.
    8. Click next and finish.
    9. Save your database.
    10. Right click the database and select install. This will install the database.
    11. Close the compatibility administrator and start baldur's gate. It should work correctly in 32bit mode without any ingame rendering fixes. You don't need to run the compatibility administrator again.

    http://www.shsforums.net/topic/30840-ie-games-and-nvidia-series-8-video-cards/?p=432892

Sign In or Register to comment.