Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Sword Coast Stratagems (SCS) threads

1235»

Comments

  • StummvonBordwehrStummvonBordwehr Member, Mobile Tester Posts: 941
    edited May 2019
    @subtledoctor and @ALIEN
    I fully agree. NEJ was fun, but buggy.

    But the grouping of the tactical mods was how it was in days of old. It was only when I registered here that I saw that there was more to SCS than bugs... I think improved anvil was in the same group of mods

    Post edited by StummvonBordwehr on
  • DanacmDanacm Member Posts: 854
    I tried to use atweaks improved fiends component with scs v32 cand10 but its not working. I tried before or after scs but there is an error message for scs tactical components.
    Are there any issues about that ? Because i really miss scs fiende allignement not match when gated.

  • StefanOStefanO Member Posts: 345
    The SCS 32RC10 readme states aTweaks and SCS aren't compatible regarding fiends.

    Danacm
  • DanacmDanacm Member Posts: 854
  • DavidWDavidW Member Posts: 817
    The difficulty I have is that aTweaks is designed to be installed after SCS - but it’s not being maintained,

    JuliusBorisov
  • DanacmDanacm Member Posts: 854
    DavidW wrote: »
    The difficulty I have is that aTweaks is designed to be installed after SCS - but it’s not being maintained,

    @DavidW other components from atweaks are usuable or all is out of date ?
    I really miss that thing, but than i may use spell revisions, as i remember it has similar fiends.

  • DanacmDanacm Member Posts: 854
  • DanacmDanacm Member Posts: 854
    High level mages use mantle type spells or absolut immunity, rather than pfmw ?

  • stargazerbstargazerb Member Posts: 57
    edited June 2019
    I get this error when trying to initialize AI (BG2EE):

    SFO: Cloning SPL file(s) SPWI807=>dw#sumfi and applying patch(es)...

    ERROR: Failure(" is not an integer, but one was expected") in apply_standard_function: inputs were func=parameter1, arguments=
    ERROR: [SPWI807.SPL] -> [override/dw#sumfi.SPL] Patching Failed (COPY) (Failure(" is not an integer, but one was expected"))
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    ERROR: [.../stratagems-inline/fiend_spl_table_sr] -> [weidu_external/workspace] Patching Failed (COPY) (Failure(" is not an integer, but one was expected"))

    And then it stops and offers to let me try again. I'm using v32, but I feel like the initialize AI part hardly ever works. Does anyone know how to fix this?

    Edit: Found a forum thread that suggested removing spwi707, 807 and 905. Now it's stuck at:
    ERROR: Failure("You are trying to edit %WIZARD_ACID_STORM_SCROLL%.ITM, which does not exist in the game")

    Post edited by stargazerb on
  • The user and all related content has been deleted.

    JuliusBorisov
  • stargazerbstargazerb Member Posts: 57
    I downloaded the new one just in case, and I got the same error as the first time, with SPWI807.spl.

  • Grond0Grond0 Member Posts: 6,868
    @stargazerb it sounds like you've got a mod conflict, possibly with Tome & Blood? You could try looking at the similar problem reported here to see if the proposed solution there helps.

    JuliusBorisovStummvonBordwehrstargazerb
  • The user and all related content has been deleted.

    stargazerb
  • DanacmDanacm Member Posts: 854
    Are there any reason to play scs bg2 with non mage class ? You forced to use a mage and other classes seems useless (maybe thief exception), in the light of pfmw, spell immunity and other cheesy spells. Absurd untouchable and relatively much mages in bg2.

  • [Deleted User][Deleted User] Posts: 0
    edited June 2019
    The user and all related content has been deleted.

    Post edited by [Deleted User] on
    Girewan
  • AasimAasim Member Posts: 591
    Danacm wrote: »
    Are there any reason to play scs bg2 with non mage class ? You forced to use a mage and other classes seems useless (maybe thief exception), in the light of pfmw, spell immunity and other cheesy spells. Absurd untouchable and relatively much mages in bg2.

    I never play my PC as a mage. I hate mages. I'm getting old. I like my PC to be a melee bruiser. If you want more balance for mages u can use Spell Revisions mod which slightly reduces their omnipotency. Or, don't use Wish for spell restoral; Project Image or Simulacrum spells, and don't stack multiple Spell Immunity spells. That alone will make mages feel much more balanced.

    StummvonBordwehr
  • DanacmDanacm Member Posts: 854
    I always missed feats like in dnd 3 pierce magical protection. :d

  • DavidWDavidW Member Posts: 817
    SCS assumes a full party and a reasonable amount of balance. I don’t recommend not bringing at least one (ideally more) arcane casters, but I also don’t recommend not bringing several frontline fighters.

    I didn’t design SCS for solo play but people seem to have soloed it successfully with non-arcane casters.

    If someone can confirm that the Tome and Blood conflict is with SCS v32 official release and not with an earlier RC, let me know and I’ll fix it. There’s no conceptual incompatibility with T&B here.

    StummvonBordwehr
  • stargazerbstargazerb Member Posts: 57
    Thanks for the help, @Grond0 and @subtledoctor. It looks like Tome and Blood was the issue. When I installed without it, it worked fine. Thanks for updating Tome and Blood! Next time I install (I'm getting a little burned out on this process), I try that version.

    Grond0
  • AasimAasim Member Posts: 591
    edited June 2019
    Sett wrote: »
    Stratagems has a lot of issues with spell mods - both technical (parsing errors) and mechanical (it's difficult enought to properly script the AI to use certain spells even when you do know exactly what that spell does). This includes T&B, aTweaks and, despite some acknowledgement of it's existence, Spell Revisions.
    Luckily I stumbled upon a "spell-revised" version of SCS somewhere on Github, that seems to be working just fine (with SR only).

    I'm pretty sure the version I uploaded I took down from public downloads almost a year ago, if not more.
    I don't know who uploaded this to Github. It's not being mantained.
    This was made by me for v28, it's v32 with SCS now - and it implements SR compatibility much better and in a much wider scope than this.
    Sett wrote: »
    Be aware that BWS is not happy with it (or aware of it's existence)

    Don't take this the wrong way, but given this I deliberaty took down from being available to public after DavidW returned to modding I'm not happy with it either and would appreciate this link taken down.

    Grond0[Deleted User]Mantis37
  • DavidWDavidW Member Posts: 817
    edited June 2019
    Please do not distribute unauthorized, outdated versions of my mods.

    Post edited by Tresset on
    elminsterJuliusBorisov
  • DavidWDavidW Member Posts: 817
    edited June 2019
    stargazerb wrote: »
    Thanks for the help, @Grond0 and @subtledoctor. It looks like Tome and Blood was the issue. When I installed without it, it worked fine. Thanks for updating Tome and Blood! Next time I install (I'm getting a little burned out on this process), I try that version.

    I'm interested in the 'acid storm scroll' issue, which someone else has reported. It appears to be from some combination of mods but I'm not sure which; if you have a chance, could you tell me what mods you were using (or, even better, post a WEIDU.log if you have one).

    EDIT: on reflection, I'm guessing it's Faiths and Powers?

    Post edited by DavidW on
  • [Deleted User][Deleted User] Posts: 0
    edited June 2019
    The user and all related content has been deleted.

    Post edited by [Deleted User] on
  • DavidWDavidW Member Posts: 817
    See G3 thread, but in short: there is code in F&P that would add Acid Storm without a scroll, and that code would trip up SCS, but it looks as if that code is never invoked. Given the G3 guest poster's comment, I think it's more likely to be Deities of Faerun. In any case, it's obviously naïve of me to assume that anyone adding a spell would add a scroll, so I'll check for it.

  • stargazerbstargazerb Member Posts: 57
    edited June 2019

    [/quote]I'm interested in the 'acid storm scroll' issue, which someone else has reported. It appears to be from some combination of mods but I'm not sure which; if you have a chance, could you tell me what mods you were using (or, even better, post a WEIDU.log if you have one).

    EDIT: on reflection, I'm guessing it's Faiths and Powers?[/quote]

    I don't have that weidu log anymore :-( But I can tell you the mods:

    Dungeon Be Gone
    Unfinished Business
    Item Revisions
    Item Upgrade
    Spell Revisions
    Rogue Rebalancing
    (Sometimes, but not that time) Shadow Magic
    Faiths and Powers
    Tome and Blood
    Might and Guile
    Scales of Balance
    Tweaks Anthology
    SCS

    I currently have that same install setup without Tome and Blood, and SCS worked (AI enhancements only). As subtledoctor guessed, I did not install IWDification, thinking that it was just another potential source of problems.

  • ThacoBellThacoBell Member Posts: 12,009
    The wolf of ulcaster is extremely rude.

  • mike123mike123 Member Posts: 2
    I want to quickly outline what process I went through to get what I think is a successful install of the mods I wanted, just in case it's helpful for anyone else.

    0. Install BG2EE from GOG
    1. Copy the install as a backup for the "vanilla" version of the game
    2. use Big Picture to install Ascension and Tactics stuff I wanted. (Bypasses weidu.org file errors I was getting)
    3. Install Sword Coast Strategems from gibberlings3 file.
    4. Receive error outlined in this thread.
    5. Copy spell files mentioned in this thread from my "vanilla" backup to override folder in my modded version of the game. In each case, I copied both the original (e.g. SPWI601) and the B version (e.g. SPWI601B).
    6. SCS install completed
    7. Installed Tweaks anthology
    8. Installed Weidu Item Upgrade
    9. Installed Jim Fixes
    10. Installed Dungeon-Be-Gone

    This appears to have worked just fine for all mods above!

    Gusinda
Sign In or Register to comment.