Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Beamdog Client - sign in fails

GallowglassGallowglass Member Posts: 3,356
As the subject title says.

The games are working fine, my login to the forums is working fine, I can sign in to "account settings" ... but the launcher/updater won't sign me in and reports failure for "unknown reason".

At the moment I don't need it, but as soon as the next patch comes out, then I'll be stuck!

I've tried re-downloading and re-installing the client, I've then tried forcing a sign-out and manually re-instating the password ... but no change.

Any suggestions?

Comments

  • elminsterelminster Member, Developer Posts: 15,990
    edited October 2016
    Not sure what you mean by you being able to sign in to your "account settings". Have you tried logging onto the the beamdog.com site? (as far as I'm aware its still a different login than what the forums use).

    JuliusBorisov
  • SlytherzSlytherz Member Posts: 45
    edited October 2016

    Elminster! I can relate to this exact problem the OP is experiencing. I contacted help desk with an in depth issue report and screenshot. I feel as though my explanation may have been horrible, as the solution was far from successful :(.

    To start, I can sign into the beamdog launcher np. It shows both of my purchased games, BG:EE and BG:EE2. It says both are up to date and ready to play! At the top of the launcher however, I have an error in bold yellow text that states, "Limited Connectivity, unable to receive product updates." "You are offline, click here to sign in" When I click that, it pops up with the small login panel and instantly disappears with no correction. So I thought what the heck, I will uninstall the games and download the Exe from beamdog site and install/update without the assistance of the launcher. Boom, When the exe opens and says thank you for your purchase...... Please sign in to download your product. When I sign in, I get a read error that states, "Verification failed for unknown reasons".




    Hope I have provided enough information for someone to assist me. Boo misses Minsc :(.

  • GallowglassGallowglass Member Posts: 3,356
    @Slytherz - yes! That's exactly the same error that I was getting, with the previously-working "Remember my password" and "Sign in automatically" options ticked.

    However, after re-installing the launcher and manually re-entering my address and password, it can't make the first successful connection to verify the account and therefore won't start the launcher at all, it just rejects the details at the sign-in box with the message "Sign in failed for unknown reasons".

    @elminster - yes, I can sign in successfully to www.beamdog.com. (That's where the launcher re-directs you if you ask to go to "account settings", which is what I meant in the OP.)

    Since I'm a direct customer (rather than Steam etc.), this means that I can no longer access updates or new products.

  • elminsterelminster Member, Developer Posts: 15,990
    Are you both running windows xp?

  • SlytherzSlytherz Member Posts: 45
    I am in fact using XP, yes! I never had a problem before though. In fact, the only reason I am concerned to begin with was a few weeks prior the launcher was indicating I needed to update to latest patches. (Shaman is new since I played last for example.)

    JuliusBorisov
  • GallowglassGallowglass Member Posts: 3,356
    @elminster - yes, same as @Slytherz.

    @ScottBrooks - aha! Thanks for that, all is now explained, and your change has got my launcher working again.

    Yes, I know XP is past its use-by date now, but so far it was working fine for everything I've wanted to do. I'll probably be switching to a new PC next year, so obviously I'll switch to a current Windows at that time ... which inevitably means that I'll then have to put up with the usual 3 or 4 years of o/s bugs before MS eventually reach a stable and reliable version of it.

Sign In or Register to comment.