Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Mac Sierra Settings Workaround

elminsterelminster Member, Developer Posts: 15,743
edited December 2016 in Troubleshooting
Unfortunately Sierra users have been experiencing issues with getting the settings to stick. Hopefully this workaround should provide a temporary solution to the problem.

Before proceeding please note the comment immediately below this post regarding the security implications of this workaround.

1. Open the terminal
2. Paste into it

sudo spctl --master-disable

3. Put in your password
4. Go to "System Preferences -> Security and Privacy
5. Click the lock at the bottom left and type in your password
6. Make sure "anywhere" is enabled




6. Launch whatever game this involves (BGEE, BG2EE, IWDEE)
7. Close the game
8. Open the terminal again
9. Paste into it

sudo spctl --master-enable

10. Go to "System Preferences -> Security and Privacy
11. (If necessary) Click the lock at the bottom left and type in your password
12. Make sure "Mac App Store and Identified Developers" is selected

You may now play the game and settings should remain what you set them at.

Note: Make sure "Mac App Store and Identified Developers" is selected after you go through these steps.

Post edited by elminster on
JuliusBorisovCrevsDaaklolien

Comments

  • SaltGordonSaltGordon Unconfirmed, Member Posts: 3
    Forgive my ignorance but what terminal are you opening? Where does one input
    sudo spctl --master-disable

  • tbone1tbone1 Member Posts: 1,949

    Forgive my ignorance but what terminal are you opening? Where does one input
    sudo spctl --master-disable

    Terminal.app in the computer's Application folder. Or /Applications/Terminal.app if you prefer.

    Launching it brings up a command-line terminal which some of us fogies used before GUIs were available. (And long after, too.)

  • subtledoctorsubtledoctor Member Posts: 10,103
    tbone1 said:

    Forgive my ignorance but what terminal are you opening? Where does one input
    sudo spctl --master-disable

    Terminal.app in the computer's Application folder. Or /Applications/Terminal.app if you prefer.

    Launching it brings up a command-line terminal which some of us fogies used before GUIs were available. (And long after, too.)
    I believe it's in /Applications/Utilities/Terminal.app

    lolien
Sign In or Register to comment.