Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Getting stuck during loading in BG:EE

Hello everybody i have a small but irritating issue, when i change map in BG:EE (vanilla version, no mods, with SoD, on PC) the game and my whole pc remain stucks for about 2 minutes, there is a way to fix this? Thanks for the support!

Comments

  • elminsterelminster Member, Developer Posts: 15,981
    Have you tried running the game using the alternative renderer option? (it's found under the graphics settings)

    lolienDrZazzersteinJuliusBorisov
  • DrZazzersteinDrZazzerstein Member Posts: 5
    elminster said:

    Have you tried running the game using the alternative renderer option? (it's found under the graphics settings)

    I tried that but nothing good...

    elminster
  • elminsterelminster Member, Developer Posts: 15,981
    What are your computers specs? Also do you have your graphics cards latest driver? (from the manufacturers website)

    DrZazzersteinJuliusBorisov
  • DrZazzersteinDrZazzerstein Member Posts: 5
    here are my specs: Operating system:
    Windows 10 64-bit
    Processor: AMD FX 8350
    Ram: 8,00 GB
    Graphics card: AMD Radeon R380
    I have both the latest driver for my graphic card and the latest update for Windows 10

    elminster
  • elminsterelminster Member, Developer Posts: 15,981
    edited January 2017
    I'm not sure then if there is anything that can be done then to address the problem right now.

    I do have some questions that might help narrow down the problem (at least on our end to get it fixed in the 2.4 patch).

    Can you attach a save from somewhere where you are getting this problem? (you can put it in a zip file and use the forums attach file feature). The save folder should be My Documents/Baldur's Gate Enhanced Edition/Save

    (or

    My Documents/Baldur's Gate Enhanced Edition/SODSave

    for Siege of Dragonspear saves)


    Can I assume this occurring both when you are traveling to places you have not yet explored and to places you have explored?

    So this is occurring when you move between locations on the world map, but not between say an outside area and a house? (so does it occur for instance when you are moving from the outside area of Beregost into a house in Beregost)

    (If you own BG2EE) Do you also have this issue there?

    DrZazzersteinJuliusBorisov
  • DrZazzersteinDrZazzerstein Member Posts: 5
    Sure, here's my latest save.
    You are right, this problem happens both in exlpored and not explored areas, but it happens also when i launch the game (but for less time, let's say about 30~ seconds).
    You are right also on your second point, the problem happens when i travel between locations on world map, but when i enter a location on that area (like a house, or a cavern) it works just fine.
    I can't say anything for Siege of Dragonspear or BG2EE, i still have to get there :)

    Thanks for the support.

    elminster
  • elminsterelminster Member, Developer Posts: 15,981
    edited January 2017
    Hmm... I'm not sure if this will make any difference at all. But you had a bunch of spell effects active in that save (hold effects involving what looks like basilisks). Anyways, its possible that (at the very least) this is slowing things down. Do you still get the issue with this save?

    DrZazzersteinJuliusBorisov
  • DrZazzersteinDrZazzerstein Member Posts: 5
    Yeah i did fight basilisks a little before, but i tried the save and nothing changed. I don't think that's the problem, i had this issue since the beginning when i coulnd't have many active effect :(.
    But i guess the problem it's on my end, i reinstalled the game and started a new game but i kept getting the same problem, so i tried the game on my old laptop and worked just fine. I guess i'll keep playing on it ^^"

    elminster
  • GallowglassGallowglass Member Posts: 3,356
    @DrZazzerstein - could there be some background process running on your new machine, buffering any large writes to the graphics chip for some reason? Conceivably a new security feature ... or maybe just something in the settings of the graphics driver.

Sign In or Register to comment.