Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Mac install of BG EE forgets option settings on restart

JetoraJetora Member Posts: 11
edited February 2017 in Troubleshooting
Hi all. I have an issue that I don't see addressed anywhere.

I have a native Mac install of BG II EE from GOG that runs beautifully.

I bought BG EE recently direct from Beamdog. On this install I had the problem of crashing on auto-save. I found the thread here that addressed that problem and solved it, as suggested, by manually adding a BG folder in the Documents folder. The crashing stopped.

I was able to play BG EE - sort of. I could change options in the game and play the game with my choice of options enabled, but the options reverted to default every time I'd restart the game. I contacted Beamdog support and they didn't have a solution other than to try installing through either Steam or GOG. So I got a refund from Beamdog. Since I'm already running a GOG install of BG II EE that saves options properly, I decided to go with GOG for BG EE.

The GOG install was flawless, and I'd thought everything was great, but realize now that I'm experiencing the exact same problem - that the Options revert to default when I quit and restart. The game also isn't recognizing any changes to the .lua file, so I can't access the CLUA interface.

I'm a bit concerned that the Beamdog install put something somewhere that I didn't get rid of before I did the GOG install, but I haven't a clue what.

Any ideas out there about why the Options aren't being saved to whatever file they need to be saved to, and how to resolve the problem on my machine?

It just baffles me that BG II EE works great, no problems with Options or the .lua or anything, yet BG EE is having this issue.

I'm running OS 10.10.5 on a MacBook Pro (13" mid 2010), 16G, NVIDIA GeForce 320M 256 MB


Edit to add: After doing some investigation, the .lua file in the Documents > Baldur's Gate - Enhanced Edition folder is getting replaced/overwritten with the default .lua file on each game restart, so anything written to the .lua during game play is overwritten/replaced the next time the game starts up. Other files in this folder are getting written to properly and not re-created each restart, that being exported characters and saves. I verified (I think) that the permissions on the .lua file and the BGEE folder are the same as for the BGIIEE .lua and folder, which does not re-create the default .lua file on each restart. So writing to this file works properly, but for some reason it's getting recreated on game start up. Does that help any in coming up with a fix or workaround? Thanks for any help y'all can offer!

Post edited by Jetora on

Comments

  • tbone1tbone1 Member Posts: 1,995
    edited February 2017
    Apple has made a few updates recently to improve security, among other things. (Hence the save issue.) These include some changes in the file system and permissions that, when you read about them, make sense. However, it does mean certain issues like this pop up.

    When I get a chance I'll look at the file structure pertaining to BG(1|2)EE; right now my wife is doing something for work and I'm restricted to the iPad.

  • JetoraJetora Member Posts: 11
    edited February 2017
    Thanks tbone1, have you (or anyone here!) had any free time to look into this?

    It's extremely frustrating, as the problem appears to be so simple - the .lua file in Documents is being written to, but not read from. Yet the game reads from and writes to the "save" files folder and the "characters" folder perfectly. Both of these are in the same folder as Baldur.lua.

    I've done everything I can think of to resolve this problem, including a clean reinstall, or as clean as I know how do to: First I archived my saves and character exports. Then I removed every file and folder with the name "beamdog" or "baldur" that I could find, including the com.beamdog files. I emptied the Trash and rebooted the machine just to be sure, then reinstalled both BG EE and BG II EE from the original downloads.

    Yet after all this the game continues to create a new, virgin Baldur.lua each time I start up the game, as if it doesn't even know the .lua is there, and instead launches with whatever the default settings are. I can go into the game and change the preferences, and those preferences are accurately written to the Baldur.lua. But when I restart the game, those preferences are promptly ignored, ad infinitum.

    I've actually made the problem worse, for now BG II EE is doing the same thing, whereas prior to my reinstalling everything, that game was saving Options and reading them back in just fine. *sigh*

    In step by step format:

    1. Launch Baldur's Gate EE or Baldur's Gate II EE.
    2. Go to Options and make changes to the user preferences. Change Graphics and/or Gameplay, doesn't seem to matter what preferences are changed.
    3. Play the game to verify that the new Options chosen are working. They are. (Play either a saved game or a new game, makes no difference.)
    4. Open the Baldur.lua file in TextWrangler and note that the preferences chosen are displayed in the Baldur.lua file. There will generally be as many as 100 lines of code in Baldur.lua at this point.
    5. Quit the game. Either save the current session or don't, doesn't matter.
    6. Restart the game.
    7. Note that all the Options have reverted to default values.
    8. At this point, do NOT change any preferences.
    9. Open Baldur.lua in TextWrangler and note that there are only a dozen or so (12 to 14) lines of code, none of which are user preferences.
    10. Rinse and repeat.

    If there's an option somewhere I can set, some file I can move, or some a command I can enter in Terminal, that will tell BG EE and BG II EE to read from their respective Baldur.lua file on startup I'm willing to try it, cuz these games are unplayable in their current state, not to mention wasting the purchase cost of these games and the time I've invested in trying to get them to work properly. Any ideas are greatly appreciated!

  • JetoraJetora Member Posts: 11
    Note to forum mods: Because I don't have the ability to update the trouble ticket I sent to Beamdog support (never given a link or password for logging into Zendesk) I'm updating this thread with additional information. If that's not an acceptable use of the Troubleshooting forum let me know and I'll stop. Thanks!

    I'm still searching for a solution to this issue, so instead of launching the game using the game file icon, I ran the Terminal app instead: Applications > Balder's Gate - Enhanced Edition > Contents > MacOS > Baldur's Gate - Enhanced Edition

    Screen shot of partial result:


    Note the line third from the bottom of the screen shot, outlined in red. It follows a whole string of files in the same folder as Baldur.lua that were scanned without error. Seems like that's a clue, but I know almost nothing about Unix (other than you can really mess up a system using super user ;) ) so I don't know what to make of it. It seemed significant so I'm posting it hoping it helps find the solution.

    Meantime, I'd love to remove all the BG related files and reinstall everything from the original downloaded installers and see if that makes a difference. My sliver of hope is knowing that my GOG install of BG II EE - the first Beamdog game I ever installed - worked beautifully before I added BG EE to my system (Beamdog version, if that matters). Can anyone identify what I'd need to do to guarantee a virgin install? It's important to note that I've deleted and re-installed these games from multiple places to see if an installer either caused or could resolve the problem, namely GOG, Beamdog, Steam, and as a last resort a (GOG) Windows version of BG EE using Crossover Mac.

  • JetoraJetora Member Posts: 11
    edited February 2017
    Update: I booted my mac from an old OS 10.8.5 system on an external disk, then installed both BG EE and BG II EE there (using GOG installers). Amazingly enough, both games read from the .lua just fine on that drive, so changes to Options aren't an issue with the games installed on that drive/system. I think I'm more confused than ever about why I can't get them to read from the .lua on 10.10.5, especially when BG II EE was working at one point. *sigh*

    I'm still looking for information on how I can do a clean install on my 10.10.5 system, specifically what files need to be removed so I can ensure a clean install like the one I did on the external drive. Any help with that is appreciated. Thanks.

  • WedgeWedge Member Posts: 3
    Not wanting to necro an old thread, but as of 2019 it looks like this issue is still present with no solution available. Is it a 10.10.5 issue?

Sign In or Register to comment.