Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Yoshimo Disappeared (known bug?) resummoned.....now reverted to day1?

Hello,

I've encountered what appears to be a very old bug. It's surprising to me how many boards I found with this issue that are many years old, yet I still encountered it myself. There also seems to be no real "fix" for it.

The bug I refer to is Yoshimo disappearing after I remove him from my party in chapter 3. He said he would be in the Copper Coronet, and despite how many people swear he 'should' be there, right by the door, no, he is not. As in other posts, I chose to side with Bodhi and this appears to be the cause of this old but unresolved bug.

The only workaround anyone suggested was to 'create' a new Yoshimo with the console. I finally got that up and running but now there is the issue that....Yoshimo now thinks we are in the first dungeon and has met me for the first time just now. Does this mean all of my relationship dialogue with him is just gone? Is there some console command to set him to remember the things he should remember? I don't know how much that actually effects anything in this game but it's disconcerting to say the least. It also updated my quest log as if I had 'just' met him and was still trying to escape that initial dungeon....

If anyone has any ideas on how to fix either issue (Yoshimo disappearing in the first place) or fixing his memory via the console or other means, I would be very grateful.

-Eriias

Comments

  • argent77argent77 Member Posts: 3,128
    I wouldn't say this is a bug. Yoshimo is scripted to disappear from the tavern when you side with Bodhi. I guess his role as a "guide" or observer isn't needed anymore in this case.

    You can "fix" it yourself if you don't like it. The relevant code can be found in AR0406.BCS and looks like this:
    IF Global("WorkingForBodhi","GLOBAL",1) Exists("Yoshimo") // Yoshimo !InParty("Yoshimo") // Yoshimo THEN RESPONSE #100 ActionOverride("Yoshimo",DestroySelf()) END
    Simply remove the whole block before you enter the tavern. You can use Near Infinity to open the script.

    ThacoBellEriias
  • EriiasEriias Member Posts: 34
    That's still really weird from a game perspective that it's not acknowledged at all. If it were meant to happen, there should be a journal update or something when you go to the tavern and he's not there when he should be. He shouldn't just vanish from the game's memory entirely.

    But thank you for your input. I'm /very/ bad with this kind of thing; what do you mean by "Near Infinity" and where can I find the file you mentioned?

  • argent77argent77 Member Posts: 3,128
    I agree, a journal entry or different dialog lines when Yoshimo leaves the party would be helpful.

    Near Infinity is a resource editor. Download link can be found there: https://forums.beamdog.com/discussion/30593/new-versions-of-nearinfinity-available/p1

    If you're playing an unmodded BG2EE, you can simply unpack the attached zip file into the override folder of your game (create the folder if it doesn't exist).

    JuliusBorisovEriias
  • EriiasEriias Member Posts: 34
    Ahh, ok. I am using the Tweaks Anthology, though, so I assume it'll be a bit more involved? I can take a look at their readme later.

    And if this is how the game is 'supposed' to work, then I guess I can just keep going. It just feels really janky. Oh well. In looking things up I got enough spoilers to know I'll be getting my favorite thief back somewhat soon anyway.

  • argent77argent77 Member Posts: 3,128
    I don't think Tweaks Anthology modifies this particular script in BG2EE.

  • EriiasEriias Member Posts: 34
    Oh it does? I must have missed that. Is there a component that will fix this for me? I must have skipped it because I didn't realize what it was at the time.

    Btw, I really appreciate you being so responsive. :) Really helps, turning something that was initially really frustrating into something interesting. So thank you!

  • EriiasEriias Member Posts: 34
    Woooo~ I fixed it! It worked just like you said. That felt fancy. Thank you very much!!

Sign In or Register to comment.