Skip to content

Server download packages and docker support

nivniv Member, Moderator, Developer Posts: 409
Hello folks,

find below the official server packages as a simple, very small zip download.

It's a universal zip that contains all three platform server binaries (Windows, Linux, and macOS). To use, unzip it into a directory of your choosing (about 350MB), and run the binary in bin/platform. It will use the same userdirectory as your client (on linux, that's ~/.local/share/Neverwinter Nights/).

STABLE

* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.34.zip 59MB, sha1: 3e02cddcea5d0ae82111a3038f14aef6c14d05d9

DEVELOPMENT

* (same as stable)

There is also a docker image at https://hub.docker.com/r/beamdog/nwserver/. The NWNXEE build also runs off this image. (If you do not know what either means, do not worry - just ignore this paragraph).

Archive

* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.33.zip 58MB, sha1: 27c13fb3833e5f676689e8c6b3ff27fdf646e529
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.32.zip 58MB, sha1: 19f9065f8b7cde4cc8aeb81f5d5741b539651002
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.31.zip 66MB, sha1: dae4145d733882456e8863fa7616bff72905d1f1
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.30.zip 61MB, sha1: 86f1363fd36cd83853716f8cbbdcf5545cec6068
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.29.zip 61MB, sha1: acdb71fed3b872eccd76828b2658fdd4819d1776
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.28.zip 61MB, sha1: 2528a30c00c996940d7e2d2689da3a4aff7e0996
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.26.zip 61MB, sha1: b9b8c33b619247145153e07e1243d22675ace963
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.25.zip 61MB, sha1: 2706e2bfb6f78f1b378c2141d6284c9b92dbcc17
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.24.zip 61MB, sha1: 092588487fc39efe98145be7422025bf9f3106b7
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.23.zip 61MB, sha1: d28a909884c6158852e59a17627d9647e29003d3
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.22.zip 61MB, sha1: 41a3b55c9db92f04bf297f023c7e8f98e11d5d16
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.21.zip 61MB, sha1: 77c0c8a138c8379eaa467886333b101b33c6be48
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.20.zip 60MB, sha1: 2951d858ac08bb7323d519ead43ecadf6ffe0e18
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.15.zip 60MB, sha1: 45a969664b00a714c2162446f60319dac37bdcdd
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.14.zip 60MB, sha1: 584f924b190fe109056c743d38a1488fc2c9c684
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.13.zip 50MB, sha1: aabb852907e5d2acb46836226592a58463aaabbf
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.12.zip 50MB, sha1: a39cb8899e27841eb8bb3d0e13aaca2fdd47b9e6
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.11.zip 50MB, sha1: cebf4ee1ea6aecc9bdcc444ef7457fd2ce7bc7b9
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.10.zip 50MB, sha1: eec561f63d9e344d63e96763e485432a9c763264
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.9.zip 50MB, sha1: 24c2514c23c513fd0e07979fd6e244ac6314e3d9
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.7.zip 50MB, sha1: fffcdbb18579c93deac0e1ea60434f1a29ff9685
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.6.zip 50MB, sha1: 862017d16d71cc3f72f72e6b6cd44686d354f736
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.5.zip 50MB, sha1: 90affe1c8064965944f42990673c2fb3e7a10a7f
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.4.zip 50MB, sha1: 2e74d5c8791aff29ffe9033c031980f9fe6b63af
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.3.zip 50MB, sha1: 7be8303d8bfe4a2bd7680b16ddf2cf4e42f4bf3c
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.2.zip 50MB, sha1: 575b65f1b2ce0a6b4dbf5c3d34080f74eb8adc9c
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.1.zip 50MB, sha1: 68808daaf65879c55d9fa49cd7315c0722ad4617
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8193.zip 43MB, sha1: e620390262528e44a2232400da959cbf9b63af71
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8188.zip 40MB, sha1: 9eedbfe9f8ceb353589876d5b20e986a036b9aab
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8187.zip 39MB, sha1: ad378c63f4700a4d3716425f9d96641609ad8c6d
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8186.zip 39MB, sha1: 63d143f93feb1f7bc76a304ebfb5a819c43b96db
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8185.zip 39MB, sha1: b2b413686b250ac9e670ba717766445ee9543d0e
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8184.zip 39MB, sha1: d7e21e7b6f28f9e3eb630658255fdc5b2209747e
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8183.zip 39MB, sha1: 2840ea4bf26a829b56c838d3a9b69c1952a47ff1
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8182.zip 38MB, sha1: b495b83d2279c966fbc94eca48b2570cc20f76b2
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8181.zip 36MB, sha1: 974853b84f1095baa05fd1e13d6b09a255a0cbad
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8180.zip 36MB, sha1: f99f406a6fe4cbb0d4d13332422b06f18b747b70
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8179.zip 25MB, sha1: ad80369a17fdae52d5507bec60fedfcad2ff132c
* 8178 packages were skipped
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8177.zip 25MB, sha1: b84155e015c136b42e481d45502dd5f3ae1ca921
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8176.zip 25MB, sha1: bf1e83fde651b7e5b4babb10eafc4318afee3797
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8175.zip 25MB, sha1: 89a75437823c0fbb79aa0df65e4b640bcdfcffe8
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8174.zip 25MB, sha1: 33e9ce2d1d9dc2600c4aaa0ed870ea7c728a0cf2
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8172.zip 25MB, sha1: 7fcd5566c55070c05adddb98851ff93fa1414378
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8171.zip 25MB, sha1: 979850b072122cf08921187d2d6804a11a8d8cd4
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8170.zip 25MB, sha1: be2d46c9657f5df5674a1522782f5628639d64a1
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8169.zip 25MB, sha1: c9393f4a434b8a712b50d8df05cda0454f66f096
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8166.zip 25MB, sha1: 63184305a77aac593d33d43218759aea286b4697
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8164.zip 25MB, sha1: 6cfd807b38e26e25c071675688020547d4441792
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8162.zip 25MB, sha1: 7a1d60e476bd7a134417a5f0f84167c2888a632a
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8159-1.zip 25MB, sha1: 6d60f39e586f8ffdf2e458999850574158921138
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8159.zip 25MB, sha1: 25a1c4ead51c8b24deed673df0108d443f7abf4e
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8158.zip 25MB, sha1: a2eaca1200ffaeb38927b1bc656838a221d410e1
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8156.zip 25MB, sha1: f1dca9192625daa81a8de3dd6ca59b95b4998005
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8155.zip 25MB, sha1: 9c30b55580120d7849d0c8f16da375d431098545
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8154.zip 25MB, sha1: af0b507a74589b7b6a1528a274c2cebc63598a0a
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8153.zip 25MB, sha1: 0c0f88950c2cc2cb4420c68a075e4544df8567e6
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8152.zip 25MB, sha1: e4ab06586866bd08ae00ee34bea63f9bba64f927
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8150.zip 25MB, sha1: 37bd830f961057062e5be3acc6b3fe8bc4e54e7c
* https://nwn.beamdog.net/downloads/nwnee-dedicated-8149.zip 25MB, sha1: ad736767135a0473d3f706bb8f9f30e63dbfa6d3
Post edited by niv on
zunathFlashburnJuliusBorisovscruffyladKenjidunahanNecroGalo
«134

Comments

  • Chris_theVikingChris_theViking Member Posts: 49
    thanx!!!
  • Chris_theVikingChris_theViking Member Posts: 49
    I hope the timing of this doesn't indicate you've been up all night getting this out. if so then a... GET SOME SLEEP...
  • nivniv Member, Moderator, Developer Posts: 409
    edited November 2017
    I woke up at 9, made coffee, sat down and repackaged the relevant data into a zip. Still, it's saturday, so I'll take the compliment. ;)

    More technical stuff; in case anyone is interested, the slim data set is built with this: https://github.com/niv/neverwinter_utils.nim/blob/master/src/nwn_resman_pkgsrv.nim

    You can see the exact restypes that go in: only the bare necessities. Hence it's so small.
    zunathChris_theVikingJuliusBorisovdunahan
  • RiceyRicey Member Posts: 9
    @niv that's great work - I just uploaded the whole install from the client to my server and ran it - nowhere did it say it was 32bit only - but of course it is! So after some :i386 libs installed later it was up and running fine ;)

    I'll give your .zip a go later.

    As for Docker, I'm not a fan in the case of running a dedicated server - they don't play well with OpenVZ or LXC containers.

    Cheers
  • hda_nwnhda_nwn Member Posts: 27
    edited November 2017
    I tried to run it in Windows Server 2012 R2 and got some errors. Then I execute with admin rights and Windows 7 compatibility and no more errors.

    Edit: Tried to login and nw server crashed.
    Edit2: Tried again and now I am in. TY for the server package
    Post edited by hda_nwn on
  • GlorwingerGlorwinger Member Posts: 41
    If you want some help with Docker-izing the server on all platforms - I am experienced with Docker containers having deployed software for clients on Linux and Windows. I have used containers on premises and in the cloud and have used both Docker Swarm and Kubernetes. I know the server doesn't necessarily need that level of management but creating Compose files and Dockerfiles that allow for adding in NWNX, Starting MySQL etc. could be helpful.
  • GlorwingerGlorwinger Member Posts: 41
    @niv - I created a simple docker-compose.yml file to manage all of the docker options - however while the instructions say to create the hak, modules, and tlk folders - the docker image fails to start when they are pre-created. The other folders that are created (database, override, portraits, etc. do not cause the same issue if they exist before the container is started.

    Is this an issue inside the server itself or part of the docker build? I am going to take the standalone versions you provided above and create another Docker image to see if I can correct this issue.

    docker-compose up
    Creating network "nwnserver_default" with the default driver
    Creating nwnserver_nwnserver_1 ...
    Creating nwnserver_nwnserver_1 ... done
    Attaching to nwnserver_nwnserver_1
    nwnserver_1 | [*] Linking in user home
    nwnserver_1 | '/nwn/run/database' -> '/nwn/home/database'
    nwnserver_1 | mkdir: created directory '/nwn/home/hak'
    nwnserver_1 | '/nwn/run/hak' -> '/nwn/home/hak'
    nwnserver_1 | mkdir: cannot create directory '/nwn/home/modules': File exists
    nwnserver_nwnserver_1 exited with code 1
  • GlorwingerGlorwinger Member Posts: 41
    OK so a few things... My error above is I was using symbolic links for the modules, hak, and tlk folders and the script in the image is checking for a directory not a link and failing... it might be a suggestion to look for either.

    I was also able to run the Docker container without using the --net host command line option by exposing both the TCP and UDP ports as such

    docker run --rm -it -p 5121:5121 -p 5121:5121/udp -e NWN_PORT=5121 -v $(pwd):/nwn/home beamdog/nwserver:8149

    I did see it attempting to register in the Master server - but I don't have firewall ports open for the proper port ranges.

    Is there a list of ports that need to be opened through a firewall for the Master server connection?
  • KaltripKaltrip Member Posts: 18
    Is there an intention to provide a 64 bit version of the linux server at some point? Having to install and use 32 bit compatibility libraries is manageable but seems a bit of an unnecessary extra step.
  • TrentOsterTrentOster Administrator, Developer Posts: 433
    64 Bit is a goal, but to do it we'll have to port the entire codebase up to 64 bit ( much of it was written pre-2000). This was a bit painful for the Infinity Engine games, it should be less so with NWN due to the cross-platform support keeping us more honest in variable sizing and declaration. It will take development and testing time to complete.
    Symphony
  • JimbobslimbobJimbobslimbob Member Posts: 206
    Just wanted to throw out my initial testing on the dedicated server myself...

    It all ran fine and setup was a breeze. Infact, the dedicated server interface itself is exactly as I remember it. I had to copy over modules and other data from my headstart version of the game to the "data" folder and then it ran fine.

    It's nice to see the multiplayer server browser back in action and I was pleased to see that there are already a number of servers up with decent populations. I noticed I had to create a multiplayer "name" when entering the server - I gather this is a remnant of the old Bioware account system that no longer exists.

    The server vault is changed (I did read on that). All well and good, but impossible to see who each folder relates to by just glancing at it. I know one work-around is to get each player to create a "dummy" character on there with their name, but perhaps we could get the server to create a simple text file in each players folder with their multiplayer name as the filename? Would help a lot.

    I also tested it out with my Game Server Manager - which I have been adding to over the years and it all seemed to work fine with it. No server querying, mind. For those that are interested, it's a program made to do a number of things to make managing a game server easier and works with pretty much any game (to certain degrees). Those that are interested can download it on my site, here: http://www.jimbobslimbob.com/filescat.asp?cat1=Programs&cat2=Utilities

    Actually, now that I mention it, the other utility I made that could be of use is my NWN Bic (Character) Organiser, which works with both NWN 1 and 2 and is useful to server operators to quickly view, backup, move and archive characters. Perhaps with the EE edition on the way I may go back and do some additions to it. Link (at the bottom of the page): http://www.jimbobslimbob.com/filescat.asp?cat1=Games&cat2=Neverwinter Nights 2

    ...blimey. I didn't actually intend this post to be as long as this or to be a shameful plug at some of my stuff, so sorry about that. Still, some may find some use in them anyway.
  • SalvanusSalvanus Member Posts: 43
    This may be a stupid question, but what is the point of using this over the NWserver program that comes with the NWN:EE install?

    I'm using this to host my old PW but I cannot see it in the server list, however I can direct connect to it using the IP shown on the NWNserver program. Does anyone have any idea why it isn't listing? I forwarded port 5121 in Windows 10 as well.
  • TheGmorkTheGmork Member Posts: 37
    When I tried to direct connect to my server I get the message that the server and client versions do not match. I tried the update instructions for the docker, but no dice. I think I probably messed it up myself, but not sure.
  • TheGmorkTheGmork Member Posts: 37
    Never mind, it was my noob level 10000 that was the problem. Thanks to @Gorgon for pointing me in the right direction
  • JimbobslimbobJimbobslimbob Member Posts: 206
    @niv Any chance of an 8151 dedicated server package, as per the recent game update?

    On a related note, when the game hits Steam, will we get a separate download (preferably under a different appid) for the dedicated server client so we can update via SteamCMD?
  • nivniv Member, Moderator, Developer Posts: 409
    8152 added. Didn't do 8151 since it was a very tempoary, broken little thing.
  • SalvanusSalvanus Member Posts: 43
    8152 is showing a client/server mismatch with today's patch...is there any way to just get NWserver working without having to download the entire game to my dedicated server?
  • JimbobslimbobJimbobslimbob Member Posts: 206
    edited December 2017
    Salvanus said:

    8152 is showing a client/server mismatch with today's patch...is there any way to just get NWserver working without having to download the entire game to my dedicated server?

    Is this still true? Was hoping to get my server updated tonight.
  • nivniv Member, Moderator, Developer Posts: 409
    The zip contains the 8152 binary. Make sure your client is also 8152 (it says so in the title bar).
    JimbobslimbobJuliusBorisov
  • JimbobslimbobJimbobslimbob Member Posts: 206
    Thanks @niv, I will try it out.
  • GlorwingerGlorwinger Member Posts: 41
    For those that want the latest 8152 Docker server image (non-NWNX until NWNX is updated) it is available here (with links to the Dockerfile that created it for information) https://hub.docker.com/r/kmsheehan/nwserver/ docker pull kmsheehan/nwserver:8152.i386
  • JimbobslimbobJimbobslimbob Member Posts: 206
    edited December 2017
    @niv - yeah the latest 8152 package is not working - it's displaying as 8150 still (and yes I did overwrite the existing files).

    Additional info - the Win32 executable is dated 4 December 2017.
  • nivniv Member, Moderator, Developer Posts: 409
    So sorry. Let's never speak of this again. Package updated.
    Jimbobslimbob
  • JimbobslimbobJimbobslimbob Member Posts: 206
    ;)
  • narcissuslairnarcissuslair Member Posts: 12
    What are the firewall port/protocol requirements?

    Also can we get the complete list of commandlines with explanations?

    Thanks,
    Narc
  • JimbobslimbobJimbobslimbob Member Posts: 206

    What are the firewall port/protocol requirements?

    Also can we get the complete list of commandlines with explanations?

    Thanks,
    Narc

    I did a complete guide over on Steam that may help: http://steamcommunity.com/app/704450/discussions/0/2549465882919514491/
  • TsaisTsais Member Posts: 11
    I have the server running on a Linux virtual machine, but can't figure out how to connect to it from Windows. With the 'old' NWN, I could see the game listed under "Join LAN game" in the client, but that connection option isn't in the new version. Trying to direct connect to 127.0.0.1:5121 doesn't work for me. Am I missing an obvious step?
  • JimbobslimbobJimbobslimbob Member Posts: 206
    @Tsais 127.0.0.1 is the loopback address. Try connecting to the Server VM's local IP instead. Also ensure it is set to public if you want it listed in the server browser, along with correct port forwarding and allowing through any firewalls you may have.
  • narcissuslairnarcissuslair Member Posts: 12
    Thanks Jimbo! Nice guide.

    I was able to connect to my server. Had to use Jimbos guide plus the following link:

    http://www.neverwinternights.info/dedicatedserver.htm
    http://nwn.wikia.com/wiki/Dedicated_server

    I also had to make changes to the Azure NSG and the local windows firewall on the Azure VM.

    It would be nice if beamdog/moderators could compile a comprehensive list of all of the old/new NWServer settings, files, and values. Point me there if its already up.
    Tsais
  • JimbobslimbobJimbobslimbob Member Posts: 206
    Cool, thanks. Hope you got it working in the end. Both the links you mentioned there I did actually link to in my guide as well.
Sign In or Register to comment.