Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Not sure where to put this, but here I go: I can not acces to the CLUA console

Hi there guys

I've been reading every single pice of info about activating the console and I got nothing but frustration.

I've fund the file (Baldur.lua).
I've add the line: SetPrivateProfileString('Program Options','Debug Mode','1') ; at the line 33.
I've saved the file and run a game normally.

But not matter if I press control+space or cmd+space, nothing happens.

The game version is 2.3.67.3 and I'm running Mac OS 10.13.2

Any clues?

:(

Comments

  • DoubledimasDoubledimas Member, Moderator, Mobile Tester Posts: 982
    It could be me, but isn't the Mac version of the game still 1.3?
    In that case you would need to look at step 1 in this thread.

  • ArunsunArunsun Member Posts: 1,513
    Make sure that you all your instances of BG (and everything that is Beamdog-related) are closed when you make the modification. These config files usually require the game to be closed to properly save.

    Alternatively, install the "hidden gameplay options" mod. It will display that option in game.

  • MrMojoyoyoMrMojoyoyo Member Posts: 5

    It could be me, but isn't the Mac version of the game still 1.3?
    In that case you would need to look at step 1 in this thread.

    Sorry, I forgot to say I’m running BGIIEE
    Arunsun said:

    Make sure that you all your instances of BG (and everything that is Beamdog-related) are closed when you make the modification. These config files usually require the game to be closed to properly save.

    Alternatively, install the "hidden gameplay options" mod. It will display that option in game.

    I’ll try to test it tonight

    Cheers!

  • tbone1tbone1 Member Posts: 1,827

    It could be me, but isn't the Mac version of the game still 1.3?
    In that case you would need to look at step 1 in this thread.

    It is if you get it from the Apple store. If you get it from Beamdog it's 2.something.

    Doubledimas
  • MrMojoyoyoMrMojoyoyo Member Posts: 5
    tbone1 said:

    It could be me, but isn't the Mac version of the game still 1.3?
    In that case you would need to look at step 1 in this thread.

    It is if you get it from the Apple store. If you get it from Beamdog it's 2.something.
    What do you mean? I get it from Steam, no the Apple Store

  • BorekBorek Member Posts: 314

    tbone1 said:

    It could be me, but isn't the Mac version of the game still 1.3?
    In that case you would need to look at step 1 in this thread.

    It is if you get it from the Apple store. If you get it from Beamdog it's 2.something.
    What do you mean? I get it from Steam, no the Apple Store
    You need to check which game version you have because Version 1.3 or sooner require editing the Baldur.ini file, version 2.0+ changed it to Baldur.lua file. In both cases you need to edit without the game being open as it will over-write when you close the game with the original unedited version. On top of that you need to make sure that the file and/or folder have not been set to read only so that they can be changed.

  • MrMojoyoyoMrMojoyoyo Member Posts: 5
    Ok guys,

    first of all: thanks for your help but it is not working.

    As I said previously, I was running BGIIEE v2.3.67.3 on macOS 10.13.2

    Now I have updated BGIIEE to v2.5.10.0

    I have added to my file Baldur.lua the string SetPrivateProfileString('Program Options','Debug Mode','1')

    Then saved and checked if the file were properly modified, and it was.

    But, for some reason, nor (left) ctrl+space o cmd+space get me anything else than pause the game.

    PD: I was not able to install the "hidden gameplay options" because I need to run an exe and I'm not able to run it :(

    may this be the end of the road? :|

  • motmot Member Posts: 1
    edited January 4
    Running BG2EE 2.3.67.3 on macOS 10.13.2 and the console works flawlessly with Control-Space.

    The exact line in Baldur.lua is:
    SetPrivateProfileString('Program Options','Debug Mode','1')
    
    The position of the line doesn’t matter. (Unless you have another line in the lua file that revokes the Debug Mode.)

    Make sure to edit the file with a text editor (e.g. BBEdit, TextMate, etc.), not with a word processor (MS-Word, Pages, etc.). You can also edit it with Apple’s TextEdit, just make sure to save the file not as Rich Text.

    Attention with the OS’ smart quotes replacement: you need straight single quotes (''), not the curly ones (‘’).

    And, as others already have said, quit BG before editing the lua file.

    PS:

    And yes, it also works with the Steam version. (I’m currently playing the Steam version.)

    Post edited by mot on
Sign In or Register to comment.